النتائج 1 إلى 12 من 12

الموضوع: Eigrp dual line المساعدة ياشباب

  1. #1
    عضو
    تاريخ التسجيل
    Apr 2008
    المشاركات
    124
    معدل تقييم المستوى
    0

    Exclamation Eigrp dual line المساعدة ياشباب



    السلام عليكم ورحمة الله وبركاته

    عندى مشروع جديد ومطلوب أن يكون عندى خطين ربط (2) بين كل فرع و المركز الرئيسى و أن يكون
    1- خط ينقل عليه البيانات فقط
    2-الخط الثانى ينقل عليه الصوت voip فقط

    وبعد ذلك يكون كل خط backup للخط الثانى بحيث أن لو خط رقم 1 حدث به مشكلة يتم نقل البيانات و الصوت على
    الخط رقم 2 وتكون الاولوية للبيانات وكذلك بالنسبة للخط رقم 2 وفى كلا الحالتين اذا حدث مشكلة فى خط تكون الاولوية الى نقل البيانات

    وبالنسبة الى البروتوكول المستخدم هو Eigrp

    الجزء الثانى هو :
    كل خدمة (نقل البيانات , الصوت ) يجب أن يكون لكل منهما AS مختلف بحيث ان AS 1 يكون خاص بالبيانات ---
    AS 2 يكون خاص بالصوت

    *- الان نريد أن نضع Backup line داخل كل AS بحيث اذا حدثة مشكلة يتم الاعتماد على الخط الثانى .

    الذى أفكر فيه ان أقوم بوضع ip address الخاص بكل وصلة serial أو خط الربط داخل كل AS . مثال
    eigrp AS 1
    network 192.168.1.1 -> النتورك الداخلية
    network 172.30.1.1 -> الوصلة الخاصة بالبيانات
    172.30.2.1 network -> الوصلة الخاصة بالصوت

    eigrp AS 2
    network 192.168.2.1 -> النتورك الداخلية
    network 172.30.1.2 -> الوصلة الخاصة بالبيانات
    network 172.30.2.1 -> الوصلة الخاصة بالصوت

    الان يكمن لجهاز Router أن يصل الى كل من 192.168.1.1 - 192.168.2.1 --- عن طريق
    172.30.1.1 , 172.30.2.1 --- 172.30.1.2 , 172.30.2.1 ---- الان هل هذا الحل صحيح انا لا اريد ان استخدم سعة الخطين مع بعض لا , لكنى اريد أن اضع افضلية الى نقل البيانات على الصوت

    وهل يوجد حل أخر (ارجوا المساعدة )





  2. #2
    عضوية جديدة الصورة الرمزية dfash
    تاريخ التسجيل
    Apr 2009
    المشاركات
    6
    معدل تقييم المستوى
    0

    رد: Eigrp dual line المساعدة ياشباب

    حل خاطئ
    ----
    لا اله الا الله عدد ما كان، لا اله إلا الله عدد ما يكون، لا اله الا الله عدد الحركات والسكون، سبحان الله و الحمد لله و لا اله إلا الله و الله أكبر ، و لا حول ولا قوة إلا بالله.
    اللهم صلي وسلم وبارك على نبينا وحبيبنا محمد وآله الطيبين الطاهرين وصحبه أجمعين ، سبحان الله و بحمده عدد خلقه ، و رضا نفسه و زنة عرشه و مداد كلماته

  3. #3
    عضو
    تاريخ التسجيل
    Apr 2008
    المشاركات
    124
    معدل تقييم المستوى
    0

    رد: Eigrp dual line المساعدة ياشباب

    اخى الكريم اريد فقط ان اتاكد منك ثانية هل أعمل على policy map
    أو على traffic-shaping

  4. #4
    عضو
    تاريخ التسجيل
    Apr 2008
    المشاركات
    124
    معدل تقييم المستوى
    0

    رد: Eigrp dual line المساعدة ياشباب

    اخوانى الكرام ارجوا المساعدة فى هذه المشكلة حيث انى اجد بعض الصعوبات فى تنفيذ هذا الطلب
    ارجوا من لديه حل ان يساعدنى وشكرا لكم

  5. #5
    عضو
    تاريخ التسجيل
    Apr 2008
    المشاركات
    124
    معدل تقييم المستوى
    0

    رد: Eigrp dual line المساعدة ياشباب

    ئلا يوجد من يساعدنى فى هذه الحالة ولو بمعلومات بسطية المشكلة فقط انى اريد من يعطينى اول الخيط للحل فقط
    وشكرا لكم

  6. #6
    عضو برونزي الصورة الرمزية Nightspy
    تاريخ التسجيل
    May 2007
    المشاركات
    1,573
    معدل تقييم المستوى
    12

    رد: Eigrp dual line المساعدة ياشباب

    تحدى جميل

    ان شاء الله هشتغل معاك فى المشروع دة

    مع انى مش ابو العريف بس هحاول

    لما اجى من الاكاديمية ان شاء الله هبداء شغل فيها
    [SIZE=1][B][B]..||..[/B][/B][/SIZE][SIZE=1][B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=125858"]حمل جميع محاضرات احمد نبيل R&S من رفعى[/URL]..||..[/B][/B][B][B][COLOR=Red][URL="http://www.arabhardware.net/forum/showthread.php?t=119516"]شرح IS-IS[/URL][/COLOR]..||..[/B][/B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=108310"][B]شرح IPv6,OSPFv3 [/B][/URL][B]..||..[URL="http://www.arabhardware.net/forum/showthread.php?t=108310"].[/URL][/B][/B][URL="http://www.arabhardware.net/forum/showthread.php?t=100662"][B]شرح كامل للOSPF[/B][/URL][B][B]..||..[/B][/B][URL="http://www.arabhardware.net/forum/showthread.php?t=91625"][B]حصريا شرح الEigrp[/B][/URL][B][B]..||..[/B][/B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=93682"]كن خبير لتحليل ترافيك شبكتك مع شرحWireShark[/URL][/B][B][B]..||..[/B][/B][URL="http://www.arabhardware.net/forum/showthread.php?t=94484&highlight=iptv"][B]مقال عن تقنية الIPTV[/B][B][B]..||..[/B][/B][/URL][B][URL="http://www.arabhardware.net/forum/showthread.php?t=93854"]جميع اوامر الروتنجIOS[/URL][/B][B][B]..||..[/B][/B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=94813"]أفضل برنامج لرسم وتخطيط الشبكات وبدون تنصيب[/URL][/B][B][B]..||..

    [/B][/B] [URL="http://badr-call-manager.blogspot.com/"][IMG]http://muslimtech.files.wordpress.com/2010/06/blog-badr-banner.jpg[/IMG][/URL]
    [URL="http://mohammad.islamway.com/"][B]سيرة أشرف من مس هذا الكوكب بقدمه وبجميع اللغات[/B][/URL]

    [/SIZE]

  7. #7

  8. #8

  9. #9
    عضو برونزي الصورة الرمزية Nightspy
    تاريخ التسجيل
    May 2007
    المشاركات
    1,573
    معدل تقييم المستوى
    12

    رد: Eigrp dual line المساعدة ياشباب

    شوف يا محمد انا كل دة وانا بحاول اعمل Lab عشان اطبق منه واتاكد من حاجة فى دماغى

    لاكن الواضح عندى ان هيكون فى شوية مشاكل لان محتاج اقوم اكثر من روتر ونظامين تشغيل وكمان Voip وداه صعب يتحقق

    لاكن هقولك على الفكرة الاساسية و هى طبعا من اجتهادى الشخصى ممكن تصيب او تخيب

    اولا لن يكون هناك اكثر من AS

    احنا هنعمل Routing باستخدام EIGRP
    وهيكون موحد

    طيب اللعب هيكون فين ؟

    اللعب هيكون فى الPBR
    Policy Based Routing
    يعنى انا هحاول اتحكم فى الترافك
    مثال
    انت عندك شبكتين منفصلتين 172.30.1.0 للdata
    172.31.1.0 لل voip
    تمام
    احنا بقى هنخلى الروتر يقول
    لو جالى اى traffic من 172.30.1.0 هطلعها من الانترفيس الى عليها ال192.168.1.1 وليكن اسمها S0/0
    وايضا يقول
    لو جالى اى traffic من 172.31.1.0 هطلعها من الانترفيس الى عليها ال192.168.1.1 وليكن اسمها S0/1

    تعالى نشوف تطبيق عملى
    اولا
    اعمل Access list لك شبكة على حدى واعطيهم permit
    access-list 1 permit ip 172.30.1.0 0.0.0.255
    access-list 2 permit ip 172.31.1.0 0.0.0.255
    بعدين
    نبدا فى الشغل على الPBR
    route-map melshare permit 10
    match ip address 1
    وكدة انت بتحدد انهى Access list هيطبق على الip address الموجودين فيها القوانين
    set interface s0/0
    كانك بتقول له لو جالك traffic من ال172.16.30.0 طلعة من S0/0
    لاكن خد بالك انت ممكن تشتغل على طول الباكيت نفسة

    وانا الى اعرفة ان الLength الخاص بالVoice packet صغير يعنى ممكن تقول
    match length <min> <max>
    set interface s0/0
    والافضل اننا نشتغل على الNext hop
    عايزك تركز فى الى انا هكتبة دة كويس اوى



    route-map data permit 10
    match ip address 1
    set next-hop 192.168.1.2
    !
    route-map voice permit 20
    match ip address 2
    set next-hop 192.168.2.2
    !

    وهذه زيادة مش متاكدة منها بصراحة بس عملتها

    route-map backupdata permit 30
    match ip address 1
    set next-hop 192.168.2.2
    set ip tos 4
    !
    route-map backupvoice permit 40
    match ip address 2
    set next-hop 192.168.1.2


    وبعد كدة تروح على الe0/0 وتكتب
    ip policy route-map data
    والtags الى فوق
    اسف انا اكتب وانا فاصل نوم


    ان شاء الله اكون على الاقل وصلتك لمفتاح الحل ونكمل بكرة
    [SIZE=1][B][B]..||..[/B][/B][/SIZE][SIZE=1][B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=125858"]حمل جميع محاضرات احمد نبيل R&S من رفعى[/URL]..||..[/B][/B][B][B][COLOR=Red][URL="http://www.arabhardware.net/forum/showthread.php?t=119516"]شرح IS-IS[/URL][/COLOR]..||..[/B][/B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=108310"][B]شرح IPv6,OSPFv3 [/B][/URL][B]..||..[URL="http://www.arabhardware.net/forum/showthread.php?t=108310"].[/URL][/B][/B][URL="http://www.arabhardware.net/forum/showthread.php?t=100662"][B]شرح كامل للOSPF[/B][/URL][B][B]..||..[/B][/B][URL="http://www.arabhardware.net/forum/showthread.php?t=91625"][B]حصريا شرح الEigrp[/B][/URL][B][B]..||..[/B][/B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=93682"]كن خبير لتحليل ترافيك شبكتك مع شرحWireShark[/URL][/B][B][B]..||..[/B][/B][URL="http://www.arabhardware.net/forum/showthread.php?t=94484&highlight=iptv"][B]مقال عن تقنية الIPTV[/B][B][B]..||..[/B][/B][/URL][B][URL="http://www.arabhardware.net/forum/showthread.php?t=93854"]جميع اوامر الروتنجIOS[/URL][/B][B][B]..||..[/B][/B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=94813"]أفضل برنامج لرسم وتخطيط الشبكات وبدون تنصيب[/URL][/B][B][B]..||..

    [/B][/B] [URL="http://badr-call-manager.blogspot.com/"][IMG]http://muslimtech.files.wordpress.com/2010/06/blog-badr-banner.jpg[/IMG][/URL]
    [URL="http://mohammad.islamway.com/"][B]سيرة أشرف من مس هذا الكوكب بقدمه وبجميع اللغات[/B][/URL]

    [/SIZE]

  10. #10
    عضو
    تاريخ التسجيل
    Apr 2008
    المشاركات
    124
    معدل تقييم المستوى
    0

    رد: Eigrp dual line المساعدة ياشباب

    شكرا لك استاذ nightspy هوه انتا فعلا وصلتنى الى اول الحل انا كده اتئكدت ان معظم الشغل هيكون من عند route map
    لكن فيه سطر مش فهمه اوى الى هوه set ip tos 4 ده بيعمل ايه .
    بوص انا فهمت انك عملت route map للاثنين network ومره خلنها تخرج من اول path وتانى مره من الطريق الثانى لكن
    هوه كده عنده الطريقين هيقدر يفرق مين فيهم الرئيسى بتاع كل نتورك وله لا ديه لزم نجربها وشكرا جدا على تعبك ومجهودك

  11. #11
    عضو برونزي الصورة الرمزية Nightspy
    تاريخ التسجيل
    May 2007
    المشاركات
    1,573
    معدل تقييم المستوى
    12

    رد: Eigrp dual line المساعدة ياشباب

    شوف يا سيدى
    الSet ip tos 4
    عشان اخلى الافضلية والاولوية للDATA

    اما دول

    route-map backupdata permit 30
    match ip address 1
    set next-hop 192.168.2.2
    set ip tos 4
    !
    route-map backupvoice permit 40
    match ip address 2
    set next-hop 192.168.1.2

    فانا بصراحة مش متاكد لاكن النظرية هنا انى عملت seq num
    متتابع بحيث ان المفروض الاول يطبق seq num 10
    لاكن يعمل اية الروتر لو فقد ال next hop 192.168.1.2 يبداء بتنفيذ الseq num 30 يعنى هينقل مسارات الdata من المسار العادى بتاعها الى مسار الفويس ويعطيه درجة اولوية اعلى من الفويس
    ونفس الكلام مع الvoice لو حدث عطل ينفذ الSeq num 40 وممكن تضيف لل backupvoice
    set tos وتعطية رقم قليل بحيث ان لو حول مسارة لمسار الData يكون لة اولوية اقل


    لا كن بصراحة ما نفذتها على الواقع

    لاكن لو عايزنى اجيلك انفذها عادى والله ممكن اعملها هههههههههههههههههههه


    نسيت ملحوظه مهمة نفس الاوامر الذى ستفعله مع R1 افعله مع R2

    لو الموضوع نجح ادعى لى اليومين دول كرب
    [SIZE=1][B][B]..||..[/B][/B][/SIZE][SIZE=1][B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=125858"]حمل جميع محاضرات احمد نبيل R&S من رفعى[/URL]..||..[/B][/B][B][B][COLOR=Red][URL="http://www.arabhardware.net/forum/showthread.php?t=119516"]شرح IS-IS[/URL][/COLOR]..||..[/B][/B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=108310"][B]شرح IPv6,OSPFv3 [/B][/URL][B]..||..[URL="http://www.arabhardware.net/forum/showthread.php?t=108310"].[/URL][/B][/B][URL="http://www.arabhardware.net/forum/showthread.php?t=100662"][B]شرح كامل للOSPF[/B][/URL][B][B]..||..[/B][/B][URL="http://www.arabhardware.net/forum/showthread.php?t=91625"][B]حصريا شرح الEigrp[/B][/URL][B][B]..||..[/B][/B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=93682"]كن خبير لتحليل ترافيك شبكتك مع شرحWireShark[/URL][/B][B][B]..||..[/B][/B][URL="http://www.arabhardware.net/forum/showthread.php?t=94484&highlight=iptv"][B]مقال عن تقنية الIPTV[/B][B][B]..||..[/B][/B][/URL][B][URL="http://www.arabhardware.net/forum/showthread.php?t=93854"]جميع اوامر الروتنجIOS[/URL][/B][B][B]..||..[/B][/B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=94813"]أفضل برنامج لرسم وتخطيط الشبكات وبدون تنصيب[/URL][/B][B][B]..||..

    [/B][/B] [URL="http://badr-call-manager.blogspot.com/"][IMG]http://muslimtech.files.wordpress.com/2010/06/blog-badr-banner.jpg[/IMG][/URL]
    [URL="http://mohammad.islamway.com/"][B]سيرة أشرف من مس هذا الكوكب بقدمه وبجميع اللغات[/B][/URL]

    [/SIZE]

  12. #12
    عضوية جديدة الصورة الرمزية dfash
    تاريخ التسجيل
    Apr 2009
    المشاركات
    6
    معدل تقييم المستوى
    0

    Wink رد: Eigrp dual line المساعدة ياشباب



    Slam Alikum ..

    SoRrY 4 late, yes..! now we have diagram i think i have some maybe they help u 4 Redundancy ..

    On each router, have static route for "the voice ip address block" pointing to the interface with "eigrp link for data",
    also, on each router, have static route for "the data ip address block" pointing to the interface with "eigrp link for voice",

    BUT MOST IMPORTANTLY, YOU NEED TO CHANGE THE "AD" FOR THE STATIC TO A VALUE HIGHER THAN "170" ( the AD for external eigrp).
    for example, in R1 you're going to have:
    R1#config t
    ip route 172.41.1.0 255.255.255.0 192.168.1.2 200 "200 is the AD"
    ip route 172.40.1.0 255.255.255.0 192.168.2.2 200 "200 is the AD"

    on R2, you need to do the same, but for networks 172.30 & 172.31

    ** if u use distribute-list its easier than route-map
    ----
    لا اله الا الله عدد ما كان، لا اله إلا الله عدد ما يكون، لا اله الا الله عدد الحركات والسكون، سبحان الله و الحمد لله و لا اله إلا الله و الله أكبر ، و لا حول ولا قوة إلا بالله.
    اللهم صلي وسلم وبارك على نبينا وحبيبنا محمد وآله الطيبين الطاهرين وصحبه أجمعين ، سبحان الله و بحمده عدد خلقه ، و رضا نفسه و زنة عرشه و مداد كلماته

المواضيع المتشابهه

  1. مشاركات: 2
    آخر مشاركة: 02-02-2010, 19:17
  2. ارجوا المساعدة بخصوص EIGRP
    بواسطة hatema في المنتدى الأرشيف
    مشاركات: 6
    آخر مشاركة: 01-02-2010, 03:19
  3. ياشباب مو عارف كيف أشغل pass4sure المساعدة ياشباب
    بواسطة yasser__lord في المنتدى الأرشيف
    مشاركات: 2
    آخر مشاركة: 17-03-2008, 05:36
  4. ياشباب المساعدة
    بواسطة ابولفاء في المنتدى السوفتوير العام
    مشاركات: 0
    آخر مشاركة: 11-06-2007, 22:28
  5. المساعدة ياشباب ؟؟؟؟!!!
    بواسطة Computer_H/W في المنتدى الأرشيف
    مشاركات: 2
    آخر مشاركة: 27-11-2006, 20:21

الكلمات الدلالية لهذا الموضوع

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •