صفحة 1 من 2 1 2 الأخيرةالأخيرة
النتائج 1 إلى 15 من 21

الموضوع: فقط للمحترفين في الشبكات

  1. #1
    عضوية جديدة
    تاريخ التسجيل
    Mar 2009
    المشاركات
    16
    معدل تقييم المستوى
    0

    فقط للمحترفين في الشبكات



    الأخوة الزملاء في هذا المنتدى العظيم

    أمل المساعدة في حل المشكلة التالية، سأحاول الشرح المشكلة بشكل مبسط راجيا الحصول على إستشارتكم:

    في العمل أردنا أن نعمل أتصال بين جهاز في الموقع (A) وموقع (B):
    الجهاز في الموقع (A) يحمل العنوان (172.16.103.1) (255.255.255.0).
    الطرف الأخر في الموقع (B) يحمل العنوان (172.26.4.100) (255.255.255.252).
    الربط بين الموقعين عن طريق تقنية (MPLS) من مزود خدمة خارجي ويتسخدم برتوكول (bgp).

    المشكلة بالضبط أنني لا أستطيع عمل بنق من (A) إلى (B) وعند عمل (trace route) من الموقع (A) إلى الموقع (B) يصل الباكت إلى الروتر في الموقع الأخر بعدين لا يعطي الروتر أي نتيجه فقط يعطي (.................)

    علماً أنني أستطيع أعمل بنق من الروتر في الموقع (B) على الجهاز المطلوب.

    بالإضافة أن لا يوجد أي (access -list ) في الموقع (B).

    هل من مساعدة ؟؟؟؟؟؟

  2. #2
    عضو الصورة الرمزية frozenEyes
    تاريخ التسجيل
    Apr 2006
    المشاركات
    624
    الدولة: Egypt
    معدل تقييم المستوى
    12

    رد: فقط للمحترفين في الشبكات

    اعرض sh run لكل من الروترين


  3. #3
    عضوية جديدة
    تاريخ التسجيل
    Mar 2009
    المشاركات
    16
    معدل تقييم المستوى
    0

    رد: فقط للمحترفين في الشبكات

    شكرا (frozenEyes) على مرورك
    بالتسبة للروتر في الموقع (A):

    !
    boot-start-marker
    boot-end-marker
    !
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    no ip dhcp use vrf connected
    !
    call rsvp-sync
    no scripting tcl init
    no scripting tcl encdir
    !
    !
    no file verify auto
    !
    !
    interface GigabitEthernet0/1
    ip address 172.16.98.30 255.255.255.240

    ip ospf priority 0
    media-type rj45
    speed auto
    duplex auto
    negotiation auto
    !
    interface FastEthernet0/2
    no ip address
    shutdown
    speed auto
    duplex auto
    !
    interface GigabitEthernet0/2
    no ip address
    media-type sfp
    speed auto
    duplex auto
    negotiation auto
    !
    interface GigabitEthernet0/2.3185
    encapsulation dot1Q 3185
    ip address 84.235.93.122 255.255.255.252
    !
    interface GigabitEthernet0/3
    no ip address
    shutdown
    media-type rj45
    speed auto
    duplex auto
    negotiation auto
    !
    !
    router ospf 100
    router-id 172.16.98.30
    log-adjacency-changes
    area 0 authentication message-digest
    redistribute bgp 64567 subnets
    network 172.16.98.30 0.0.0.0 area 0
    !
    router bgp 64567
    no synchronization
    bgp log-neighbor-changes
    redistribute connected
    redistribute static
    redistribute ospf 100
    neighbor 84.235.93.121 remote-as 65000
    no auto-summary
    !
    ip classless
    ip route 130.1.4.0 255.255.255.0 172.31.135.218
    ip route 172.16.99.0 255.255.255.240 172.16.98.20
    ip route 172.16.100.0 255.255.252.0 172.16.98.20
    ip route 172.16.106.0 255.255.254.0 172.16.98.20
    ip route 172.16.108.0 255.255.252.0 172.16.98.20
    ip route 172.16.112.0 255.255.252.0 172.16.98.20
    ip route 172.16.200.0 255.255.252.0 172.16.98.20
    ip route 172.16.204.0 255.255.255.0 172.16.98.20
    !
    no ip http server
    !
    !
    !
    ip access-list standard SNMP-Servers
    permit 172.16.103.237
    !
    !
    control-plane
    !
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    gatekeeper
    shutdown
    !
    end
    ------
    --------------------------
    بالتسبة للورتر في الموقع (B):

    boot-start-marker

    boot-end-marker
    !
    no aaa new-model
    !
    ip cef
    !
    no ip domain lookup
    ip domain name yourdomain.com
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    !
    voice-card 0
    no dspfarm
    !
    !
    interface FastEthernet0/0.3495
    encapsulation dot1Q 3495
    ip address 172.31.19.158 255.255.255.252
    !
    interface FastEthernet0/1
    description *** Connected to S1_NAJ_GF_LAN Port Fa0/48 ***
    ip address 172.26.7.254 255.255.252.0
    duplex full
    speed 100
    !
    router bgp 64567
    no synchronization
    bgp log-neighbor-changes
    redistribute connected
    neighbor 172.31.19.157 remote-as 65000
    no auto-summary
    !
    ip forward-protocol nd
    !
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    no ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    control-plane
    !
    end

  4. #4
    عضوية جديدة
    تاريخ التسجيل
    Mar 2009
    المشاركات
    16
    معدل تقييم المستوى
    0

    رد: فقط للمحترفين في الشبكات

    الأخوة رواد المنتدى

    معقولة لايوجد أحد يستطيع مساعدتي لحل المشكلة:eek::eek:
    هل لأن شرحي غير واضح أو انها لهذاه لدرجة صعبة :ah46::ah46:
    مازلت في أنتظار مروركم ومساعدتكم

  5. #5
    عضو
    تاريخ التسجيل
    Feb 2008
    المشاركات
    664
    الدولة: England
    معدل تقييم المستوى
    10

    رد: فقط للمحترفين في الشبكات

    اخي العزيز اتمنى ان اساعدك ولكن تقف عندي عدة استفهامات مما وضعت انت

    اولاً
    interface FastEthernet0/0.3495
    encapsulation dot1Q 3495
    ip address 172.31.19.158 255.255.255.252
    هل هذي الـInterface متجهه للـISP واذا كانت كذلك فاعتقد بان الـIP address غلط لانها تقع ظمن الـPrivate addressing الا اذا كنت متأكد انه هو نفسه الذي تم اعطائك هو من الـISP.

    على نفس الروتر العنوان التالي

    interface FastEthernet0/1
    ip address 172.26.7.254 255.255.252.0
    يختلف مع عنوان الجهاز من ناحية الـsubnets وباعتقادي لا ينفع ان يكون كاgateway للجهاز وخصوصاً لا يوجد routing protocol او static route على الروتر B الا الـBGP الذي يربط مع العالم الخارجي.

    ايضاً كلا الروترين لديهم نفس الـautonomous system للـBGP فهل site A وايضاً site B هم في نفس الموقع ام يفصلهم الـISP كما ذكرت لانه بحد علمي انت تحتاج EBGP وليس IBGP. <<< اعذرني لاني ضعيف في الـBGP.


    الملاحظ وهو في الـSite A ان الـOSPF وايضاً الـstatic route لا تظم الـ172.16.1.103 /24 عنوان الجهاز ولا اي subnet تظم هذي الـsubnet الي هيا تظم عنوان الجهاز.

    بالاضافه اعتقد ان الـIP route statements تشير الى طريق مسدود او ماشابه لانه الـNext Hop هو Private address بالاضافه انها تشير الى موقع في نفس الـInterface الجايه منها وهذا عاده يتم في router on stick لعمل vlan routing.

    قد اكون مخطى ولكن سامحني لضيق الوقت واتمنى ان ترشدني ان كنت مخطى لان الصوره ليست واضحه تماماً بالنسبه لي.

    ان كان كما وصفت في اول مشاركه بان الـSite A يقدر يخرج الا اي مكان ولكن عندما يصل الى Router B يكون هناك drop للـICMP فقد تكون المشكله بالـsite B.

    ولكن كااضافه ساعمل ping من router A الى router B وليس الى الجهاز وعلى router B ساعمل access-list تسمح للـICMP traffic واكتب الامر التالي router#debug ip packet [access-list ] او تقدر تختصرها بعمل debug ip icmp.

    ومنها ستعرف اذا كانت تصل الى router B ام لا ، اذا كانت تصل فهناك مشكله في عودة الـReplay وهناك عدة احتمالات.

    بالاضافه يمكن عمل ping من router B الى router A واذا نجحت حاول من الاجهزه ويمكنك ايضاً استخدام الـtraceroute لمعرفه اين يكمن الخلل.

    هناك access-list ولكن باعتقادي انه output omitted
    من المستحسن ان وجد رسمه للشبكه للتسهير على فهم الـDesign للمشكله.

    اتمنى ان وجدت حل ان تخبرن في نفس الموضوعا حتى ننال المعرفه من حل مشكله كهذه.

  6. #6
    عضو
    تاريخ التسجيل
    Feb 2008
    المشاركات
    664
    الدولة: England
    معدل تقييم المستوى
    10

    رد: فقط للمحترفين في الشبكات

    فقط كاملاحظه الـdebug commands قد يكون لها ضرر اذا كان الـprocessor عالي من حيث معالجه البيانات فحاول ان تستخدم هذه الاوامر عندما يكون استخدام الشبكه منخفض.

  7. #7
    عضو الصورة الرمزية qobtan_3005
    تاريخ التسجيل
    Sep 2006
    المشاركات
    475
    معدل تقييم المستوى
    0

    رد: فقط للمحترفين في الشبكات

    pls telll explain to me if these running config
    are for router A and B which belong to the ISP who provide you with MPLS
    your site is connected to your ISP through wich routing protocols
    as i can imagine from your config
    and if so
    your AS is 65000

    what is the prupose of these configuration
    what it is supposed to do
    MPLS VPN between two networks behinds these site A
    and B

    OR U ARE JUST RUNNING mpls



  8. #8
    عضوية جديدة
    تاريخ التسجيل
    Mar 2009
    المشاركات
    16
    معدل تقييم المستوى
    0

    رد: فقط للمحترفين في الشبكات

    الاستاذ (takiadeen)
    شكرا على مرورك

    هل هذي الـInterface متجهه للـISP واذا كانت كذلك فاعتقد بان الـIP address غلط لانها تقع ظمن الـPrivate addressing الا اذا كنت متأكد انه هو نفسه الذي تم اعطائك هو من الـISP.
    ايضاً كلا الروترين لديهم نفس الـautonomous system للـBGP فهل site A وايضاً site B هم في نفس الموقع ام يفصلهم الـISP كما ذكرت لانه بحد علمي انت تحتاج EBGP وليس IBGP. <<< اعذرني لاني ضعيف في الـBGP.
    للعلم الدائرة تعميل في كل الطرفين، والمشكلة ليست في وجود الاتصال بقدر هي إتصال بين أي جهاز في الموقع (A) إلى جهاز محدد في الموقع (B) الذي يحمل العنوان 172.26.4.100.

    الملاحظ وهو في الـSite A ان الـOSPF وايضاً الـstatic route لا تظم الـ172.16.1.103 /24 عنوان الجهاز ولا اي subnet تظم هذي الـsubnet الي هيا تظم عنوان الجهاز.
    بالنسبة للـ (OSPF) فهو لتنظيم الاتصال بين (Router) و الــ(Core Switch)
    وبالنسبة للــ static route وضيفته لتوجيه الباكت الموجه لخارج الشبكة في الموقع (A) إلى (Gateway).


    ولكن كااضافه ساعمل ping من router A الى router B وليس الى الجهاز وعلى router B ساعمل access-list تسمح للـICMP traffic واكتب الامر التالي router#debug ip packet [access-list ] او تقدر تختصرها بعمل debug ip icmp.
    شكرا على المقترح، سأعمل المطلوب سأوافيكم بالتنيجه

  9. #9
    عضوية جديدة
    تاريخ التسجيل
    Mar 2009
    المشاركات
    16
    معدل تقييم المستوى
    0

    رد: فقط للمحترفين في الشبكات

    pls telll explain to me if these running config
    are for router A and B which belong to the ISP who provide you with MPLS

    في الموقع (A)
    router bgp 64567
    no synchronization
    bgp log-neighbor-changes
    redistribute connected

    في الموقع (B)
    encapsulation dot1Q 3495
    ip address 172.31.19.158 255.255.255.252
    !
    router bgp 64567
    no synchronization
    bgp log-neighbor-changes
    redistribute connected
    neighbor 172.31.19.157 remote-as 65000
    no auto-summary

    your site is connected to your ISP through wich routing protocols

    موزد الخدمة وفر خدمة يسميها (IP-VPN) وذكر أنها بواسطة (MPLS)
    بالتسبة لي في كلا الموقعين، قمت بتزيل (Bgp) لتفيعل الخدمة بناءً على طلب موزد الخدمة
    علماً أنها عن طريق خطوط أرضيه بعضها فايبر خاصة بمزود الخدمة.

  10. #10
    عضو الصورة الرمزية qobtan_3005
    تاريخ التسجيل
    Sep 2006
    المشاركات
    475
    معدل تقييم المستوى
    0

    رد: فقط للمحترفين في الشبكات

    first try to ping from the router at SITE B to the ip address 172.31.191.157
    this the ip address of your BGP neighbour
    if it is successfull then u can reach the ISP from site B

    second try to ping from the router at SITE A
    to the ip address 84.235.93.121
    this is the ip address of your BGP neighbour
    if it is successfull so u can reach the ISP from site B


  11. #11
    عضوية جديدة
    تاريخ التسجيل
    Mar 2009
    المشاركات
    16
    معدل تقييم المستوى
    0

    رد: فقط للمحترفين في الشبكات

    first try to ping from the router at SITE B to the ip address 172.31.191.157
    this the ip address of your BGP neighbour
    if it is successfull then u can reach the ISP from site B

    second try to ping from the router at SITE A
    to the ip address 84.235.93.121
    this is the ip address of your BGP neighbour
    if it is successfull so u can reach the ISP from site B

    عزيزي qobtan_3005...
    المشكلة ليست في الاتصال بين الموقع (A) والموقع (B)، حيث أني أستطيع أعمل Telnet من (A) إلى الوتر في الموقع (B)
    المشكلة بالضبط أن لا أستطيع عمل (ping) من الموقع (A) إلى جهاز محدد في الموقع (B) يحمل العنوان 172.26.4.100 مع أن العكس صحيح من الروتر في الموقع (B).

    المشكلة غريبة نوعا ما، لكن مش صعبة أتوقع

  12. #12
    عضو
    تاريخ التسجيل
    Nov 2005
    المشاركات
    89
    معدل تقييم المستوى
    0

    رد: فقط للمحترفين في الشبكات

    هل كل موقع منهم على domain مختلف عن الآخر

  13. #13
    عضوية جديدة
    تاريخ التسجيل
    Mar 2009
    المشاركات
    16
    معدل تقييم المستوى
    0

    رد: فقط للمحترفين في الشبكات

    هل كل موقع منهم على domain مختلف عن الآخر
    الموقع (A) على domain والموقع B بدون

  14. #14
    عضو الصورة الرمزية minimax
    تاريخ التسجيل
    Mar 2004
    المشاركات
    436
    معدل تقييم المستوى
    14

    رد: فقط للمحترفين في الشبكات

    معليش أخويا ممكن نشوف نتيجة الأوامر هذه

    show ip route | inc 172.26.4.100

    من router a

    وكمان

    show ip route | inc 172.16.103.1

    من Router B و Router A





  15. #15
    عضوية جديدة
    تاريخ التسجيل
    Mar 2009
    المشاركات
    16
    معدل تقييم المستوى
    0

    رد: فقط للمحترفين في الشبكات



    الاخ minimax

    معليش أخويا ممكن نشوف نتيجة الأوامر هذه

    show ip route | inc 172.26.4.100

    من router a

    وكمان

    show ip route | inc 172.16.103.1

    من Router B و Router A



    جربت الأوامر ماطلع لي أي نتبجة

صفحة 1 من 2 1 2 الأخيرةالأخيرة

المواضيع المتشابهه

  1. للمحترفين فقط !!!
    بواسطة Mr_MAK في المنتدى الأرشيف
    مشاركات: 4
    آخر مشاركة: 05-05-2008, 17:43
  2. للمحترفين
    بواسطة mooon_eraky في المنتدى الأرشيف
    مشاركات: 3
    آخر مشاركة: 25-11-2006, 13:53
  3. للمحترفين ...........
    بواسطة N E O في المنتدى الأرشيف
    مشاركات: 5
    آخر مشاركة: 18-10-2006, 03:39
  4. للمحترفين فقط؟؟
    بواسطة gollden في المنتدى الأرشيف
    مشاركات: 2
    آخر مشاركة: 20-01-2006, 03:11
  5. للمحترفين في الشبكات
    بواسطة khaled_c في المنتدى الأرشيف
    مشاركات: 4
    آخر مشاركة: 17-04-2004, 07:52

الكلمات الدلالية لهذا الموضوع

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •