النتائج 1 إلى 5 من 5

الموضوع: QOS PRECLASSIFY

  1. #1
    عضو الصورة الرمزية qobtan_3005
    تاريخ التسجيل
    Sep 2006
    المشاركات
    475
    معدل تقييم المستوى
    0

    QOS PRECLASSIFY



    السلام عليكم ورحمة الله وبركاته

    QoS pre-classify was designed so that tunneled interfaces could classify packets on the output
    interface before data was encrypted and tunneled.

    الفكرة ان لو انى حعمل QOS classification على بناء على الTOS byte (DSCP OR IPprecedence

    مش محتاج ال QOS PRECLASIFIY
    لان لما بيتعمل ENCRYPTION or encapsulation سواء عن طريق ال ipsec or GRE او GRE OVER IPSEC
    ESP protocol

    ال TOS byte is copied from the original ip packet to the new IP PACKET after encryption

    لكن اما اكون عايز اعمل QOS classifiaction بناء على

    the source or destination IP address,
    protocol number, or source port or destination port numbers

    ومع عمل ال encryption or encapsulation بالتالى حيبقى فيه new ip address غير الاصلى

    وبالتالى اذا كنت عايز اعمل qos classification مش حعرف لان اصبح فيه ip address جديد
    للتغلب على هذة المشكلة محتاج اعمل QOS CLASSIFICATION قبل معمل encapsulation or encryption

    وهيه ديه فايده ال QOS prequalify حيث ال cisco ios حتعمل نسخة مؤقتة من ال ip pcaket قبل ميتعملها encryption او encapsulation

    سؤالى هنا فى حالة معينة لما اكون عامل GRE over IPSEC
    بيطبق ال QOS PREQUALIFY على ال GRE TUNNEL INTERFACE وعلى ال CRYPTOMAP
    وعلى ال PHYISCAL INTERFACE بيطبق SERVICE POLICY معينة


    QoS Pre-Classification Example
    interface serial1/1
    ip address 10.1.1.1 255.255.255.252
    service-policy output to-remote-branch
    crypto map vpn

    interface tunnel1
    ip address 192.168.1.1 255.255.255.252
    tunnel source serial1/1
    tunnel destination 10.1.1.2
    crypto map vpn
    qos pre-classify

    crypto map vpn 10 ipsec-isakmp
    set peer 10.1.1.2
    set transform-set remote-branch-vpn
    match ip address 100
    qos pre-classify


    ماذا لو لم يتم تطبيق qos pre-classify على ال tunnel interface
    ماذا لو لم يتم تطبيق qos pre-classify على ال crypto map
    ليه انا محتاج اطبقهم على الاتنين crypto map and the tunnel interface
    ليه مش كافى ان اطبق qos pre-calssify على ال crypto map بس او على tunnel interface بس


    الحمد لله finally CCNP



  2. #2
    عضو الصورة الرمزية qobtan_3005
    تاريخ التسجيل
    Sep 2006
    المشاركات
    475
    معدل تقييم المستوى
    0

    رد: QOS PRECLASSIFY

    السلام عليكم ورحمة الله وبركاته

    ايه شباب مفيش اى رد حتى ولو مش عارف او الله اعلم
    الحمد لله finally CCNP



  3. #3
    عضو برونزي الصورة الرمزية ahmed magdy
    تاريخ التسجيل
    Jul 2007
    المشاركات
    551
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: QOS PRECLASSIFY

    السلام عليكم,

    هذه هي اجابه الاسئله اللي انت عايزها, من كتاب ال QOS في شهاده ال CCVP
    دي اجابه لاول سؤال و هي اماكن تطبيق ال QOS
    1- Apply the policy to the tunnel interface without qos pre-classify when you want to classify
    packets based on the pre-tunnel header.
    2-Apply the policy to the physical interface without qos pre-classify when you want to
    classify packets based on the post-tunnel header. In addition, apply the policy to the
    physical interface when you want to shape or police all traffic belonging to a tunnel, and
    the physical interface supports several tunnels.
    3- Apply the policy to a physical interface and enable qos pre-classify when you want to
    classify packets based on the pre-tunnel header.


    اجابه سؤالك الثالث و هتجد اجابه جزء من الرابع:

    If QoS preclassify is
    only enabled on the crypto map and not on the tunnel interface, the router will see one flow
    only, the GRE tunnel (protocol 47).

    سلام
    [SIZE=5][FONT=comic sans ms][B]عَنْ عُمَرَ بْنِ الخَطَّابِ رَضِيَ الله عَنْهُ، أَنَّ رَسُولَ اللَّهِ صَلَّى اللَّهُ عَلَيْهِ وَسَلَّمَ قَالَ: "[COLOR=#cc0066][COLOR=#cc0066]مَنْ رَأَى صَاحِبَ بَلَاءٍ فَقَالَ الْحَمْدُ لِلَّهِ الَّذِي عَافَانِي مِمَّا ابْتَلَاكَ بِهِ وَفَضَّلَنِي عَلَى كَثِيرٍ مِمَّنْ خَلَقَ تَفْضِيلًا إِلَّا عُوفِيَ مِنْ ذَلِكَ الْبَلَاءِ كَائِنًا مَا كَانَ مَا عَاشَ[/COLOR][/COLOR]"[/B][/FONT][/SIZE]

  4. #4
    عضو الصورة الرمزية qobtan_3005
    تاريخ التسجيل
    Sep 2006
    المشاركات
    475
    معدل تقييم المستوى
    0

    رد: QOS PRECLASSIFY

    جزاك الله خيرا وربنا يكرمك ويبارك فيك


    مشكور على ردك


    الحمد لله finally CCNP



  5. #5
    عضو
    تاريخ التسجيل
    Feb 2008
    المشاركات
    664
    الدولة: England
    معدل تقييم المستوى
    10

    رد: QOS PRECLASSIFY



    اقتباس المشاركة الأصلية كتبت بواسطة qobtan_3005 مشاهدة المشاركة


    ايه شباب مفيش اى رد حتى ولو مش عارف او الله اعلم

    من قال لا اعلم فقد افتى

الكلمات الدلالية لهذا الموضوع

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •