صفحة 1 من 4 1 2 3 4 الأخيرةالأخيرة
النتائج 1 إلى 15 من 59

الموضوع: بالصور : استخدام ال dhcp مع ال inter-vlan

  1. #1
    عضو فضي الصورة الرمزية ahab
    تاريخ التسجيل
    Mar 2008
    المشاركات
    2,669
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    15

    Thumbs up بالصور : استخدام ال dhcp مع ال inter-vlan



    بسم الله الرحمن الرحيم

    هذا اللاب عن استخدام ال DHCP مع intr-vlan والأمر ip helper address




    كما تلاحظ في الرسمة يوجد لدي ما يلي :
    Server0 يعمل ك dhcp فيقوم بتوزيع الأيبيهات على الأجهزة
    ويقوم بالتوزيع لعدد 2 vlan وبذلك يكون عندي 2 pool




    ال pool الأول سيقوم بتوزيع الأيبيهات ل vlan 1 في الشبكة 192.168.1.0 بدءً من ال Ip التالي 192.168.1.10
    لاحظ أن ال default gateway وهي 192.168.1.1 سوف يمررها للأجهزة المشتركة في vlan 1

    أما ال pool الثاني سيقوم بتوزيع الأيبيهات ل vlan 10 في الشبكة 192.168.10.0 بدءً من ال ip التالي 192.168.10.10




    بالنسبة لبرمجة السويتش فهو كالتالي :
    أولاً نقوم بإنشاء vlan 10
    Switch(config)# vlan 10
    والمعروف أنه تلقائيًا يوجد vlan 1 وتنتمي إليه جميع البورتات.

    البورت f0/1 نجعله trunk
    interface FastEthernet0/1
    switchport mode trunk
    !
    بالنسبة للأجهزة الموجودة في vlan 1
    interface FastEthernet0/2
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/4
    switchport mode access
    spanning-tree portfast
    !
    بالنسبة للجهاز الموجود في vlan 10
    interface FastEthernet0/3
    switchport mode access
    switchport access vlan 10
    spanning-tree portfast

    بالنسبة لبرمجة الراوتر وعمل routing بين ال Vlan

    interface FastEthernet0/0
    no ip address
    !

    نقوم بعمل subinterface من الإنترفيس fa0/0 وليكن 0/0.1
    ثم نحدد ال encapsulation ونكتب رقم ال vlan
    ونعطيها ip address
    interface FastEthernet0/0.1
    encapsulation dot1Q 1 native
    ip address 192.168.1.1 255.255.255.0
    ip helper-address 192.168.2.5
    !
    لاحظ أن ال ip التالي 192.168.1.1 هو ال default gateway الذي أعددته على ال dhcp لل pool الأول

    نقوم بعمل ال subinterface الثاني لل Vlan رقم 10
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.10.1 255.255.255.0
    ip helper-address 192.168.2.5
    !
    وكذلك ال ip التالي 192.168.10.1 هو ال default gateway الذي أعددته على ال dhcp لل pool الثاني

    أما الأمر ip helper-address 192.168.2.5 فهو أمر مهم جدًا
    حيث أن جهاز الحاسب يقوم بإرسال broadcast يطلب فيه عرضًا من ال ip ولأن الراوتر لا يمرر ال broadcast فلن يحصل الحاسب على ال ip
    ولذلك فإن الأمر ip helper-address 192.168.2.5 يخبر الراوتر ويقول له إذا جاءك برودكاست على هذا الإنترفيس فقم بتحويله إلى unicast على ال ip التالي 192.168.2.5 وبالتالي يستطيع الحاسب الحصول على ال ip من ال dhcp

    interface FastEthernet1/0
    ip address 192.168.2.1 255.255.255.0

    لاحظ أن ال Ip الخاص بالسيرفر وبالإنترفيس السابق من نفس ال subnet

    وبضبط إعدادات الحاسبين اللذان في vlan 1 ليأخذا ال ip من ال dhcp ستجد أنه قد تحقق ذلك




    وهذا الجهاز الذي يليه




    وهذا الجهاز في vlan 10





    وفي حالة استبدال الserver0 براوتر سيسكوا ليعمل ك dhcp



    فتكون الإعدادات بهذا الشكل

    interface FastEthernet0/0
    ip address 192.168.2.5 255.255.255.0
    duplex auto
    speed auto
    نقوم بعمل استثناء لل ip التي لا أريد توزيعها من خلال ال dhcp
    ip dhcp excluded-address 192.168.1.1 192.168.1.9
    ip dhcp excluded-address 192.168.10.1 192.168.10.9

    نقوم بعمل Pool خاص ب Vlan1
    ip dhcp pool v1
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    نقوم بعمل pool خاص ب vlan10
    ip dhcp pool v10
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1

    انتبه أن default router هو default gateway للحاسب.



    ولابد من استخدام routing protocol بين R1 و DHCP

    وللسهولة استخدمت ال eigrp

    وهذا برمجته على R1

    router eigrp 10
    network 192.168.1.0
    network 192.168.10.0
    network 192.168.2.0

    ويكون على ال dhcp بهذا الشكل
    router eigrp 10
    network 192.168.2.0

    ولتحميل ملفات ال packet tracer

    الملف الأول

    http://www.elshefa.com/images/ahab.pkt

    الملف الثاني

    http://www.elshefa.com/images/ahab2.pkt

  2. #2
    عضو
    تاريخ التسجيل
    Jun 2007
    المشاركات
    979
    الدولة: Egypt
    معدل تقييم المستوى
    11

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan

    جزاك الله خيرا
    شكرا

  3. #3
    عضو الصورة الرمزية abo Abdullah
    تاريخ التسجيل
    Jul 2008
    المشاركات
    211
    معدل تقييم المستوى
    0

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan

    مشكور على المجهود الرائع

    جزاك الله خيرا
    رأيت الذنوب تميت القلوب *** وقد يورث الذل إدمانها
    وترك الذنوب حياة القلوب *** وخير لنفسك عصيانها


    Telecom Engineer

  4. #4
    عضو ذهبي
    تاريخ التسجيل
    Mar 2009
    المشاركات
    1,756
    الدولة: Egypt
    معدل تقييم المستوى
    15

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan

    تسلم يا اخى مجهود رائع
    [CENTER]
    [B][URL="http://arabhardware.net/forum/showthread.php?t=374583&p=2701104#post2701104"] [/URL][/B][/CENTER]
    [CENTER][B][/B][/CENTER]
    [CENTER][B][URL="http://arabhardware.net/forum/showthread.php?t=374583&p=2701104#post2701104"]مراجعة للشاشة الرائعة

    [/URL][/B][/CENTER]
    [CENTER][B][URL="http://arabhardware.net/forum/showthread.php?t=374583&p=2701104#post2701104"]Samsung SyncMaster S24B750V Series 7 [/URL][/B]

    [/CENTER]

  5. #5
    عضو الصورة الرمزية sincere
    تاريخ التسجيل
    Sep 2008
    المشاركات
    339
    الدولة: Sudan
    معدل تقييم المستوى
    10

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan

    بارك الله فيك
    شكرا

  6. #6
    عضو الصورة الرمزية kamel_s_s
    تاريخ التسجيل
    Dec 2008
    المشاركات
    456
    معدل تقييم المستوى
    10

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan

    جزاك الله خيرا

  7. #7
    عضو فضي الصورة الرمزية ahab
    تاريخ التسجيل
    Mar 2008
    المشاركات
    2,669
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    15

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan

    the_way2allah ، abo Abdullah ، ellassy ، sincere ، kamel_s_s
    جزاكم الله خيرًا على المشاركة

    وكنت قد نسيت كتابة أوامر ال routing protocol بين ال R1 و ال DHCP فانتبهوا ( تمت الإضافة )



  8. #8
    عضو
    تاريخ التسجيل
    Aug 2007
    المشاركات
    58
    معدل تقييم المستوى
    0

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan

    جزاك الله كل خير،،
    ومن يتق الله يجعل له مخرجا ويرزقه من حيث لا يحتسب

  9. #9
    عضو الصورة الرمزية ozaro19
    تاريخ التسجيل
    Dec 2008
    المشاركات
    211
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan

    جزاك الله خير

    افادني لابك الجميل

  10. #10
    عضو ذهبي الصورة الرمزية warior10
    تاريخ التسجيل
    Nov 2005
    المشاركات
    1,991
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    25

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan

    هلا يا معلم
    ايوة كده محرمناش من ابداعاتك فينك من زمان
    من يوم ماخلصت ccnp و ccvp وانت نفسك كبرت على الغلابة

    جميل جدا والله
    ربنا يجعل عبك فى ميزان حسناتك
    بس يا ريت تعملنا واحد كمان ب mls
    [SIZE=3][COLOR=red]الحــــر يعـــرف مــــــا تــريـــد المحـــــــكمة [/COLOR][/SIZE]
    [SIZE=3][COLOR=red]وقضــــاتها سلفا قـــــد ارتشفوا من دمــــه [/COLOR][/SIZE]
    [SIZE=3][COLOR=red]لا يرتجي دفعا لبهتــــــان رماه به الطغــــاة [/COLOR][/SIZE]
    [SIZE=3][COLOR=red]المجرمون الجالسون فوق كراسي القضاة[/COLOR][/SIZE]

  11. #11
    عضو
    تاريخ التسجيل
    Feb 2009
    المشاركات
    751
    الدولة: Qatar
    معدل تقييم المستوى
    10

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan

    ما شاء الله ,
    شرح ممتاز وبسيط ,
    الله يوفقك اخي الحبيب ,
    (أربع من كن فيه كان منافقاً خالصاً ومن كانت فيه خصلة منهن كانت فيه خصلة من النفاق حتى يدعها إذا اؤتمن خان وإذا حدث كذب وإذا عاهد غدر وإذا خاصم فجر).

  12. #12
    عضو فضي الصورة الرمزية ahab
    تاريخ التسجيل
    Mar 2008
    المشاركات
    2,669
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    15

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan

    ieee2 ، ozaro19 ، dohaboy79
    جزاكم الله خيرًا على ردودكم المشجعة

  13. #13
    عضو فضي الصورة الرمزية ahab
    تاريخ التسجيل
    Mar 2008
    المشاركات
    2,669
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    15

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan

    اقتباس المشاركة الأصلية كتبت بواسطة warior10 مشاهدة المشاركة
    هلا يا معلم
    ايوة كده محرمناش من ابداعاتك فينك من زمان
    من يوم ماخلصت ccnp و ccvp وانت نفسك كبرت على الغلابة

    جميل جدا والله
    ربنا يجعل عبك فى ميزان حسناتك
    بس يا ريت تعملنا واحد كمان ب mls
    أيوه يا عم أحمد اتريق يا يريس
    دا أنا أغلب الغلابة ( مدرس حاسب ) :D
    عامة لما تيجي الرياض أنا أوريك . :ah42:





  14. #14
    عضو برونزي الصورة الرمزية ameer_s
    تاريخ التسجيل
    May 2008
    المشاركات
    1,808
    الدولة: Qatar
    معدل تقييم المستوى
    11

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan

    شكرا لك .....

  15. #15
    عضو فضي الصورة الرمزية ahab
    تاريخ التسجيل
    Mar 2008
    المشاركات
    2,669
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    15

    رد: بالصور : استخدام ال dhcp مع ال inter-vlan



    ameer_s شرفت الموضوع يا ربس

    اقتباس المشاركة الأصلية كتبت بواسطة warior10 مشاهدة المشاركة
    بس يا ريت تعملنا واحد كمان ب mls
    يا جماعة هو ينفع مع استخدام L3 switch يكون ال DHCP يقع خلف L3 switch

    لأن أمر ال ip helper address لا نستطيع استخدامه على الانترفيس المتصل بالسويتش العادي


    قمت بتفعيل ال DHCP على ال L3 switch نفسه وكل شيء تمام


    فهل أحد عنده رأي آخر؟؟؟



صفحة 1 من 4 1 2 3 4 الأخيرةالأخيرة

المواضيع المتشابهه

  1. مشكلتي مع inter vlan routing بطريقة traditional inter vlan
    بواسطة FunctionSys في المنتدى الأرشيف
    مشاركات: 5
    آخر مشاركة: 11-12-2012, 19:25
  2. عندي مشكلة في لاب inter vlan
    بواسطة mndlna في المنتدى الأرشيف
    مشاركات: 2
    آخر مشاركة: 26-08-2011, 13:17
  3. inter vlan
    بواسطة سندبادالجيل في المنتدى الأرشيف
    مشاركات: 8
    آخر مشاركة: 21-02-2010, 17:33
  4. سؤال مهم vlan & inter-vlan
    بواسطة somaaoo في المنتدى الأرشيف
    مشاركات: 4
    آخر مشاركة: 02-01-2010, 07:37
  5. سؤال فى ال Inter Vlan
    بواسطة scorpionking300 في المنتدى الأرشيف
    مشاركات: 4
    آخر مشاركة: 28-04-2009, 21:01

الكلمات الدلالية لهذا الموضوع

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •