النتائج 1 إلى 6 من 6

الموضوع: block rip updates using access list

  1. #1
    عضو
    تاريخ التسجيل
    Dec 2007
    المشاركات
    136
    الدولة: Egypt
    معدل تقييم المستوى
    0

    block rip updates using access list



    Dear all


    i want to block RIP updates from propagating using access-list

    i know that RIP updates sent on UDP port 520 and sent either broadcast (RiIP v1) or multicast (RIP v2)


    i know that we can make it easily by using passive-interface, but the main question if i make access-list to allow only TCP connections, is this mean that the RIP updates will not passed as it uses UDP port 520?

    i tried it in example but rip updates is propagated .


    i don't know why




    R0 Cionfiguration


    interface Ethernet0/0
    ip address 11.0.0.1 255.0.0.0
    ip access-group 100 out
    half-duplex
    !
    interface Ethernet0/3
    ip address 10.0.0.1 255.0.0.0
    half-duplex
    !
    router rip
    network 10.0.0.0
    network 11.0.0.0
    !
    access-list 100 permit tcp any any
    access-list 100 deny udp any any

    !

    R1 Cionfiguration

    interface Ethernet0/0
    ip address 11.0.0.2 255.0.0.0
    half-duplex
    !
    interface Ethernet0/1
    ip address 12.0.0.1 255.0.0.0
    half-duplex
    !
    router rip
    network 11.0.0.0
    network 12.0.0.0

    R2 Cionfiguration


    interface Ethernet0/1
    ip address 12.0.0.2 255.0.0.0
    half-duplex
    !
    interface Ethernet0/3
    ip address 13.0.0.1 255.0.0.0
    half-duplex
    !
    router rip
    network 12.0.0.0
    network 13.0.0.0
    !


    although i make Access-list in R0 to block all UDP , the rip updates propagated from R0 to R1 and R2.
    R1 and R2 have Network 10.0.0.0 in their Routing table from RIP

    plz need help

    Thanks
    BR

  2. #2
    عضو
    تاريخ التسجيل
    Mar 2009
    المشاركات
    252
    معدل تقييم المستوى
    9

    رد: block rip updates using access list

    distribute list ..
    بس بأمانه مش فاكر أوامرها خالص لأنى سايب الموضوع ده بقالى 6 شهور تقريبا ومكنتش ذاكرته كويس ايامها
    اللهم صلى على نبينا محمد وعلى آله وصحبه وسلم ..

  3. #3
    عضو الصورة الرمزية minimax
    تاريخ التسجيل
    Mar 2004
    المشاركات
    436
    معدل تقييم المستوى
    14

    رد: block rip updates using access list

    outbound access lists will not match traffic that is generated by the router and that's why nothing will match the access-list. Only traffic going thru the router will match the outbound access-list


  4. #4
    عضو الصورة الرمزية hisooka_dos
    تاريخ التسجيل
    Aug 2009
    المشاركات
    565
    معدل تقييم المستوى
    0

    Wink رد: block rip updates using access list

    اقتباس المشاركة الأصلية كتبت بواسطة minimax مشاهدة المشاركة
    outbound access lists will not match traffic that is generated by the router and that's why nothing will match the access-list. Only traffic going thru the router will match the outbound access-list

    كلامك صح ...
    ماذا يعني شعار cisco ؟ تفضل لتكتشف ذلك .

    زر خاص ومميز يوجد بلوحة مفاتيحي
    ______:D______
    http://img709.imageshack.us/img709/4950/arab.png
    ضغطة واحدة تنقلك إلى عالم الإحتراف

    _______________________
    Agissez comme s'il était impossible d'échouer

  5. #5
    عضو
    تاريخ التسجيل
    Dec 2007
    المشاركات
    136
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: block rip updates using access list

    اقتباس المشاركة الأصلية كتبت بواسطة minimax مشاهدة المشاركة
    outbound access lists will not match traffic that is generated by the router and that's why nothing will match the access-list. Only traffic going thru the router will match the outbound access-list




    thanks alot

    gzak allah khiran

    thanks alot for u all for ur replies

  6. #6
    عضو برونزي الصورة الرمزية أيمن النعيمي
    تاريخ التسجيل
    Nov 2007
    المشاركات
    2,600
    معدل تقييم المستوى
    21

    رد: block rip updates using access list



    اقتباس المشاركة الأصلية كتبت بواسطة minimax مشاهدة المشاركة
    outbound access lists will not match traffic that is generated by the router and that's why nothing will match the access-list. Only traffic going thru the router will match the outbound access-list


    شكرا اخ محمد على هذه الاضافة الجميلة
    الصراحة المعلومة هذه رايحة عن بالي وماخطرتلي ابدا
    جزاك الله خيرا اخي

المواضيع المتشابهه

  1. q in access list
    بواسطة mndlna في المنتدى الأرشيف
    مشاركات: 0
    آخر مشاركة: 24-08-2011, 16:37
  2. ما الفرق بين الامر sh ip access-list و الامر sh access list
    بواسطة Dr Virus.exe في المنتدى الأرشيف
    مشاركات: 2
    آخر مشاركة: 05-07-2011, 21:23
  3. Prefix List Vs Distribute list Vs Offse list Vs Route Map Vs Access List
    بواسطة Brigadier في المنتدى الأرشيف
    مشاركات: 8
    آخر مشاركة: 17-02-2011, 03:50
  4. ماهو الفرق بين access-list و access-group
    بواسطة hani_79 في المنتدى الأرشيف
    مشاركات: 0
    آخر مشاركة: 08-11-2008, 22:23
  5. تفضلوا IP Access List Command List.
    بواسطة okaenrique في المنتدى الأرشيف
    مشاركات: 19
    آخر مشاركة: 25-09-2008, 06:26

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •