صفحة 1 من 2 1 2 الأخيرةالأخيرة
النتائج 1 إلى 15 من 24

الموضوع: شرح + config لكلا من pppoe , pppoa

  1. #1
    عضو
    تاريخ التسجيل
    Oct 2007
    المشاركات
    479
    معدل تقييم المستوى
    0

    شرح + config لكلا من pppoe , pppoa



    تم اضافة الموضوع للنقاش بيننا

    انا عرفت ان فيه طريقه تشغيل pppoe على روتر سيسكو كسيرفر للكلينت وخصيصا انى شغال فى انترنت سيرفيس بروفيدر فاتمنى نناقش الموضوع وتفيدونى وشكرا .
    CCNA Certified

  2. #2
    عضو الصورة الرمزية frozenEyes
    تاريخ التسجيل
    Apr 2006
    المشاركات
    624
    الدولة: Egypt
    معدل تقييم المستوى
    12

    رد: شرح + config لكلا من pppoe , pppoa



  3. #3
    عضو
    تاريخ التسجيل
    Oct 2007
    المشاركات
    479
    معدل تقييم المستوى
    0

    رد: شرح + config لكلا من pppoe , pppoa

    شكرا ليك اخى الكريم ولكن نريد ان نناقش هنا الاوامر باللغة العربيه مع الشرح وشكرا لردك واهتمامك ربنا يكرمك
    CCNA Certified

  4. #4
    عضو الصورة الرمزية frozenEyes
    تاريخ التسجيل
    Apr 2006
    المشاركات
    624
    الدولة: Egypt
    معدل تقييم المستوى
    12

    رد: شرح + config لكلا من pppoe , pppoa

    من غير ترجمة الكلام واضح بص كدة على المثال دة :

    This is an example of configuring PPPoE in a back-to-back scenario. The objective here is to simulate a PPPoE server (typically found on the ISP end)


    Client--Fa0/0----------------------------------------Fa0/0--Server


    In this example, we're using 2 routers connected back-to-back on their Fa0/0 ports. Here're the parameters being simulated

    1. Authentication using Chap/Pap (Username: cisco, password: sisco)
    2. Client being authenticated by the server (one way authentication)
    3. IP address being negotiated using IPCP

    Here's the relevant configuration needed on the client router


    interface FastEthernet0/0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    duplex auto
    speed auto
    pppoe enable
    pppoe-client dial-pool-number 1
    !

    interface Dialer1
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication pap chap callin
    ppp pap sent-username cisco password sisco
    ppp chap hostname cisco
    ppp chap password sisco
    !
    ip route 0.0.0.0 0.0.0.0 Dialer1


    Here's the relevant configuration needed on the Server


    username cisco password sisco
    !
    bba-group pppoe global
    virtual-template 1
    !
    interface FastEthernet0/0
    ip address 10.252.102.49 255.255.255.240
    ip rip advertise 4
    load-interval 30
    duplex auto
    speed auto
    pppoe enable group global
    !

    interface Virtual-Template1
    mtu 1492
    ip unnumbered FastEthernet0/0
    peer default ip address pool pppoepool
    ppp authentication pap chap
    !
    ip local pool pppoepool 10.10.10.1 10.10.10.200
    !


    Here's how the flow will be


    1. Client negotiates PPPoE using PADo, PADi and PADr with the server, both client and server move into PPP-->LCP phase
    2. Client/Server negotiate authentication, other parameters
    3. Server asks the client for a username/password (using pap, as pap is configured before chap)
    4. Client sends out a username/password configured in it's dialer
    5. Server authenticates this username/password against its global username/password list (alternatively a AAA/Radius server)
    6. Client and Server both move on to IPCP phase
    7. Client sends an ip address of 0.0.0.0 (asking for an ip address from the Server)
    8. Server hands out an IP address from its pool (in this case pppoepool)
    9. Client/Server finish IPCP phase and the link comes up


  5. #5
    عضو
    تاريخ التسجيل
    Oct 2007
    المشاركات
    479
    معدل تقييم المستوى
    0

    رد: شرح + config لكلا من pppoe , pppoa

    انا مع حضرتك وشاكر جدا لمجهودك ولكن فى بعض الاوامر غير مفهومه ةمحتاجين نناقشها ونعرف سبب وضعها وكل امر وددوره ايه حضرتك فهمتنى يا بشمهندس اكيد


    bba-group

    interface Virtual-Template1
    pppoe enable group global
    dialer pool 1
    ip address negotiated
    وفى امر اسمه enable vpdn
    CCNA Certified

  6. #6
    عضو برونزي الصورة الرمزية م/ أحمد بخيت
    تاريخ التسجيل
    Sep 2006
    المشاركات
    1,157
    الدولة: United Arab Emirates
    معدل تقييم المستوى
    13

    رد: شرح + config لكلا من pppoe , pppoa

    يا جماعة انا عندي رأي غير
    بصراحة انا في كام حاجة كدا افضل اني ابعد عن سيسكو
    زي الفويس وكمان الكونكشنز
    بمعنى اني افضل استخدام السيرفر ف الكلام دا افضل م الراوتر
    لأن السيرفر بيديني خواص اكتر ومميزات اعلى
    هل الكلام دا صح ؟؟؟
    [CENTER][B]Move - 2- Improve[/B]
    [/CENTER]
    [FONT=Tahoma][SIZE=4] اللهم اشفي مرضانا وجميع مرضى المسلمين[/SIZE][/FONT]
    [CENTER][SIGPIC][/SIGPIC] [/CENTER]

  7. #7
    عضو الصورة الرمزية frozenEyes
    تاريخ التسجيل
    Apr 2006
    المشاركات
    624
    الدولة: Egypt
    معدل تقييم المستوى
    12

    رد: شرح + config لكلا من pppoe , pppoa

    اقتباس المشاركة الأصلية كتبت بواسطة eslam_elsadat مشاهدة المشاركة
    انا مع حضرتك وشاكر جدا لمجهودك ولكن فى بعض الاوامر غير مفهومه ةمحتاجين نناقشها ونعرف سبب وضعها وكل امر وددوره ايه حضرتك فهمتنى يا بشمهندس اكيد


    bba-group

    interface Virtual-Template1
    pppoe enable group global
    dialer pool 1
    ip address negotiated
    وفى امر اسمه enable vpdn
    ربنا يجبر بخاطرك لكن انا مش مهندس ولا حاجة :D

    اعذرنى فانا لم اتعمق فى هذا الموضوع بعد فالاجابات التى لدى ليست كاملة وانا احب ان اكون ملم حتى اعطيك اجابة صحيحة ،،، وان شاء الله الاخوة بالمنتدى ما يقصروا معك

    http://www.cisco.com/en/US/docs/ios/...de/dcvpdn.html
    http://www.cisco.com/en/US/docs/ios/.../ftpprfls.html
    http://www.cisco.com/en/US/docs/ios/...e/dcvtemp.html

    وبالتوفيق ،،


  8. #8
    عضو
    تاريخ التسجيل
    May 2009
    المشاركات
    295
    معدل تقييم المستوى
    9

    رد: شرح + config لكلا من pppoe , pppoa

    السلام عليكم ورحمة الله وبركاته،

    مستر forzenEyes أنا من مدة وكنت حابب أتناقش معاك على هذا الموضوع كمان،

    أيش رأيك نكمل موضوع نقاشنا هنا :D

    المهم، أنا مستغرب ليش بنعمل هذا الشيء في الراوتر ونعمل جهاز الدي إس إل كـ bridge وما إلى ذلك.
    أحد الأصدقاء قال لي أنه رابط المودم مع الراوتر عن طريق الإيثرنت، وعامل ip route 0.0.0.0 0.0.0.0 ، والحال ماشي معاه تمام التمام،

    هل معاك فكرة معينة، أو ماشابه ليش بنعمل الإعدادات على الراوتر في حين أنها ماشية بالـ default route ؟

    أيش الفرق؟
    CCIE R&S Written exam
    Cisco Sales Expert
    CCNP
    CCNA-Security
    CCNA-Voice

    CCNA
    JNCIA-ER
    Dell Equallogic: Operation, Configuration and Management
    Dell Equallogic: Disaster Recovery


  9. #9
    عضو الصورة الرمزية frozenEyes
    تاريخ التسجيل
    Apr 2006
    المشاركات
    624
    الدولة: Egypt
    معدل تقييم المستوى
    12

    رد: شرح + config لكلا من pppoe , pppoa

    اقتباس المشاركة الأصلية كتبت بواسطة attyah مشاهدة المشاركة
    أحد الأصدقاء قال لي أنه رابط المودم مع الراوتر عن طريق الإيثرنت، وعامل ip route 0.0.0.0 0.0.0.0 ، والحال ماشي معاه تمام التمام،

    هل معاك فكرة معينة، أو ماشابه ليش بنعمل الإعدادات على الراوتر في حين أنها ماشية بالـ default route ؟

    أيش الفرق؟
    طيب انا هقولك ايه الغرض وعلى فكرة لو عملت default route من غيرما تحول Bridge ال internet هيوصل تمام
    بس انتا فرضنا ان حضرتك Home user عادى جدا حبيت تدخل على جهازك من برة وليكن عن طريق Remote Desktop
    هتعمل connect على اى ايبى مع استخدام no-ip لو تحب لان الايبى بيتغير كل شوية ????
    طبعا بعيدا عن Logme in :D

    Home User PC====Cisco Router(NAT+Default Route)===ADSL Modem===Internet
    ADSL Modem internal ip = 192.168.1.1
    cisco router outside interface =192.168.1.2
    cisco router LAN interface =192.168.2.1
    Home User PC=192.168.2.10


  10. #10
    عضو الصورة الرمزية frozenEyes
    تاريخ التسجيل
    Apr 2006
    المشاركات
    624
    الدولة: Egypt
    معدل تقييم المستوى
    12

    رد: شرح + config لكلا من pppoe , pppoa

    نكمل بكره عشان هموت وانام :D


  11. #11
    عضو
    تاريخ التسجيل
    May 2009
    المشاركات
    295
    معدل تقييم المستوى
    9

    رد: شرح + config لكلا من pppoe , pppoa

    اقتباس المشاركة الأصلية كتبت بواسطة frozenEyes مشاهدة المشاركة
    نكمل بكره عشان هموت وانام :D

    ههههههههه، طيب ولا يهمك يا سيدي، نكمل بكرة وليش لا.
    CCIE R&S Written exam
    Cisco Sales Expert
    CCNP
    CCNA-Security
    CCNA-Voice

    CCNA
    JNCIA-ER
    Dell Equallogic: Operation, Configuration and Management
    Dell Equallogic: Disaster Recovery


  12. #12
    عضو
    تاريخ التسجيل
    Oct 2007
    المشاركات
    479
    معدل تقييم المستوى
    0

    رد: شرح + config لكلا من pppoe , pppoa

    شكرا لك اخى frozen ولنجعل هذا الموضع خاص بتقنيات adsl ومن لديه معرفه بما سبق فليناقش معنا وربنا يوفق
    CCNA Certified

  13. #13
    عضو الصورة الرمزية frozenEyes
    تاريخ التسجيل
    Apr 2006
    المشاركات
    624
    الدولة: Egypt
    معدل تقييم المستوى
    12

    رد: شرح + config لكلا من pppoe , pppoa

    زى ما قلت لحضرتك قبل كدة انا شايف انا الامر يتعلق ب incoming traffic وليس outgoing وهذا راييى البسيط ولو فى احد من الاخوة له مداخلة فليتفضل ،،،


  14. #14
    عضو
    تاريخ التسجيل
    May 2009
    المشاركات
    295
    معدل تقييم المستوى
    9

    رد: شرح + config لكلا من pppoe , pppoa

    Home User PC====Cisco Router(NAT+Default Route)===ADSL Modem===Internet
    مش برضه نفس الفكرة الأثنين؟ سواء كان default route أو كان المودم bridge، الفكرة واحدة مادام بتخرج على النت، ومادام ختخرج على الآيبي اللي هو no-ip ......

    بس بيني وبينك أنا أفضل أكثر شيء الـ logmein مافيش أحلى منه، ولا راوترات ولا وجع راس :D
    CCIE R&S Written exam
    Cisco Sales Expert
    CCNP
    CCNA-Security
    CCNA-Voice

    CCNA
    JNCIA-ER
    Dell Equallogic: Operation, Configuration and Management
    Dell Equallogic: Disaster Recovery


  15. #15
    عضو الصورة الرمزية frozenEyes
    تاريخ التسجيل
    Apr 2006
    المشاركات
    624
    الدولة: Egypt
    معدل تقييم المستوى
    12

    رد: شرح + config لكلا من pppoe , pppoa



    لأ مش نفس الفكرة ،،، انتا فى السيناريو السابق لو انت ما عندك Cisco router بين ADSL Modem و Home user PC
    انت كل اللى محتاجة مثلا عشان تعمل Remote Desktop من برة الشبكة انك تعمل Port Forwarding على Adsl modem بفتح
    TCP port 3389 الى Home User pc ip وليكن الى 192.168.1.10 وهذا مثال على روتر linksys
    http://portforward.com/english/route...te_Desktop.htm

    اما فى حالة وجود Cisco router بين Adsl modem فى حالة Route mode و Home user pc فلا ادرى ما الحل فى هذا الحالة ولكن اتوقع انك تعمل نفس الخطوات السابقة بالاضافة الى فتح tcp port 3389 على cisco router بعمل static Nat
    ip nat inside source static tcp 192.168.1.200 3389 209.247.228.201 3389

    فانا ارى فعلا ان الموضوع فى الحالة الثانية اصبح Complex جدا ناهيك عن security طبعا بفتح اكثر من بورت وكل هذا لان
    Adsl modem هو الذى يقوم بعملية الاتصال فى المقام الاول اما اذا تحول الى Bridge mode فالوضع سيختلف وضع Bridge Mode فى Adsl Modem كل ما يحتوى عليه هو VPI/VCI Settings و Encapsulation فقط اما الاتصال ذات نفسه فيتم عن طريق External Device سواء اذا كان Router او PC عن طريق Software خاص به ، وفى حالتنا هذة Cisco router هو الذى يقوم بالاتصال PPP
    عن طريق Dialer interface الى باقى الاعدادات .

    وهذة وجهة نظر عبد الله الفقير ،،، :o


صفحة 1 من 2 1 2 الأخيرةالأخيرة

المواضيع المتشابهه

  1. مراجعه شخصيه لكلا من gtx470 OC vs gtx560 TI OC VS hd 5850
    بواسطة DaRk L0rD في المنتدى الأرشيف
    مشاركات: 10
    آخر مشاركة: 20-11-2011, 01:34
  2. آلية سحب النقود من الصراف الآلي لكلا الجنسين .
    بواسطة الفجر القادم في المنتدى الأرشيف
    مشاركات: 7
    آخر مشاركة: 26-12-2008, 22:37
  3. أريد أخذ نسخة من running config - Start Config - flash إلى TFTP
    بواسطة the_way2allah في المنتدى الأرشيف
    مشاركات: 2
    آخر مشاركة: 28-11-2008, 22:01
  4. مالفرق بين PPPoE - PPPoA و متى يستخدم كل منهما
    بواسطة c i s c o في المنتدى الأرشيف
    مشاركات: 12
    آخر مشاركة: 05-11-2008, 11:31
  5. برنامج للفايروس لكلا من السيرفر و الكلينت
    بواسطة omar alhalabi في المنتدى السوفتوير العام
    مشاركات: 1
    آخر مشاركة: 13-01-2008, 09:42

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •