النتائج 1 إلى 11 من 11

الموضوع: VOIP QoS Example

  1. #1
    عضو برونزي الصورة الرمزية SyrianCyclone
    تاريخ التسجيل
    Dec 2005
    المشاركات
    890
    الدولة: Germany
    معدل تقييم المستوى
    14

    VOIP QoS Example



    السلام عليكم و رحمة الله و بركاته

    مثال صغير لتطبيق ال QoS for VoIP

    PC--->IP phone--->Switch---->Router---->Internet



    على فرض عندنا 2 vlans

    VLAN 10 for data, and 20 for voice

    و نريد ضمان جودة الصوت و انتقاله بسرعة عبر الشبكة , و أعطائه الاولوية

    كود:
    Configuring Switch:
    
    Interface FastEthernet0/1
    
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 10 
    switchport mode trunk
    switchport voice vlan 20
    spanning-tree portfast
    switchport priority extend cos 0
    speed auto
    شرح هذه الاوامر :
    هذه الاعدادات تسمح للصوت و الداتا بالمرور من نفس البورت و هم ب Valan مختلفة كما هو واضح ,
    Cisco IP phone يدعم بشكل تلقائي بروتوكولي 802.1q trunking و ال 802.1p COS tagging
    حيث سيقوم بعمل tagging للفويس ترافيك ب L2 COS 5 و يقوم أيضا بعمل L3 IP Precedence 5


    اما الامر :
    كود:
    switchport priority extend cos 0
    لتأكد من الداتا الترافيك الصادرة عن ال PC سيتم إعادة تصنيفها و إعطائها L2 cos 0 و ذلك لأن ال PC متصل بالتلفون و نريد عزل تصنيف الداتا عن الفويس و عدم إعطاء نفس الأهمية لداتا بنفس قدر الفويس .



    الامر Speed auto مهم جدا جدا لأن cisco phone اعداداته الافتراضية هي auto-neqotation بالنسبة
    للسرعة و ال duplex

    فإذا كان البورت السويتش 100 و full-duplex عندها بشكل اتوماتيكي سيقوم ال cisco phone بجعل البورت المتصل به 100 و half-duplex عندها سيحصل بالتأكيد ما يسمى بال duplex mismatch

    الان إعداد الراوتر :

    ولا يجب علينا عمل 2 اكسيس ليست Extnded ACL اكسيس لست عملها هو ماتش الفويس ترافيك

    واحدة ل Voice RTP traffic
    ,
    و الثانية ل Voice signaling traffic

    كود:
    signaling traffic For Skinny, H.323, MGCP:
    
    access-list 101 permit tcp any any range 2000 2002
    access-list 101 permit tcp any any eq 1720
    access-list 101 permit tcp any any range 11000 11999
    access-list 101 permit udp any any eq 2427
    
    RTP traffic
    
    access-list 102 permit udp any any range 32767

    الان نعمل class map لكل نوع ترافيك :

    كود:
    class-map match-all voice-traffic
    match access-group 102
    
    class-map match-all voice-signaling
    match access-group 101
    الان نعمل policy map لكل كلاس انشأناه :

    كود:
    policy-map qos-voice
    class voice-traffic
    priority 240
    
    class voice-signaling
    bandwidth 16
    
    class class-defult
    fair-queue
    هنا قمنا بإعطاء الفويس ترافيك 240 كيلوبايت من الباندويث و السيغنالينغ 16 kbps و باقي الترافيك الاخرى
    WFQ (Wighted fair queuing (



    اهم عملية بكل هذا هو حساب و تحديد كم نعطي للفويس ترافيك من الباندويث و هنا حسب كم مكالمة تتم بنفس الوقت راح اسمح بها و إذا سمحت على فرض ب 10 مكالمات بنفس الوقت هل راح يكفي الباندويث يلي انا محدده للباندويث ؟
    طبعا لازم أخذ بعين الاعتبار ال كوديك المستخدمة لضغط الصوت فلو كانت مثلا g711u فهي 80
    او مستعمل g729 فهي 11 , كل هذا يؤخذ بالحسبان , يعني ما نعطي باندويث بشكل اعتباطي !!

    أخيرا
    نطبق الان البوليسي على الانترفيس الواصل للانترنت و ليكن fa 0/0

    كود:
    interface FastEthernet0/0
    service-policy output qos-voice

    اتمنى ان يكون قد أفادكم الموضوع
    تحياتي للجميع .
    و لأستاذي العزيز على قلبي ياسر رمزي الذي علمني الكثير و الكثير
    [CENTER][COLOR="Red"][SIZE="4"] الموت لكل خائن , خان وطنه و اهله [/SIZE][/COLOR][/CENTER]

    [CENTER][SIGPIC][/SIGPIC][/CENTER]


    [CENTER][IMG]http://folding.extremeoverclocking.com/sigs/sigimage.php?un=SyrianCyclone&t=155660[/IMG][/CENTER]

  2. #2
    عضو الصورة الرمزية SmartSolutions
    تاريخ التسجيل
    Sep 2008
    المشاركات
    140
    الدولة: Syria
    معدل تقييم المستوى
    0

    رد: VOIP QoS Example

    مشكور أخي على الشرح الجميل ... بارك الله فيك

  3. #3
    عضو
    تاريخ التسجيل
    Aug 2009
    المشاركات
    392
    معدل تقييم المستوى
    9

    رد: VOIP QoS Example

    شكرا أخي وبارك الله فيك نتمنى دائما من الأعضاء مثل هذه المواضيع
    لا تقل قد فشلت قل لم انجح بعد

  4. #4
    عضو الصورة الرمزية amer200
    تاريخ التسجيل
    Jan 2009
    المشاركات
    359
    معدل تقييم المستوى
    9

    رد: VOIP QoS Example

    الف شكر شي رهيب
    اتكلنا على الله دائما وابدا
    ccna -ccnp-ccvp
    :ah40:
    حصريا شرح CCNP-BSCI
    http://www.arabhardware.net/forum/sh...d.php?t=133213


  5. #5
    عضو برونزي الصورة الرمزية SyrianCyclone
    تاريخ التسجيل
    Dec 2005
    المشاركات
    890
    الدولة: Germany
    معدل تقييم المستوى
    14

    رد: VOIP QoS Example

    نورتو الموضوع يا أأعزاء
    [CENTER][COLOR="Red"][SIZE="4"] الموت لكل خائن , خان وطنه و اهله [/SIZE][/COLOR][/CENTER]

    [CENTER][SIGPIC][/SIGPIC][/CENTER]


    [CENTER][IMG]http://folding.extremeoverclocking.com/sigs/sigimage.php?un=SyrianCyclone&t=155660[/IMG][/CENTER]

  6. #6
    عضو برونزي الصورة الرمزية one-zero
    تاريخ التسجيل
    Jul 2007
    المشاركات
    8,296
    معدل تقييم المستوى
    59

    رد: VOIP QoS Example

    شكرا اخي العزيز
    [CENTER][SIZE=4]{[COLOR=red]وَإِذْ يَمْكُرُ بِكَ الَّذِينَ كَفَرُوا لِيُثْبِتُوكَ أَوْ يَقْتُلُوكَ أَوْ يُخْرِجُوكَ وَيَمْكُرُونَ وَيَمْكُرُ اللَّهُ وَاللَّهُ خَيْرُ الْمَاكِرِينَ[/COLOR]}[/SIZE][SIZE=4]…[/SIZE][SIZE=6][SIZE=4](الأنفال:30)
    [URL="http://www.facebook.com/pages/yasserauda/215036411882800"]للتواصل معي عبر الفيس بوك اضغط هنا
    [/URL][URL="http://www.youtube.com/watch?v=37LoZWjv1HE&feature=player_profilepage"][/URL][URL="http://www.facebook.com/pages/yasserauda/215036411882800"] صفحتي الخاصه على الفيس بوك
    [/URL][URL="http://www.facebook.com/pages/Mentored-Learning-New-Horizons-Dubai/234720379925819"]صفحة التعليم الارشادي على الفيس بوك
    [/URL][URL="http://www.youtube.com/user/yasserramzyauda"]قناتي على اليوتيوب
    [/URL][/SIZE][/SIZE][SIZE=3][URL="http://yasserauda.blogspot.com/"]مدونتي الخاصه[/URL][/SIZE][/CENTER]

  7. #7
    عضو الصورة الرمزية بيبرس جدة
    تاريخ التسجيل
    May 2008
    المشاركات
    217
    معدل تقييم المستوى
    0

    رد: VOIP QoS Example

    جزاك الله خير
    اللهم اغفر لي ولوالدي ولوالدتي ولجميع المؤمنين والمؤمنات والمسلمين والمسلمات الاحياء منهم والاموات ولمن له حق علي ومن اوصاني بالدعاء


    اللهم اغفر لابي وأرحمه وأكرم نزله ووسع مدخله



  8. #8
    عضو الصورة الرمزية kamel_s_s
    تاريخ التسجيل
    Dec 2008
    المشاركات
    456
    معدل تقييم المستوى
    10

    رد: VOIP QoS Example

    جزاك الله خيرا
    هل لابد من وجود FXS card علي ال router عند عمل الاب علي GNS3 علي هذه الشكل
    PC--->IP phone--->Switch---->Route<....switch<...ip phone
    هل يعمل اللاب بدون FXS card

  9. #9
    عضو برونزي الصورة الرمزية SyrianCyclone
    تاريخ التسجيل
    Dec 2005
    المشاركات
    890
    الدولة: Germany
    معدل تقييم المستوى
    14

    رد: VOIP QoS Example

    اقتباس المشاركة الأصلية كتبت بواسطة kamel_s_s مشاهدة المشاركة
    جزاك الله خيرا
    هل لابد من وجود FXS card علي ال router عند عمل الاب علي GNS3 علي هذه الشكل
    PC--->IP phone--->Switch---->Route<....switch<...ip phone
    هل يعمل اللاب بدون FXS card
    ال GNS3 اخي لا يدعم FXS بورت
    تستطيع الاستغناء عنه ب بعمل الاب بدونه أما اوامره تستطيع دراستها و يوجد الكثير من الامثلة عليه
    انا عن نفسي لم أتعمق بالفويس في هذه الفترة و دراستي الان هي هي في كورس BGP و لكن وضعت هذا المثال كتطبيق ل QoS
    [CENTER][COLOR="Red"][SIZE="4"] الموت لكل خائن , خان وطنه و اهله [/SIZE][/COLOR][/CENTER]

    [CENTER][SIGPIC][/SIGPIC][/CENTER]


    [CENTER][IMG]http://folding.extremeoverclocking.com/sigs/sigimage.php?un=SyrianCyclone&t=155660[/IMG][/CENTER]

  10. #10
    عضو الصورة الرمزية kamel_s_s
    تاريخ التسجيل
    Dec 2008
    المشاركات
    456
    معدل تقييم المستوى
    10

    رد: VOIP QoS Example

    اقتباس المشاركة الأصلية كتبت بواسطة SyrianCyclone مشاهدة المشاركة
    ال GNS3 اخي لا يدعم FXS بورت
    تستطيع الاستغناء عنه ب بعمل الاب بدونه أما اوامره تستطيع دراستها و يوجد الكثير من الامثلة عليه
    انا عن نفسي لم أتعمق بالفويس في هذه الفترة و دراستي الان هي هي في كورس BGP و لكن وضعت هذا المثال كتطبيق ل QoS
    جزاك الله خيرا اخي الفاضل وموفق باذن الله في دراستك

  11. #11
    عضو
    تاريخ التسجيل
    Sep 2006
    المشاركات
    234
    الدولة: Syria
    معدل تقييم المستوى
    0

    رد: VOIP QoS Example



    الله يجزيك الخير

المواضيع المتشابهه

  1. voip
    بواسطة hady.elsayed في المنتدى الأرشيف
    مشاركات: 0
    آخر مشاركة: 03-09-2012, 15:12
  2. help me voip
    بواسطة djakiadams في المنتدى الأرشيف
    مشاركات: 1
    آخر مشاركة: 19-11-2011, 01:52
  3. VOIP lab..........
    بواسطة bsma404 في المنتدى الأرشيف
    مشاركات: 8
    آخر مشاركة: 30-05-2008, 19:00
  4. ما هو ال voip ..... ؟
    بواسطة hard1 في المنتدى الأرشيف
    مشاركات: 13
    آخر مشاركة: 28-07-2006, 13:18

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •