صفحة 1 من 2 1 2 الأخيرةالأخيرة
النتائج 1 إلى 15 من 25

الموضوع: شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد

  1. #1
    عضو
    تاريخ التسجيل
    Jan 2010
    المشاركات
    58
    الدولة: Jordan
    معدل تقييم المستوى
    0

    شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد



    السلام عليكم ورحمة الله وبركاته


    توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد




    هذا الرسم التوضيحي للشبكة التي نريد إنشاءها وتوزيع IPs عليها



    أولا اشكر الله تعالى على هذا العلم النافع والحمد له والشكر أيضا للأستاذ لومارك وجزاه الله كل خير على الشرح الوافي لبرنامج Dynamips بالصوت والصورة على الموقع :
    وجميع من ساهم في هذا المنتدى الرائع بهدف إرضاء الله تعالى ودعواكم لنا ونشر العلم , وارجوا في هذه المحاضرة الإطلاع على محاضرات Dynamips لمعرفة إنشاء هذه الشبكة وملف NET وهذا ما بداخله ((مع مراعاة الخط الأحمر يجب تغييره أو تعديله )):
    autostart = False

    [JOJ-PC]

    [[3640]]

    image = c:\Program Files\Dynamips\images\C3640-JK.BIN
    idlepc = 0x604f3e84

    ram = 96
    disk0 = 0
    disk1 = 0
    confreg = 0x2102
    nvram = 256
    mmap = True

    ##############
    [[ROUTER R1]]
    ##############
    console = 2001
    model = 3640

    slot0 = NM-4E
    slot1 = NM-4T

    e0/0 = SW1 f1/1
    e0/1 = NIO_gen_eth:\Device\NPF_{30AAA040-90CF-40B9-9CCF-F337B9A0CF2A}

    ###############
    [[ROUTER SW1]]
    ###############
    console = 2002
    model = 3640
    slot1 = NM-16ESW

    f1/2 = NIO_gen_eth:\Device\NPF_{8B1CFB81-C9CA-466B-A5BF-4D422613CE89}

    f1/6 = NIO_gen_eth:\Device\NPF_{D836A481-B61A-4DB0-A2EC-C9CE70B2B494}

    f1/11 = NIO_gen_eth:\Device\NPF_{345606E7-60D9-4AE3-A909-6DC4B9E2DF66}

    أولا : إعداد Switch :
    كما نعرف وموضح في الصورة أنه يوجد أربعة Vlans كل واحده تخص قسم معين , فلهذا يجب إنشاءهم وحجز الـ Ports لهم :
    ملاحظة : أول Vlan هي افتراضية وتم إنشاءها من قبل ولا نستطيع تغير اسمها لـ Sales ولكن نستطيع استخدامها ووضعها للـ Sales او اي قسم اخر حسب احتياجاتك
    Switch>
    Switch>ena
    Switch#vlan database
    Switch(vlan)#vlan 2 name IT
    VLAN 2 added:
    Name: IT
    Switch(vlan)#Vlan 3 name Accountants
    VLAN 3 added:
    Name: Accountants
    Switch(vlan)#Vlan 4 name Managers
    VLAN 4 added:
    Name: Managers
    الأن تم إنشاء الـ Vlans الأربعة وكما قولنا الأولى أفتراضيه وهي للـ Sales والثانية للـ IT والثالثة للـ Accountants أما الرابعة للـ Managers


    ولرؤية هذا من خلال الأمر : Show Vlan أو Show Vlan- switich


    والأن نريد حجز الـ Ports لكل Vlan :
    Switch#conf t
    Switch(config)#int range f1/2 - 5
    Switch(config-if-range)#switchport mode access
    Switch(config-if-range)#switchport access vlan 2
    Switch(config-if-range)# exit
    Switch(config)#int range f1/6 - 10
    Switch(config-if-range)#switchport mode access
    Switch(config-if-range)#switchport access vlan 3
    Switch(config-if-range)# exit
    Switch(config)#int range f1/11 - 15
    Switch(config-if-range)#switchport mode access
    Switch(config-if-range)#switchport access vlan 4






    ولرؤية هذا من خلال الأمر : Show Vlan أو Show Vlan- switich



    وأخيرا يجب وضع Port بين Switch و Router =<Trunk
    Switch#conf t
    Switch(config)#int f1/1
    Switch(config-if)#switchport mode trunk

    وهكذا تم إعداد الـ Switch ووضع Vlans وبإذن الله تعالى سوف ننتقل الآن لإعداد Routers

    ثانيا : إعداد Router :
    سوف يتم تقسيم Interface إلى Sub-Interfaces وكل واحد خاص لـ Vlan كما هو موضح في صورة :


    Router(config)#int e0/0
    Router(config-if)#full-duplex
    Router(config-if)#duplex full
    Router(config-if)#no ip address
    Router(config-if)#no sh
    Router(config-if)#exit
    Router(config)#int e0/1
    Router(config-if)#ip address 192.168.1.1 255.255.255.0
    Router(config-if)#ip helper-address 192.168.1.2 Ip DHCP Server هنا نحدد
    Router(config-if)#no sh


    تقسيم InterFace إلى Sub-Interfaces وإعطائهم Default Gateway وتحديد Vlan الخاصة لكل منهم الآن :

    Router(config)#int e0/0.2


    رقم 2 تعني Vlan الثانيهRouter(config-subif)#encapsulation dot1Q 2


    Router(config-subif)#ip address 192.168.2.1 255.255.255.0

    Router(config-subif)#ip helper-address 192.168.1.2
    Router(config-subif)#exit

    Router(config)#int e0/0.3
    Router(config-subif)#encapsulation dot1Q 3
    Router(config-subif)#ip address 192.168.3.1 255.255.255.0
    Router(config-subif)#ip helper-address 192.168.1.2
    Router(config-subif)#exit

    Router(config)#int e0/0.4
    Router(config-subif)#encapsulation dot1Q 4
    Router(config-subif)#ip address 192.168.4.1 255.255.255.0
    Router(config-subif)#ip helper-address 192.168.1.2
    Router(config-subif)#exit





    ولتأكد ورؤية ما تم عمله من خلال الأمر : Show ip interface brief



    ثالثا : إعداد DHCP Server :

    يجب أولا إعداد كرت الشبكة في جهاز Server ووضع الـ IP الخاص به كما في الصورة :






    ثم تنزيل DHCP Service من خلال :
    Start -> Control Panel -> Add/Remove Programs -> Add/Remove Windows Components -> Networking Services -> Select Dynamic Host Configuration Protocol (DHCP)
    مع مراعاة وجود Windows Server 2003 CD في الجهاز عند تنزيل DHCP Service



    والآن هي مرحلة عمل الـ Scopes بعد فتح DHCP وعمل Authorize له (( إن كان ضمن Domain )) :
    أول Scope سوف يكون للـ Sales وبنفس هذه الخطوات نستطيع عمل الـ Scope للـ IT وغيره












    وهنا نستطيع حجز IPs لمنع الـ Dhcp Scope إعطاءها للآخرين








    أما هنا يتم وضع Default gateway الخاص لكل Vlan




    يرجى تعلم DHCP Scope ,




    لمعرفة التطبيقات والإجراءات اللازم إعدادها لموافقة شروط شبكة العمل لديك , وبعد أنشاء الـScope




    Vlan تظهر لنا الصورة التالي الخاصة لكل






    رابعا : إعداد Client :
    يجب التحقق أن Local Network Connection موضوع على









    وفي النهاية يجب عمل Repair لل Network Adapter أو Restart للجهاز .... عندها الأجهزة في Sales Vlan سوف تحصل علىIPs الخاصة بها كما في الصورة :



    أما الأجهزة في IT Vlan سوف تحصل علىIPs الخاصة بها كما في الصورة :



    أما الأجهزة في Accountants Vlan سوف تحصل علىIPs الخاصة بها مع ملاحظة مهم وهي تطبيق الأمرين في صورة في حالة وجود IP من قبل ونريد وضع IP آخر جديد :




    أما الأجهزة في Managers Vlan سوف تحصل علىIPs الخاصة بها كما في الصورة :





    وفي النهاية أرجوا أنني أتمت الصورة الكافية لكيفية توزيع IPS للـ Vlans من خلال DHCP Server واحد فقط مع مراعاة Router يدعم IP Helper


    اللهم تقبل عملنا ولا تحرمنا الأجر والعلم والرزق والعمل الطيب وأنتم يا أخوة لا تحرمونا من دعواتكم والدعاء لوالدي وباقي المسلمين الذين سبقونا لدار الآخرة ويجعل قبورهم وقبورنا روضة من رياض الجنة وليست حفرة من حفر النار





    وهنا عملت الكورس في ملف PDF على الرابط









  2. #2
    عضو فضي الصورة الرمزية internetworld
    تاريخ التسجيل
    Jul 2008
    المشاركات
    1,735
    الدولة: Egypt
    معدل تقييم المستوى
    14

    رد: توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد

    جزاك الله كل خير
    شرح جميل .......................بارك الله فيك

  3. #3
    عضو فضي الصورة الرمزية dr_timoon
    تاريخ التسجيل
    Apr 2005
    المشاركات
    996
    الدولة: Egypt
    معدل تقييم المستوى
    15

    رد: شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد

    ما شاء الله عليك اخى الكريم
    شرح رائع جدا جدا و اسولب متميز
    لم استطيع ترك الموضوع حتى اكملت المقالة الى النهاية
    جزاك الله كل الخير
    منتظرين جديدك
    Remember Arabhardware is a community, let's keep it that way. If you understand the word "community" - then you understand this forum

  4. #4
    عضو الصورة الرمزية hamidh
    تاريخ التسجيل
    Jul 2007
    المشاركات
    320
    معدل تقييم المستوى
    0

    رد: شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد

    جزاك الله خير اخي
    سبحان الله وبحمدهـ ... سبحان الله العظيم

    سبحان الله !! حقاً يصبح الإنسان مبدعاً عندما يفكر!!

  5. #5
    عضو الصورة الرمزية a_baidak
    تاريخ التسجيل
    Aug 2007
    المشاركات
    170
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد

    والله العظيم رائع جدا جدا جدا

    ديه مشكله بتقابل ناس كتيره فعلا

    بارك الله فيك مقال رائع بجد

    جزاك الله كل خير وجعله الله في ميزان حسناتك باذن الله

  6. #6
    عضو الصورة الرمزية sysadmin2000
    تاريخ التسجيل
    Mar 2009
    المشاركات
    169
    الدولة: Kuwait
    معدل تقييم المستوى
    0

    رد: شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد

    جزاك الله خير ومشكور على المجهود الاكثر من رائع

    بس ليا استفسار بسيط ... انا عندى dc هل لما اعطى interface الفيزيكال على الراوتر واحوله سب انتر فيس واعطى لكل شبكه gateway مختلف هل لازم اضع ال dns الاساسى موحد لكل الاجهزه على كل vlans علشان يستطيعوا يشوفوا السيرفر .

    ثانيا
    2 - هل كلهم حيقدروا يشوفوا انترنت بدون مشاكل

  7. #7
    عضو فضي الصورة الرمزية hisham_munshar
    تاريخ التسجيل
    Nov 2006
    المشاركات
    2,595
    الدولة: Palestinian Territory
    معدل تقييم المستوى
    14

    رد: شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد

    مشكور و جزاك الله كل خير

  8. #8
    عضو
    تاريخ التسجيل
    Oct 2010
    المشاركات
    25
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    0

    رد: شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد

    حقيقة ابدعت ,, والله عمل رائع جزاك الله الف خير

  9. #9
    عضو
    تاريخ التسجيل
    Aug 2009
    المشاركات
    133
    معدل تقييم المستوى
    9

    رد: شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد

    بصراحة تسلم ايدك

  10. #10
    عضو
    تاريخ التسجيل
    Feb 2009
    المشاركات
    81
    الدولة: Syria
    معدل تقييم المستوى
    0

    رد: ابداع

    حبيت أتشكرك على الشرح الرائع
    والله بصراحة ابدعت كتيير

  11. #11
    عضوية جديدة
    تاريخ التسجيل
    Mar 2011
    المشاركات
    8
    معدل تقييم المستوى
    0

    رد: شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد

    السلام عليكم

    سلمت من كل مكروه

    وحفظك الله وزادك من العلم

  12. #12
    عضوية جديدة
    تاريخ التسجيل
    Nov 2009
    المشاركات
    50
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    0

    Question رد: شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد

    جزاك الله خيرا على هذا الموضوع الرائع ولكن انا عندي سؤال اذا كنت عايز تربط كل scops بالانترنت وعند isa server واحد و domain and dns server واحد كيف يكمن ربط جميع scops معهم

  13. #13
    عضو
    تاريخ التسجيل
    Jan 2010
    المشاركات
    58
    الدولة: Jordan
    معدل تقييم المستوى
    0

    رد: شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد

    من الممكن في اعداد Scopes تشير لنفس Domain controller IP وان تضع Default route 0.0.0.0 حيث Default gateway له هو الايزا أو من الممكن ان تضع proxy server هو الايزا للجميع ولكن هذا يحتاج كل Networks IDs أو Vlans الاتصال مع نفس الـ VLAN التي تحتوي على الايزا والدومين ...... الخ

  14. #14
    عضوية جديدة
    تاريخ التسجيل
    Nov 2009
    المشاركات
    50
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    0

    Unhappy رد: شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد

    هل يعني اضيف امر ip route 0.0.0.0 0.0.0.0 f0/1 لراوتر ليرى isa server والبتالي سوف يصل انترنت

  15. #15
    عضو
    تاريخ التسجيل
    Aug 2009
    المشاركات
    80
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: شرح توزيـــــــع الـ IPs على Vlans من خلال DHCP Server واحد



    اقتباس المشاركة الأصلية كتبت بواسطة lavandr مشاهدة المشاركة
    هل يعني اضيف امر ip route 0.0.0.0 0.0.0.0 f0/1 لراوتر ليرى isa server والبتالي سوف يصل انترنت
    بالظبط كدة
    بالاضافة انك هتخلي الايزا سيرفر يعمل NAT او تسطب ال Routing علي السيرفر بحيث كل الكمبيوترات اللي في ال Vlans تطلع ب Real IP واحد علي النت

صفحة 1 من 2 1 2 الأخيرةالأخيرة

المواضيع المتشابهه

  1. Linksys access point WAP610N does not forward dhcp requests to the dhcp server
    بواسطة Gawad في المنتدى الأرشيف
    مشاركات: 0
    آخر مشاركة: 16-06-2012, 17:28
  2. ربط عدة vlans مع الانترنت عن طريق isa server
    بواسطة lavandr في المنتدى الأرشيف
    مشاركات: 1
    آخر مشاركة: 26-05-2011, 08:53
  3. DHCP Server VLANS in GNS3 فيديو عربي
    بواسطة Gawad في المنتدى الأرشيف
    مشاركات: 10
    آخر مشاركة: 29-11-2010, 11:48
  4. Vlans and Isa server
    بواسطة abadsharona82 في المنتدى منتدى الشهادات العام
    مشاركات: 28
    آخر مشاركة: 19-01-2010, 08:24

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •