النتائج 1 إلى 5 من 5

الموضوع: سؤال VPN لماذا كل هذه ال Static Routing ؟

  1. #1
    عضو الصورة الرمزية abo Abdullah
    تاريخ التسجيل
    Jul 2008
    المشاركات
    211
    معدل تقييم المستوى
    0

    Exclamation سؤال VPN لماذا كل هذه ال Static Routing ؟



    السلام عليكم يا شباب

    حقيقة أني مواصل في دراسة TSHOOT لكن واجهتني قضية في مثال خاص بالVPN وهو في صفحة 456 لمن لديه كتاب CCNP Official Certification Guide.

    صورة الTopology هي:



    سؤالي هو مامعنى الأسطر التي باللون الأحمر في اعدادات الراوتر HQ، يبدو لي الأمر غريبا جدا؟؟


    أما الاعدادات فهي:

    HQ# show run
    ...OUTPUT OMITTED...
    hostname HQ
    !
    crypto isakmp policy 1
    encr 3des
    authentication pre-share
    group 2
    !
    crypto isakmp policy 2
    encr aes
    authentication pre-share
    group 2
    crypto isakmp key cisco address 172.16.1.2
    !
    crypto ipsec transform-set TSHOOT-TRANSFORM esp-aes esp-sha-hmac
    !
    crypto map SDM_CMAP_1 1 ipsec-isakmp
    description Tunnel to172.16.1.2
    set peer 172.16.1.2
    set transform-set TSHOOT-TRANSFORM
    match address 100
    !
    interface Tunnel0
    ip address 10.1.1.1 255.255.255.252
    ip mtu 1420
    tunnel source 172.16.1.1
    tunnel destination 172.16.1.2
    tunnel path-mtu-discovery
    crypto map SDM_CMAP_1
    !
    interface FastEthernet0/0
    ip address 192.168.1.29 255.255.255.0
    !
    interface Serial1/0
    ip address 172.16.1.1 255.255.255.0
    encapsulation ppp
    crypto map SDM_CMAP_1
    !
    ip route 0.0.0.0 0.0.0.0 Tunnel0
    ip route 10.1.1.0 255.255.255.0 172.16.1.2
    ip route 172.16.1.2 255.255.255.255 Serial1/0

    !
    !
    access-list 100 remark SDM_ACL Category=4
    access-list 100 permit gre host 172.16.1.1 host 172.16.1.2
    !
    ...OUTPUT OMITTED...

    أما إعدادات الراوتر الآخر فهي:

    BR# show run
    ...OUTPUT OMITTED...
    hostname BR
    !
    crypto isakmp policy 1
    encr 3des
    authentication pre-share
    group 2
    !
    crypto isakmp policy 2
    encr aes
    authentication pre-share
    group 2
    crypto isakmp key cisco address 172.16.1.1
    !
    crypto ipsec transform-set TSHOOT-TRANSFORM esp-aes esp-sha-hmac
    !
    crypto map SDM_CMAP_1 1 ipsec-isakmp
    set peer 172.16.1.1
    set transform-set TSHOOT-TRANSFORM
    match address SDM_1
    !
    interface Tunnel0
    ip address 10.1.1.2 255.255.255.252
    ip mtu 1420
    tunnel source 172.16.1.2
    tunnel destination 172.16.1.1
    tunnel path-mtu-discovery
    crypto map SDM_CMAP_1
    !
    interface FastEthernet0/0
    ip address 10.2.2.1 255.255.255.0
    !
    interface Serial1/0
    ip address 172.16.1.2 255.255.255.0
    encapsulation ppp
    !
    ip route 0.0.0.0 0.0.0.0 Tunnel0
    ip route 10.1.1.0 255.255.255.0 172.16.1.1
    ip route 172.16.1.1 255.255.255.255 Serial1/0
    !
    ip access-list extended SDM_1
    remark SDM_ACL Category=4
    permit gre host 172.16.1.2 host 172.16.1.1
    ...OUTPUT OMITTED...

    سؤالي هو مامعنى هذه الأسطر باللون الأحمر، يبدو لي الأمر غريبا جدا؟؟
    الصور المرفقة الصور المرفقة
    رأيت الذنوب تميت القلوب *** وقد يورث الذل إدمانها
    وترك الذنوب حياة القلوب *** وخير لنفسك عصيانها


    Telecom Engineer

  2. #2
    عضو برونزي
    تاريخ التسجيل
    May 2007
    المشاركات
    1,475
    معدل تقييم المستوى
    12

    رد: سؤال VPN لماذا كل هذه ال Static Routing ؟

    ip route 0.0.0.0 0.0.0.0 Tunnel0
    ip route 10.1.1.0 255.255.255.0 172.16.1.2
    ip route 172.16.1.2 255.255.255.255 Serial1/0


    الاول والثاني عادي
    بس اللي انا مستغربه الروت التالت
    مهو كدا كدا هيشوفه لانه Direct Connected
    ولا انا فاهم غلط ؟؟؟

    -------------------------------------------
    [B][SIZE=4]فين الاسئله يا شباب في اقسام Cisco
    عاوزين اسئله في الVoice و الData
    عاوزين نقدر نفدكم [/SIZE][/B]

  3. #3
    عضو الصورة الرمزية abo Abdullah
    تاريخ التسجيل
    Jul 2008
    المشاركات
    211
    معدل تقييم المستوى
    0

    Exclamation رد: سؤال VPN لماذا كل هذه ال Static Routing ؟

    مبارك عليك الشهر يا بشمهندس وعلى جميع أعضاء المنتدى وكل المسلمين.

    أولا: مشكور على المرور

    ثانيا: طيب لو أردت مراجعة ما فهمته أنا. السطر الأول يقوم بجعل ال default route لهذا الراوتر هو الtunnel


    أما السطر الثاني فهو يقوم بتوجيه أي شيء مرسل إلى 10.1.1.0 إلى 172.16.1.2 والذي يفترض أن يكون هو الآي بي الخاص بالمخرج: Interface Serial 1/0


    السطر الثالث وهو الغريب يبدو أنه يقوم بتوجيه ما يرسل إلى الآي بي 172.16.1.2 إلى المخرج: Interface Serial 1/0 .

    حسب فهمي يجب أن يكون الآي بي 172.16.1.2 متصلا مع ال Serial Interface أي لا داعي لل Static Route ولأن الأولوية للConnected على الStatic فما الفائدة من هذا الأمر وهل يمكن أن يقوم بأي حال من الأحوال بتوجيه البيانات إلى الTunnel ؟؟؟:err:


    أين بقية المشرفين وأين الأستاذ ياسر؟
    رأيت الذنوب تميت القلوب *** وقد يورث الذل إدمانها
    وترك الذنوب حياة القلوب *** وخير لنفسك عصيانها


    Telecom Engineer

  4. #4
    عضوية جديدة
    تاريخ التسجيل
    Jul 2009
    المشاركات
    1
    الدولة: Palestinian Territory
    معدل تقييم المستوى
    0

    رد: سؤال VPN لماذا كل هذه ال Static Routing ؟

    السطر الثاني خصص الشبكة 10.1.1.0 للوصول عبر السيريال
    السطر الثالث يعتبر لاغي لوجود الشبكة موصوله بشكل مباشر مع الراوتر والله اعلم

  5. #5
    عضو
    تاريخ التسجيل
    Sep 2009
    المشاركات
    76
    الدولة: Zimbabwe
    معدل تقييم المستوى
    0

    رد: سؤال VPN لماذا كل هذه ال Static Routing ؟



    ip route 0.0.0.0 0.0.0.0 Tunnel0

    اي ترافيك تخرج عن طريق
    Tunnel 0




    ================================================== ================
    ip route 172.16.1.2 255.255.255.255 Serial1/0


    دائما نكتب هذا الروت لتحديد مسار destination الموجود في
    Tunnel ويكون full subnet بمعنى /32
    ================================================== ======================
    -------------------------------------------------------------------

    هذا السطر اعتقد انه يمكن الاستغناء عنه ولكن هذا تفسيرة


    ip route 10.1.1.0 255.255.255.0 172.16.1.2


    هذا الروت خاص بتوجيه مسار tunnel ip وهي في كلا الحالات سوف تخرج مع default route الموجود في السطر الاول


المواضيع المتشابهه

  1. هل يمكن عمل static and dynamic routing على نفس الراوتر
    بواسطة abdellaah في المنتدى الأرشيف
    مشاركات: 15
    آخر مشاركة: 03-03-2011, 07:18
  2. (عنوان معدل ) طلب شرح عن ال static routing
    بواسطة mr/seif في المنتدى الأرشيف
    مشاركات: 2
    آخر مشاركة: 18-01-2011, 13:51
  3. سؤال عن Static Routing
    بواسطة fatehalmsddi في المنتدى الأرشيف
    مشاركات: 6
    آخر مشاركة: 04-12-2010, 20:10
  4. سؤال فى static Routing بالصورة !
    بواسطة the_way2allah في المنتدى الأرشيف
    مشاركات: 6
    آخر مشاركة: 13-02-2009, 01:07
  5. Static Routing In ISA 2004
    بواسطة old friend في المنتدى الأرشيف
    مشاركات: 4
    آخر مشاركة: 14-08-2006, 14:41

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •