صفحة 1 من 2 1 2 الأخيرةالأخيرة
النتائج 1 إلى 15 من 19

الموضوع: مشكله السيرفر في ال Vlan

  1. #1
    عضو
    تاريخ التسجيل
    Jul 2008
    المشاركات
    100
    معدل تقييم المستوى
    0

    مشكله السيرفر في ال Vlan



    بسم الله الرحمن الرحيم

    السلام عليكم و رحمه الله و بركاته....

    اخواني لدس مشكله في ال vlan ,عندي سيرفر يعمل كا DC و شابكه على سوتش سسكو و لكن عند عمل vlan السيرفر لا يرى الاجهزه مع العلم ان البورت المشبوك عليه Trunk port ما المشكله اخواني ؟؟ و اللاجهزه ايضا لا تعمل Ping على الراوتر....اترككم مع الصوره اوضح...




    المطلوب اخواني ان ابقي على ال Vlan و ان اجعل السيرفر يرى كل الاجهزه و على اللاجهزه ايضا ان تعمل بينج للروتر...

    بارك الله فيكم اخواني....

  2. #2
    عضو برونزي الصورة الرمزية Gawad
    تاريخ التسجيل
    Nov 2009
    المشاركات
    1,933
    معدل تقييم المستوى
    18

    رد: مشكله السيرفر في ال Vlan

    بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه أجمعين

    نبدأ الأول من أسفل: استخدم الأمر show cdp ne detail وشوف السويتش والراوتر شايفين بعض ولا لأ، وكمان شوف السويتش شايف الأجهزة والسيرفير ولا لأ، استخدم كمان الأمر show mac add table وهكذا لو شايفين بعض تمام ننتقل للمرحلة التانية مع الl3
    جرب وقولنا ايه النتيجة إن شاء الله

    ولا تنسني والمسلمين من صالح الدعاء
    وصلي الله وسلم وبارك علي المصطفي وآله وصحبه وإخوانه أجمعين
    [CENTER][SIZE=4][COLOR=Blue]اللهم صلي على محمد وعلى آل محمد كما صليت على آل إبراهيم وبارك على محمد وعلى آل محمد كما باركت على آل إبراهيم في العالمين إنك حميد مجيد[/COLOR][/SIZE]

    [B][SIZE=4]اللهم احفظ مصر آمنة مطمئنة وسائر بلاد المسلمين
    اللهم قنا الفتن ما ظهر منا وما بطن
    [/SIZE][/B]
    [/CENTER]

  3. #3
    عضو
    تاريخ التسجيل
    Jul 2008
    المشاركات
    100
    معدل تقييم المستوى
    0

    رد: مشكله السيرفر في ال Vlan

    بارك الله فيك اخي,أي نعم السوتش شايف الراوتر و العكس ايضا:

    SW1#sh cdp ne detail

    Device ID: R1
    Entry address(es):
    IP address : 192.168.0.1
    Platform: cisco C2800, Capabilities: Router
    Interface: FastEthernet0/1, Port ID (outgoing port): FastEthernet0/1
    Holdtime: 140

    Version :
    Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2007 by Cisco Systems, Inc.
    Compiled Wed 18-Jul-07 06:21 by pt_rel_team

    advertisement version: 2
    Duplex: full

    --------------------------------------------------------------------

    R1#sh cdp ne detail

    Device ID: SW1
    Entry address(es):
    Platform: cisco 2960, Capabilities: Switch
    Interface: FastEthernet0/1, Port ID (outgoing port): FastEthernet0/1
    Holdtime: 133

    Version :
    Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX, RELEASE SOFTWARE (fc1)
    Copyright (c) 1986-2005 by Cisco Systems, Inc.
    Compiled Wed 12-Oct-05 22:05 by pt_team

    advertisement version: 2
    Duplex: full

    -----------------------------------------------------------------------
    و عند اضهار ال MAC يخرج التالي::

    SW1#sh mac-address-table
    Mac Address Table
    -------------------------------------------

    Vlan Mac Address Type Ports
    ---- ----------- -------- -----

    1 00e0.f927.8902 DYNAMIC Fa0/1
    SW1#
    _______________________________

    ما المشكله يا طيب؟؟

  4. #4
    عضو برونزي الصورة الرمزية Gawad
    تاريخ التسجيل
    Nov 2009
    المشاركات
    1,933
    معدل تقييم المستوى
    18

    رد: مشكله السيرفر في ال Vlan

    بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه أجمعين

    و عند اضهار ال MAC يخرج التالي::


    Mac Address Table
    -------------------------------------------

    Vlan Mac Address Type Ports
    ---- ----------- -------- -----

    1 00e0.f927.8902 DYNAMIC Fa0/1
    SW1#

    معني كده ان السويتش مش شايف الأجهزة ولا السيرفير، تأكد إن البورتات علي السويتش مشshut down، وتأكد إن البورتات هذه الcdp مفعل عليها، وعامة فعل الcdp السويتش كله من جديد بالأمر cdp run من الprivilege mode، وياريت لو حضرتك تضع الconfig كوبي بست هنا علشان بس تكون العملية أوضح إن شاء الله

    وصلي الله وسلم وبارك علي المصطفي وآله وصحبه وإخوانه أجمعين
    SW1#sh mac-address-table ولا تنسني والمسلمين من صالح الدعاء
    وصلي الله وسلم وبارك علي المصطفي وآله وصحبه وإخوانه أجمعين
    [CENTER][SIZE=4][COLOR=Blue]اللهم صلي على محمد وعلى آل محمد كما صليت على آل إبراهيم وبارك على محمد وعلى آل محمد كما باركت على آل إبراهيم في العالمين إنك حميد مجيد[/COLOR][/SIZE]

    [B][SIZE=4]اللهم احفظ مصر آمنة مطمئنة وسائر بلاد المسلمين
    اللهم قنا الفتن ما ظهر منا وما بطن
    [/SIZE][/B]
    [/CENTER]

  5. #5
    عضو
    تاريخ التسجيل
    Jul 2008
    المشاركات
    100
    معدل تقييم المستوى
    0

    رد: مشكله السيرفر في ال Vlan

    بارك الله فيك اخي....لقد قمت بتفعيل cdp من جديد و لكن نفس النتيجه و اليك ال Configration

    SW1#sh run
    Building configuration...

    Current configuration : 1265 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname SW1
    !
    !
    !
    interface FastEthernet0/1
    switchport mode trunk
    !
    interface FastEthernet0/2
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/3
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/4
    switchport access vlan 3
    switchport mode access
    !
    interface FastEthernet0/5
    switchport access vlan 3
    switchport mode access
    !
    interface FastEthernet0/6
    switchport mode trunk
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    interface Vlan1
    ip address 192.168.0.7 255.255.255.0
    !
    !
    line con 0
    !
    line vty 0 4
    login
    line vty 5 15
    login
    !
    !
    end

  6. #6
    عضو
    تاريخ التسجيل
    Jul 2008
    المشاركات
    100
    معدل تقييم المستوى
    0

    رد: مشكله السيرفر في ال Vlan

    بارك الله فيك اخي....لقد قمت بتفعيل cdp من جديد و لكن نفس النتيجه و اليك ال Configration

    SW1#sh run
    Building configuration...

    Current configuration : 1265 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname SW1
    !
    !
    !
    interface FastEthernet0/1
    switchport mode trunk
    !
    interface FastEthernet0/2
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/3
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/4
    switchport access vlan 3
    switchport mode access
    !
    interface FastEthernet0/5
    switchport access vlan 3
    switchport mode access
    !
    interface FastEthernet0/6
    switchport mode trunk
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    interface Vlan1
    ip address 192.168.0.7 255.255.255.0
    !
    !
    line con 0
    !
    line vty 0 4
    login
    line vty 5 15
    login
    !
    !
    end

  7. #7
    عضو برونزي الصورة الرمزية Gawad
    تاريخ التسجيل
    Nov 2009
    المشاركات
    1,933
    معدل تقييم المستوى
    18

    رد: مشكله السيرفر في ال Vlan

    بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه أجمعين

    طيب هوه حضرتك عملت allow للvlans علي الترنكات؟

    inter f0/1
    sw mod tr
    sw tr nat vla 1
    sw tr allowed vlan all

    وايضا بالنسبة للبورت المشبوك علي السيرفير

    معلش انا طولت عليك بس طبعا الجهاز مش قدامي فمعلش علي كتر الأسئلة
    وصلي الله وسلم وبارك علي المصطفي وآله وصحبه وإخوانه أجمعين
    [CENTER][SIZE=4][COLOR=Blue]اللهم صلي على محمد وعلى آل محمد كما صليت على آل إبراهيم وبارك على محمد وعلى آل محمد كما باركت على آل إبراهيم في العالمين إنك حميد مجيد[/COLOR][/SIZE]

    [B][SIZE=4]اللهم احفظ مصر آمنة مطمئنة وسائر بلاد المسلمين
    اللهم قنا الفتن ما ظهر منا وما بطن
    [/SIZE][/B]
    [/CENTER]

  8. #8
    عضو
    تاريخ التسجيل
    Jul 2008
    المشاركات
    100
    معدل تقييم المستوى
    0

    رد: مشكله السيرفر في ال Vlan

    بارك الله فيك اخي و جزاك الجنه و وسع عليك رزقك و جزاك عني خيرا....

    اي نعم اخي allow للترنكات و لكن اعتقد ان المشكه موجوده بسسب ان السوتش لا يرى الاجهزه و الا السيرفر ولاكت لا اعلم لماذا مع العلم ان Vlan 2 و vlan 3 تعمل بأكمل و جه و اجهزه الVlan 2 لا ترى اجهزه ال vlan 3 و عند عمل sh mac يضهر التالي كالعاده:

    SW1#sh mac-address-table
    Mac Address Table
    -------------------------------------------

    Vlan Mac Address Type Ports
    ---- ----------- -------- -----

    1 00e0.f927.8902 DYNAMIC Fa0/1
    SW1#

    لا اعلم ما الحل اخي ....جنني هالسوتش !!!

  9. #9
    عضو برونزي الصورة الرمزية Gawad
    تاريخ التسجيل
    Nov 2009
    المشاركات
    1,933
    معدل تقييم المستوى
    18

    رد: مشكله السيرفر في ال Vlan

    بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه أجمعين

    طيب بالنسبة للسيرفير انت مش حاطه في vlan؟؟
    علشان هوه لازم يكون في vlan علي subinterface علي الانترفيس بتاع الراوتر علشان يقدر يلاقي gateway
    طيب لو نراجع الكونفج علي الراوتر :
    علي الانترفيس بتاع الراوتر نعمل subinterfaces:
    inter f0/0
    no sh

    inter f0/0.2
    enca dot1q 2
    ip add xxxx xxxx
    interf0/0.3
    enca dot1q 3
    ip add xxx xxx
    inter f0/0.4 هذه vlan للسيرفير
    enca dot1q 4
    ip add xxxx xxxx
    وبعدين روح علي السيرفير وضع الgateway الايبي السابق
    جرب وقولنا ايه النتيجة إن شاء الله

    ولا تنسني والمسلمين من صالح الدعاء
    وصلي الله وسلم وبارك علي المصطفي وآله وصحبه وإخوانه أجمعين
    [CENTER][SIZE=4][COLOR=Blue]اللهم صلي على محمد وعلى آل محمد كما صليت على آل إبراهيم وبارك على محمد وعلى آل محمد كما باركت على آل إبراهيم في العالمين إنك حميد مجيد[/COLOR][/SIZE]

    [B][SIZE=4]اللهم احفظ مصر آمنة مطمئنة وسائر بلاد المسلمين
    اللهم قنا الفتن ما ظهر منا وما بطن
    [/SIZE][/B]
    [/CENTER]

  10. #10
    عضو
    تاريخ التسجيل
    Jul 2008
    المشاركات
    100
    معدل تقييم المستوى
    0

    رد: مشكله السيرفر في ال Vlan

    بارك الله فيك يا طيب و جزاك اللجنه و وفقك لما يحب و يرضا.....تم حل المشكله و ذللك بفضل من الله و بفضل منك يا طيب,تم حل المشكله بتباع التالي:

    1-تم عمل Subinterface لكل vlan بالشبكه
    2-تم عمل vlan خاصه بالسيرفر
    3-تم عمل ما يسمى بال Routing between Vlan
    4-عند اظهار ال Mac يظهر التالي:

    SW1#sh mac-address-table
    Mac Address Table
    -------------------------------------------

    Vlan Mac Address Type Ports
    ---- ----------- -------- -----

    1 00e0.f927.8902 DYNAMIC Fa0/1
    2 00e0.f927.8902 DYNAMIC Fa0/1
    3 00e0.f927.8902 DYNAMIC Fa0/1
    4 00e0.f927.8902 DYNAMIC Fa0/1
    SW1#
    ولكن عندي ملاحظه اخي,الان كل ال vlan ترى بعضها البعض,انا اريد السيرفر فقط ان يرى كل الاجهزه و الاجهزه الباقيه ان ترى بعضها فقط حسب ال vlan التابعه له,هل من حل اخي...

    جزاك عني خيرا...

  11. #11
    عضو برونزي الصورة الرمزية Gawad
    تاريخ التسجيل
    Nov 2009
    المشاركات
    1,933
    معدل تقييم المستوى
    18

    رد: مشكله السيرفر في ال Vlan

    بسم الله والحمد لله والصلاة و السلام علي رسول الله وآله وصحبه وإخوانه أجمعين

    الحمد لله، طيب السيرفير عليه ايه يعني هل هوه ftp http mail ,>>>>> هنا انت ممكن تعمل access list إن شاء الله، ياريت اعرف ايه الخدمة اللي بيقدمها السيرفير وعلي اساسها يمكن كتابة الاكسس ليست إن شاء الله

    وصلي الله وسلم وبارك علي المصطفي وآله وصحبه وإخوانه أجمعين
    [CENTER][SIZE=4][COLOR=Blue]اللهم صلي على محمد وعلى آل محمد كما صليت على آل إبراهيم وبارك على محمد وعلى آل محمد كما باركت على آل إبراهيم في العالمين إنك حميد مجيد[/COLOR][/SIZE]

    [B][SIZE=4]اللهم احفظ مصر آمنة مطمئنة وسائر بلاد المسلمين
    اللهم قنا الفتن ما ظهر منا وما بطن
    [/SIZE][/B]
    [/CENTER]

  12. #12
    عضو
    تاريخ التسجيل
    Jul 2008
    المشاركات
    100
    معدل تقييم المستوى
    0

    رد: مشكله السيرفر في ال Vlan

    السيرفر عباره عن Active Directory و Dns اخي.....بارك الله فيك....

  13. #13
    عضو
    تاريخ التسجيل
    Jul 2009
    المشاركات
    49
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: مشكله السيرفر في ال Vlan

    creating Inter Vlans from Router

  14. #14
    عضو
    تاريخ التسجيل
    Jul 2008
    المشاركات
    100
    معدل تقييم المستوى
    0

    رد: مشكله السيرفر في ال Vlan

    بارك الله فيك اخي احمد جواد على متابعتك للموضوع .....لساني عاجز عن شكرك و وفقك الله لمايحب و يرضا....

    استكمالا للموضوع اخي الحبيب.....لماذا نعمل أكسس لست؟؟ انا لا اريد حجب اي بورت على اي جهاز Client عندي...اذا لجأنا لحل ال Access-list سنستغني عن ال Vlan ....أليس كذللك؟؟

    الموضوع ببساطه انه انا اريد عمل اكثر من vlan عندي ....جربت ان اضع السيرفر على Trunk port لأنه انا اعلم ان ال Trunk port ليس تابع لأي vlan و للذلك تسطيع كل ال Vlan رؤيته و التعامل معه أليس كذللك اخي احمد و لكن ذلك لم يجدي نفعا؟؟

    عند عمل Subinterfaces تستطيع ال vlan رؤيه بعضها و هذا اعادنا لنقطه الصفر.....أي نعم منعنا ال Broadcast و لكن بهذه الحركه سنبطأ عمل ال DHCP هذا اذا عملناه على الراوتر و اذا عملناه على السيرفر سيتعطل كلينا ...

    يالنسبه لل ISA سيرفر سيقع بنفس المطب.....لأنه اذا وضعناه ب valn خاصه به فلن تصله الاجهزه و هذه مشكله عظيمه....لأنه بذلك فقدت السيطره على الاجهزه, لأنه ال Gateway للجهزه هو ال ISA Server و ال Gateway لل ISA هو الراوتر...

    في المحصله......ال Active Directory يجب ان يراى كل الاجهزه و ذلك لأدخالها على ال Domain و على ال ISA ان يفعل نفس الشيئ و على كل vlan ان لا ترى الاخره اوليس من اجل هذا اخترعت ؟؟

    بارك الله فيك اخي احمد و جزاك عني خيرا....




  15. #15
    عضو برونزي الصورة الرمزية Gawad
    تاريخ التسجيل
    Nov 2009
    المشاركات
    1,933
    معدل تقييم المستوى
    18

    رد: مشكله السيرفر في ال Vlan



    بسم الله و الحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه أجمعين:

    جزاك الله خيراً أخي الكريم،

    بالنسبة للvlans الغرض الأساسي منها هو تقليل البرودكاست في الشبكة بتقسيم الدومين الكبير إلي دومين صغيرة
    أما لماذا تري الvlans بعضها، ذلك بسبب وجود راوتر هو المسئول عن الinter vlan routing
    نرجع إلي المثال:
    هنا لا نريد الvlans أن تكلم بعضها تمام؟ هنا نحن نفترض أن الأجهزة في الvlans لا توجد عليها خدمات مثلاً سيرفيرات إضافية أو أي خدمة أخري تقدمها لباقي الأجهزة
    عامة انا ما أعرف الأيبيهات عند حضرتك وعلي ذلك افترض الأتي

    vlan 3 192.168.30.0 255.255.255.0
    vlan 2 192.168.20.0 255.255.255.0
    علي الراوتر
    Router(config)#ip access-list standard 10

    Router(config-std-nacl)#remark

    Router(config-std-nacl)#remark deny_client_vlan_talk

    Router(config-std-nacl)#deny 192.168.20.0 0.0.0.255
    Router(config-std-nacl)#permit any

    Router(config-std-nacl)#exit

    Router(config)#inter f0/0.30

    Router(config-subif)#ip access-group 10 out

    وبالتالي هو سوف يمنع vlan 192.168.20.0 إنها تكلم 30، وهنا مش مضطرين نعمل acl علي 20 نفسها لأنه هذه الacl سوف تمنع الرد في العودة
    والله أعلي وأعلم
    ولا تنسني والمسلمين من صالح الدعاء
    وصلي الله وسلم وبارك علي المصطفي وآله وصحبه وإخوانه أجمعين
    [CENTER][SIZE=4][COLOR=Blue]اللهم صلي على محمد وعلى آل محمد كما صليت على آل إبراهيم وبارك على محمد وعلى آل محمد كما باركت على آل إبراهيم في العالمين إنك حميد مجيد[/COLOR][/SIZE]

    [B][SIZE=4]اللهم احفظ مصر آمنة مطمئنة وسائر بلاد المسلمين
    اللهم قنا الفتن ما ظهر منا وما بطن
    [/SIZE][/B]
    [/CENTER]

صفحة 1 من 2 1 2 الأخيرةالأخيرة

المواضيع المتشابهه

  1. مشكله فى السيرفر
    بواسطة akramnssar في المنتدى مشاكل الحاسب وحلولها
    مشاركات: 0
    آخر مشاركة: 11-04-2010, 09:46
  2. مشكله في السيرفر
    بواسطة abdo_osha في المنتدى مشاكل الحاسب وحلولها
    مشاركات: 3
    آخر مشاركة: 06-06-2009, 18:27
  3. مشكله في ال vlan
    بواسطة himaking في المنتدى الأرشيف
    مشاركات: 1
    آخر مشاركة: 12-05-2009, 03:25
  4. مشاركات: 2
    آخر مشاركة: 19-12-2008, 01:03
  5. مشكله في السيرفر ... هل من مساعده
    بواسطة abu zeed abbasi في المنتدى الأرشيف
    مشاركات: 5
    آخر مشاركة: 01-09-2005, 17:54

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •