النتائج 1 إلى 9 من 9

الموضوع: اريد حلولا: الخطوط الاحتياطية

  1. #1
    عضو الصورة الرمزية ACCESS POINT
    تاريخ التسجيل
    Jun 2009
    المشاركات
    129
    معدل تقييم المستوى
    0

    اريد حلولا: الخطوط الاحتياطية



    السلام عليكم ورحمة الله وبركاته

    لدي في العمل شبكة بهذا التصميم



    كما هو واضح من الشكل أن كلBranches موصولة بـخط من ISP1 و HQ موصول بـ Two LINKS من ISP1 حيث أن الخط الأول هو Primary والثاني Backup

    بالنسبة لـ HQ يعمل على BGP Protocol و Branches كلها تعمل على Static Router (Default Route)

    والعمل كله سليم وقائم على أتم ما يرام لكن الحاصل كما في الصورة التالية:



    انه ركبت دوائر جديدة من ISP2 لتكون احتياطية مع العلم أني حصلت على Basic configuration من ISP2 ووجدت AS no. الخاص بـ BGP مختلف بينه وبين ISP1 يعني :

    ISP1: router bgp 65001
    ISP2: router bgp 65002


    فسؤالي هو ما الحلول التي ممكن أن تتخذ للربط وتكون مناسبة وتحقق High Availability & Load balance ؟

    مع العلم ان الروترات كلها ISR1 وكل الخطوط MPLS
    CCNA
    CCNA Security

  2. #2
    عضو الصورة الرمزية ACCESS POINT
    تاريخ التسجيل
    Jun 2009
    المشاركات
    129
    معدل تقييم المستوى
    0

    رد: اريد حلولا: الخطوط الاحتياطية

    معقولة حوالي 50 مشاهده

    و خمسة ايام وﻻ فيه وﻻ رد :eek:
    CCNA
    CCNA Security

  3. #3
    عضو برونزي
    تاريخ التسجيل
    May 2007
    المشاركات
    1,475
    معدل تقييم المستوى
    12

    رد: اريد حلولا: الخطوط الاحتياطية

    للاسف ليس لي علاقه بالMPLS ولكن ما رائيك في ان تستخدم روت ماب وتجعل كل خط يعمل مره او تعمل نات وتستخدم امر rotary
    -------------------------------------------
    [B][SIZE=4]فين الاسئله يا شباب في اقسام Cisco
    عاوزين اسئله في الVoice و الData
    عاوزين نقدر نفدكم [/SIZE][/B]

  4. #4
    عضو محترف الصورة الرمزية Brigadier
    تاريخ التسجيل
    May 2005
    المشاركات
    9,999
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    47

    رد: اريد حلولا: الخطوط الاحتياطية

    جاري دراسة تصميم و حل مناسب , لكن لدي بعض الاسأله:

    هل لديك المقدره على الجلوس و الضبط في HQ Router ? وماذا عن Both Branch Routers ؟

    هل بالفعل ال Bracnh Routers لن يسمح لك باستعمال Dynamic Routing Protocol لغرض تسهيل عمل المطلوب؟

    للتاكد لا اكثر , هل بالفعل BGP مضبوط ويعمل على HQ Router ؟

  5. #5
    عضو الصورة الرمزية ali hamdy
    تاريخ التسجيل
    Apr 2008
    المشاركات
    63
    معدل تقييم المستوى
    10

    رد: اريد حلولا: الخطوط الاحتياطية

    لو حضرتك مقسم الشبكة الداخلية الى شبكتين 192.168.1.0 و 172.16.0.0 مثلا حضرتك ممكن تعمل route-map تماتش فيها الشبكة 192 lمثلا وتديها weight =1000 والشبكة 172 اديها wight =10 وتطبقها على انتر فيس 0/0سيريال اللى هو واصل على isp1
    وتعمل route-map تانية تماتش فيها الشبكة 172 وتديها weight = 1000 والشبكة 192 وتديها wight = 100 وتطبقها مثلا على انترفيس سيريال 1/0 اللى متوصل على isp 2 يبقى حضرتك حققت ال load balance وحققت ال high availability
    وارجو من الاخوة التصحيح لو فى خطا

  6. #6
    عضو محترف الصورة الرمزية Brigadier
    تاريخ التسجيل
    May 2005
    المشاركات
    9,999
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    47

    رد: اريد حلولا: الخطوط الاحتياطية

    اولاً:- راونر الـ Headquarter "HQ" /

    أ- المعطيات
    -راوتر ISR يعمل عليه راوتينج بروتوكول BGP .
    - اثنان من مزودي الخدمه " نشط , ثانوي".
    -ارقام ال AS الخاصة بكل من مزود خدمه أ و ب.

    ب- المطلوب
    -تحقيق التوازن بين الوصلتين باتجاه مزود خدمه أ , و ضبط الوصلة الى مزود ب كنوع ثانوي.

    __________


    لنبدأ في الاعدادات التي تخص ما يحقق لنا هذه المطاليب في راوتر HQ
    هذه الاعدادات سوف تمكن الراوتر من الاتصال بعدد اثنين مزود خدمه مع منع المشكلة الشائعه من جعل الراوتر HQ منطقة انتقاليه , و لعمل Load Sharing سيلزم بعض الاضافات سوف اقوم بذكرها لاحقاً بعد هذه الاعدادات.


    اقتباس المشاركة الأصلية كتبت بواسطة Amaranth
    كود:
    Router BGP 50
    neighbor 10.10.10.10 remote-as 101 
    neighbor 10.10.10.10 route-map LOCAL Out
    !-- This Policy route map is applied locally in  the outband direction to disable the use of your HQ router as a transit  for Both ISPs 
    
    neighbor 10.10.10.10 route-map 101one in
    !-- this is applied to filter out anything not  sourced within First  ISP network , this means only to accept routes  from First ISP which is sourced with its network 
    
    
    neighbor 20.20.20.20 remote-as 102
    neighbor 20.20.20.20 route-map LOCAL Out
    !-- Same note about this command described above 
    
    neighbor 20.20.20.20 route-map 102one in
    
    !-- like said before but this time we will accept only routes sourced with 102 network ISP

    الان سوف نقوم بعمل AS-Path ACL التي سوف نستعملها للروات ماب LOCAL بغرض تطبيق سياسة منع الراوتر المحلي من ان يكون منطقة انتقاليه مابين مزودي الخدمه الاثنين, ولاحظ ان هذه القائمة فقط تسمح بال Local BGP Routes

    كود:
       
    
    ip as-path access-list 10 permit  ^$
    !--   this means that only the locally  originated "^$ " Routes is allowed , anything else is denied because the  nature of the implicit deny
    
    route-map LOCAL permit 10
    match as-path 101
    ايضاً نقوم بعمل قائمتين اضافيتين لكل من الراوت ماب 101one و 102one

    كود:
     
    
    
    ip as-path access-list 20 permit ^101$
    
    route-map 101one permit 10
     match as-path 101!--this for accepting only the routes sourced within 101 ISP network , anything else is no prohibited
     
    ip as-path access-list 30 permit ^102$
    
    route-map 102one permit 10
      match as-path 102

    الان نحتاج الى انشاء Two Default Routes لكي يتم نشرها لبقية اعضاء الشبكة التي تتبع HQ Router

    كود:
      
    
    ip route 0.0.0.0 0.0.0.0 10.10.10.10
    ip route 0.0.0.0 0.0.0.0 20.20.20.20
    الان لا ننسى انه سوف نسمح فقط لل Default Route updates ان تصل لل HQ من مزودي الخدمه "ولانسمح لاي نوع اخر بالدخول" وهذا بتطبيق الاتي IP Prefix List
    نضيف الاتي في Global Config Mode
    كود:
      
    neighbor 10.10.10.10 prefix-list ABC in
    neighbor 20.20.20.20 prefix-list ABC inip prefix-list ABC seq 5 permit 0.0.0.0/0

  7. #7
    عضو محترف الصورة الرمزية Brigadier
    تاريخ التسجيل
    May 2005
    المشاركات
    9,999
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    47

    تابع الرد رقم 2

    * تنويه: تم استعمال بعض الارقام و العناوين بهدف المثال والتوضيح فقط و يجب مراعاة العناوين و الارقام التي تخص AS او الشبكات المستعمله الفعليه لدى البيئة في العمل .


    ____

    ب- راوتر HQ /

    ماتم تحقيقه انفاً:
    -تم تحقيق هدف الاتصال باثنين مزود خدمه مع تلافي المشاكل الشائعة.

    ما تبقى علينا تحقيقه الان:
    -تحقيق موازنه الاحمال بين الوصلتين التي تتصلان بمزود الخدمه الاساسي.

    كود:
     
    
    router bgp 50
    neighbor 10.10.10.10 remote-as 101
    neighbor 10.10.10.10 route-map UPDATES-1 in
    
    !--- This allows only the networks up to 128.0.0.0.
    
    neighbor 30.30.30.30 remote-as 101
    neighbor 30.30.30.30 route-map UPDATES-2 in
    
    !--- This allows anything above the 128.0.0.0 network.
    
    route-map UPDATES-1 permit 10
    match ip address 1
    set weight 100
     
    route-map UPDATES-1 permit 20
    match ip address 2
      
    route-map UPDATES-2 permit 10
    match ip address 1
      
    route-map UPDATES-2 permit 20
    match ip address 2
    set weight 100
      
    access-list 1 permit 0.0.0.0  127.255.255.255
    access-list 2 deny 0.0.0.0 127.255.255.255
    access-list 2 permit any
    مع الاخذ بالاعتبار ان العنوان الافتراضي 30.30.30.30 هو العنوان الذي يمثل الوصلة الاخرى من الوصلتين الى مزود الخدمه الاول.

    طبعاً عامل الموازنه هنا هو تقسيم نطاق عناوين من 0.0.0.0 الى 127.255.255.255 يتم اعطائها weight 100 ليتم تفضيلها مع احد
    الوصلتين المتجهتان نفس مزود الخدمه.

    من 128.0.0.0 واكبر سوف يتم اعطائها نفس الوزن ولكن مع الوصلة الاخرى ليتم تفضيل هذا
    النطاق من العناوين ونقله على هذه الوصله .

    وبذلك نكون قد حققنا هدف الموازنه في استعمال الوصلتين.

  8. #8
    عضو محترف الصورة الرمزية Brigadier
    تاريخ التسجيل
    May 2005
    المشاركات
    9,999
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    47

    الجزء الاخير

    *الجزء الخاص بـ Branch Routers

    ما اعطيته لي من معطيات تفترض تحتيم اللجوء فقط الى اسلوب ال Static Routes مما سوف يجعل الحل المقدم ليس بدقة المطلوب بشكل كبير لكنه يبقى حل يحقق ولو بشكل نسبي ما اشرت اليه .

    - الفكره:
    تتبلور الفكرة حول استعمال
    static default route ليوصلنا لمزود الخدمه الاساسي , ونستعمل floating static default route ليوصلنا بمزود الخدمه الاحتياطي او الثاني .

    طبعاً سوف تقوم بهذا الشيء مع كل راوتر على حده.

    كود:
    ip route 0.0.0.0 0.0.0.0 Serial0 /1
    ip route 0.0.0.0 0.0.0.0 Serial1 /2
    طبعاً مع اختيار الinterfaces الصحيحه "لان هذا مجرد مثال " حيث كل الاولى هنا تقود الى المزود الاساسي الاول , والثانيه تشير للثاني الاحتياطي.

    ...

    اتمنى ان اكون قد افدتك ولو بالقليل, ولو فيه اضافات او تعديلات من الاخوه ارجو الا يبخلو بشيء.


    موفق.


    أخوك/نادر.

  9. #9
    عضو الصورة الرمزية ACCESS POINT
    تاريخ التسجيل
    Jun 2009
    المشاركات
    129
    معدل تقييم المستوى
    0

    رد: اريد حلولا: الخطوط الاحتياطية



    جزاكم الله خير واسف على التاخير في الرد

    لكن انا حاليا جاس افاوض SP على انه يوحد رقم BGP من جهتي هل هذا الحل ممكن وينفع مع العلم ان الشركتين مختلفتين
    CCNA
    CCNA Security

المواضيع المتشابهه

  1. مشكلة فى اتخاذ النسخة الاحتياطية على ويندوز سيرفير 2003
    بواسطة بحبك يا غايب في المنتدى مشاكل الحاسب وحلولها
    مشاركات: 0
    آخر مشاركة: 29-01-2013, 14:52
  2. مشاركات: 52
    آخر مشاركة: 04-06-2009, 05:31
  3. بخصوص النسخة الاحتياطية
    بواسطة ماريو2002 في المنتدى الأرشيف
    مشاركات: 0
    آخر مشاركة: 04-02-2009, 07:49
  4. مشاركات: 1
    آخر مشاركة: 30-10-2008, 17:32
  5. مشكلة مع MSI RC410 M2 في النسخ الاحتياطية
    بواسطة Photoshopper في المنتدى الأرشيف
    مشاركات: 9
    آخر مشاركة: 06-06-2008, 14:33

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •