صفحة 1 من 2 1 2 الأخيرةالأخيرة
النتائج 1 إلى 15 من 19

الموضوع: مشكلة فى الـ Static Route

  1. #1
    عضو
    تاريخ التسجيل
    Dec 2010
    المشاركات
    79
    الدولة: Egypt
    معدل تقييم المستوى
    8

    مشكلة فى الـ Static Route



    السلام عليكم ورحمة الله وبركاته
    قمت بعمل lab على الـ Packet tracer وبه مشكلة ولا استطيع حلها
    وهى أن روتر A لا يكلم روتر C حيث عند عمل ping من A لـ C لا يوجد رد والـ Lab موجود على الرابط التالى :
    http://www.4shared.com/file/OeXCu_YT/static.html

  2. #2
    عضو
    تاريخ التسجيل
    Oct 2009
    المشاركات
    198
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    0

    رد: مشكلة فى الـ Static Route

    اسف حاولت أفتح الملف لاكن الإصدار مختلف بحمل أخر اصدار من البرنامج وأرجعلك

  3. #3
    عضو
    تاريخ التسجيل
    Dec 2010
    المشاركات
    79
    الدولة: Egypt
    معدل تقييم المستوى
    8

    رد: مشكلة فى الـ Static Route

    شكرا لك أخى الكريم

  4. #4
    عضو
    تاريخ التسجيل
    Oct 2009
    المشاركات
    198
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    0

    رد: مشكلة فى الـ Static Route

    لازم تضيف كل الشبكات

    اضف في A الشبكة 172.31.0.0 وهي المتصلة بين B and C

    وقم بإضافة في C الشبكة172.31.0.0 المتصلة بين A and B

  5. #5
    عضو محترف الصورة الرمزية Brigadier
    تاريخ التسجيل
    May 2005
    المشاركات
    9,999
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    47

    رد: مشكلة فى الـ Static Route

    لم اطلع على الملف / ولكن الذي اشك انه سبب المشكلة هو الاتي:

    تاكد انك تقوم ببناء Static Route ايضاً بمسار الرجوع مثلاً افرض لديك الاتي

    R1 -----R2------R3-----R4

    لكي يستطيع الرابع من Ping الاول /
    عرف طريق Static يوضح كيفية الوصول من الرابع الى الاول " اي لكي تصل لعنوان الاول خذ مسار عنوان انترفيس الرابع".
    عرف طريق Static يوضح كيفية الوصول من الاول الى الرابع ...الخ

    لذلك لا يكفي ان يكون فقط معرف طريق الذهاب فهو لا يكفي بل يجب تعريف طريق الرجوع "المسار العكسي".


  6. #6
    عضوية جديدة
    تاريخ التسجيل
    Jan 2011
    المشاركات
    8
    معدل تقييم المستوى
    0

    رد: مشكلة فى الـ Static Route

    أخي العزيز حاولت المساعدة ولكن الملف لا يفيح لدي

  7. #7
    عضو فضي الصورة الرمزية ahab
    تاريخ التسجيل
    Mar 2008
    المشاركات
    2,669
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    15

    رد: مشكلة فى الـ Static Route


    خلاصة الكلام في ال static
    إنك لما تعمل sh ip route تشوف كل الشبكات اللي عندك وهل الإنترفيس الذي سيتم الخروج من عليه مظبوط أم لا
    ولو شفت شبكة ناقصة أضف لها أمر static route



  8. #8
    عضو
    تاريخ التسجيل
    Dec 2010
    المشاركات
    79
    الدولة: Egypt
    معدل تقييم المستوى
    8

    رد: مشكلة فى الـ Static Route

    شكرا لكل من أرسل إلى رد ولكن لم يمشى الحال وذلك سأكتب الـ Configuration الخاصة بكل روتر
    روتر A
    interface FastEthernet0/0
    ip address 192.168.0.1 255.255.255.0

    interface Serial2/0
    ip address 10.0.0.1 255.0.0.0

    ip route 172.16.0.0 255.255.0.0 Serial2/0
    ip route 192.160.1.0 255.255.255.0 Serial2/0
    ip route 0.0.0.0 0.0.0.0 Serial2/0

    روتر B
    interface FastEthernet0/0
    ip address 172.16.0.1 255.255.0.0

    interface Serial2/0
    ip address 10.0.0.2 255.0.0.0

    interface Serial3/0
    ip address 172.31.1.1 255.255.0.0

    ip route 192.168.0.0 255.255.255.0 Serial2/0
    ip route 192.160.1.0 255.255.255.0 Serial3/0
    ip route 0.0.0.0 0.0.0.0 Serial3/0

    روتر C

    interface FastEthernet0/0
    ip address 192.160.1.1 255.255.255.0

    interface Serial2/0
    ip address 172.31.1.2 255.255.0.0

    ip route 192.168.0.0 255.255.255.0 Serial2/0
    ip route 172.16.0.0 255.255.0.0 Serial2/0
    ip route 0.0.0.0 0.0.0.0 Serial3/0

    وأسف يا شباب على الإطالة وأشكر لكم سعة الصدر

  9. #9
    عضو
    تاريخ التسجيل
    Dec 2010
    المشاركات
    79
    الدولة: Egypt
    معدل تقييم المستوى
    8

    رد: مشكلة فى الـ Static Route

    نسيت أن اوضح أن المشكلة الوحيدة لما اجى اعمل من روتر A
    ping 192.160.1.1
    لا يوجد رد

  10. #10
    عضو
    تاريخ التسجيل
    Oct 2009
    المشاركات
    198
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    0

    رد: مشكلة فى الـ Static Route

    قم بالدخول على A وقم بإضافة 192.160.0.0
    وبس

  11. #11
    عضو فضي الصورة الرمزية ahab
    تاريخ التسجيل
    Mar 2008
    المشاركات
    2,669
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    15

    رد: مشكلة فى الـ Static Route

    أخي ccna_beginner
    كدت أن أتجنن حيث أن البنج ينجح ما بين pc0 و pc2 والعكس صحيح
    فكيف لا ينجح ما بين الراوتر a والشبكة المعنية
    ولكن بعد الإطلاع على الإعدادت بكشل جيد فإنه ينقصك أمر

    لكن دعني أوضح هذه النقطة أولاً

    البنج من جهاز حاسب إلى جهاز حاسب ينجح لأن ال source adress سيكون 192.168.0.5 ,والشبكة تبعها موجودة في routing table على كل من الراوتر a و c

    ولكن عندما يكون البنج من الراوتر a إلى أي ip في الشبكة 192.160.1.0 فأعتقد أن ال source address سيكون 10.0.0.1 والشبكة التي ينتمي إليها هذا ال ip غير موجود في routing table للراوتر c

    لذلك فإن ما ينقصك هو هذا الأمر على الراوتر C

    ip route 10.0.0.0 255.0.0.0 s2/0



  12. #12
    عضو برونزي الصورة الرمزية Gawad
    تاريخ التسجيل
    Nov 2009
    المشاركات
    1,933
    معدل تقييم المستوى
    18

    رد: مشكلة فى الـ Static Route

    بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه أجمعين

    جزاكم الله خيراً ونفع بكم وعلمني وإياكم .. اللهم آمين

    بالنسبة للموضوع ده ، ده كان من أهم اسباب تركي للpacket tracer وبحثي عن بدائل أخري

    كلنا يتفق علي أنه في حالة وجود الـdefualt route هنا يقوم الراوتر بالإرسال من خلاله وهذا في حالة الراوترين A&C أي أنه من المفترض أن يقوم الجهازين بالرد علي بعضهم وهذا الطبيعي وهذا ما تعلمه سيسكو في مناهجها
    لكن المعضلة في برنامج ال packet tracer البرنامج في هذا اللاب بالذات فيه خطأ برمجي يحتاج منك أن تقوم بتعريف الراوتر A بجميع الشبكات بينه وبين الراوتر C أي الشبكة بين الراوتر B والراوتر C وبالعكس من ناحية c تقوم بتعريفه الشبكة بين A&B
    وقد قمت بتعديل هذه النقطة واللاب موجود في المرفقات والبينج شغال والحمد لله.
    ولو الدكتور مراون الإنستراكتور اللي علمني CCNA جزاه الله خيراً موجود يقولك علي الحكاية ديه إن شاء الله، لأن احنا راسلنا سيسكو عن اللاب ده بالذات وطلع الراجل اللي بيضحك ده وقلنا: اه ما احنا عارفين ، شكراً وخلاص علي كده
    الخلاصة قم بعمل اللاب علي الـGNS3 وسوف تلاحظ الفرق إن شاء الله\
    نقطة هامة:
    الحالة ديه إنك تعرف الراوتر بجميع الشبكات بينه وبين الDESTINATION لاقيتها في كتاب TODD EMPSON علي الرابط التالي:
    http://amnetwork.blogspot.com/2010/07/ccna.html
    لما كان بيتكلم عن الـSTATIC
    بس برضه ديه حالة غريبة
    والله أعلي وأعلم
    ولا تنسني والمسلمين من صالح الدعاء
    وصلي الله وسلم وبارك علي المصطفي وآله وصحبه وإخوانه أجمعين

    الملفات المرفقة الملفات المرفقة
    [CENTER][SIZE=4][COLOR=Blue]اللهم صلي على محمد وعلى آل محمد كما صليت على آل إبراهيم وبارك على محمد وعلى آل محمد كما باركت على آل إبراهيم في العالمين إنك حميد مجيد[/COLOR][/SIZE]

    [B][SIZE=4]اللهم احفظ مصر آمنة مطمئنة وسائر بلاد المسلمين
    اللهم قنا الفتن ما ظهر منا وما بطن
    [/SIZE][/B]
    [/CENTER]

  13. #13
    عضو فضي الصورة الرمزية ahab
    تاريخ التسجيل
    Mar 2008
    المشاركات
    2,669
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    15

    رد: مشكلة فى الـ Static Route

    اقتباس المشاركة الأصلية كتبت بواسطة أحمد مصطفي (جواد) مشاهدة المشاركة


    كلنا يتفق علي أنه في حالة وجود الـdefualt route هنا يقوم الراوتر بالإرسال من خلاله وهذا في حالة الراوترين A&C أي أنه من المفترض أن يقوم الجهازين بالرد علي بعضهم وهذا الطبيعي وهذا ما تعلمه سيسكو في مناهجها
    لكن المعضلة في برنامج ال packet tracer البرنامج في هذا اللاب بالذات فيه خطأ برمجي يحتاج منك أن تقوم بتعريف الراوتر A بجميع الشبكات بينه وبين الراوتر C أي الشبكة بين الراوتر B والراوتر C وبالعكس من ناحية c تقوم بتعريفه الشبكة بين A&B


    معذرة أخي أحمد ، لم أستطع تشغيل اللاب الذي وضعته

    ولكن لي تعليق بسيط ، لا أدري إن كنت موافقني في الرأي أم لا
    في ال static route
    - لابد من تعريف جميع الشبكات في كلا الاتجاهين
    أو
    -تعريف جميع الشبكات في اتجاه واستخدام ال default route في الاتجاه الآخر

    ولذلك اللاب على حالته الموجودة : قام أخي السائل بوضع ال default route على a و b في اتجاه الراوتر C ولم يضع على الراوتر C أي تعريف للوصول إلى الشبكة 10.0.0.0
    فكيف سينجح البنج بين الراوترين ؟؟
    إنت عارف إن أي باكيت بتطلع بيكون فيها source, destination ip وهما لا يتغيروا على طول المسار

    وفي حالة البنج من 192.160.1.5 إلى الراوتر A 192.168.1.1 فإن الراوتر C يعرف كيف يوجه الباكيت وكذلك الراوتر B وكذلك في حالة العودة لأن كلا من ال source وال destination موجودين في ال routing table

    أما في حالة البنج بين الراوترين : فسؤالي هو كيف يتم اختيار ال source هل يتم على حسب الإنترفيس الذي ستخرج منه الباكيت ( إذا كانت الإجابة بنعم فإنه من المستحيل أن ينجح البنج ) لأن الراوتر C لا يعرف طريق العودة إلى 10.0.0.0 ولا يوجد عليه default route في اتجاه الراوتر A و B

    للتأكد من ذلك واللاب على حالته بدون تغيير قمت بعمل pdu من الراوتر A إلى الجهاز 192.160.1.5 لم ينجح البنج كما ذكر الأخ وقمت بعمل simulation لل BDU فكان التوقف في مسار العودة عند الراوتر C

    فقمت بعمل edit لل BDU وغيرت ال source إلى الإنترفيس fa0/0 صاحب ال IP رقم 192.168.0.1 فنجح البنج بدون مشاكل

    ولذلك أعتقد أن الباكيت تريسر سليم في هذا اللاب

    والله أعلم

  14. #14
    عضو برونزي الصورة الرمزية Gawad
    تاريخ التسجيل
    Nov 2009
    المشاركات
    1,933
    معدل تقييم المستوى
    18

    رد: مشكلة فى الـ Static Route

    بسم الله و الحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه أجمعين

    كيف الحال ياحج إيهاب عساك بخير والأسرة الكريمة .. اللهم آمين

    بدون الحاجة لوجود default route المفروض البينج يشتغل لأن A&C عندهم STATIC ROUTES للشبكات في الجهتين وده الطبيعي وافتح اي كتاب فيه لاب STATIC حتلاقي نفس الكلام إن شاء الله
    جرب اللاب ده علي الGNS3 بدون DEFUALT ROUTE وحيشتغل معاك عادي جداً إن شاء الله، الآن أقوم بعمل اللاب وسوف أرفع لك ملف ال.NET والكونفيج إن شاء الله

    وصلي الله وسلم وبارك علي المصطفي وآله وصحبه وإخوانه أجمعين
    [CENTER][SIZE=4][COLOR=Blue]اللهم صلي على محمد وعلى آل محمد كما صليت على آل إبراهيم وبارك على محمد وعلى آل محمد كما باركت على آل إبراهيم في العالمين إنك حميد مجيد[/COLOR][/SIZE]

    [B][SIZE=4]اللهم احفظ مصر آمنة مطمئنة وسائر بلاد المسلمين
    اللهم قنا الفتن ما ظهر منا وما بطن
    [/SIZE][/B]
    [/CENTER]

  15. #15
    عضو فضي الصورة الرمزية ahab
    تاريخ التسجيل
    Mar 2008
    المشاركات
    2,669
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    15

    رد: مشكلة فى الـ Static Route



    حياك الله أخي أحمد

    هو مفيش مشكلة لو جاوبت على سؤالي

    على أي أساس سيتم اختيار ال source address أثناء عمل البنج من الراوتر A إلى الراوتر C


صفحة 1 من 2 1 2 الأخيرةالأخيرة

المواضيع المتشابهه

  1. static & subntting route lab
    بواسطة xman10b في المنتدى الأرشيف
    مشاركات: 1
    آخر مشاركة: 17-01-2012, 01:03
  2. Static route
    بواسطة islam-salah في المنتدى الأرشيف
    مشاركات: 3
    آخر مشاركة: 23-10-2011, 13:23
  3. مشكله في Static Route
    بواسطة E-ng.LedoZ في المنتدى الأرشيف
    مشاركات: 3
    آخر مشاركة: 08-09-2011, 13:33
  4. سؤال عن Trace route & Static IP
    بواسطة fatehalmsddi في المنتدى الأرشيف
    مشاركات: 0
    آخر مشاركة: 05-12-2010, 13:00
  5. load balancing with static route
    بواسطة tele_lehio في المنتدى الأرشيف
    مشاركات: 4
    آخر مشاركة: 27-09-2010, 08:50

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •