النتائج 1 إلى 10 من 10

الموضوع: سؤال حول static routuing و rip2

  1. #1
    عضو
    تاريخ التسجيل
    Feb 2006
    المشاركات
    53
    الدولة: Morocco
    معدل تقييم المستوى
    0

    سؤال حول static routuing و rip2



    أشكر كل الإخوة القائمين والمساهمين في هذا الموقع
    ولدي سؤال هل يمكن دمج static routuing و rip2 في lab واحد لأنه لم ينجح لي حتى عملت فقط ب static routuing
    الاب lab مكون من ثلاث روترات

  2. #2
    عضو برونزي الصورة الرمزية Gawad
    تاريخ التسجيل
    Nov 2009
    المشاركات
    1,933
    معدل تقييم المستوى
    18

    رد: سؤال حول static routuing و rip2

    فين التوبولوجي
    [CENTER][SIZE=4][COLOR=Blue]اللهم صلي على محمد وعلى آل محمد كما صليت على آل إبراهيم وبارك على محمد وعلى آل محمد كما باركت على آل إبراهيم في العالمين إنك حميد مجيد[/COLOR][/SIZE]

    [B][SIZE=4]اللهم احفظ مصر آمنة مطمئنة وسائر بلاد المسلمين
    اللهم قنا الفتن ما ظهر منا وما بطن
    [/SIZE][/B]
    [/CENTER]

  3. #3
    عضو
    تاريخ التسجيل
    Feb 2006
    المشاركات
    53
    الدولة: Morocco
    معدل تقييم المستوى
    0

    رد: سؤال حول static routuing و rip2

    جزاك الله الأخ الكريم أحمد مصطفى على التجاوب السريع لم أجد طريقة لتحمميل ملف pkt الذي أعمل عليه
    بالمرفقات لكني أعطي هذا الرابط
    الطوبولوجي هي بهذا الشكل
    على lan 1 يعمل ب static routuing و lan 2 يعمل ب rip2 وlan 3 يعمل بهما معا
    وباستعمال العناوين التالية على WAN
    13.0.0.0/30 13.0.0.4/30 13.0.0.8/30
    وعلى lan
    . 160.10.0.0/25 static routuing
    160.10.0.128/26 rip2
    160.10.0.192/27 static routuing و rip2


    ولدي سؤال آخر وجدت في هذه الصفحة بأن
    Note:

    You need to advertise only the classful network number, not a subnet:
    Router(config-router)#network 172.16.0.0


    not
    Router(config-router)#network 172.16.10.0


    If you advertise a subnet, you will not receive an error message, because the router will automatically convert the subnet to the classful network address.

    لكن في هذه الصفحة وجدت شيئا آخر
    http://www.orbit-computer-solutions....figuration.php

    Router(config-router)#network 172.16.1.0
    Router(config-router)#network 172.16.2.0

    172.16.1.0 و 172.16.2.0 classless

    فما العمل
    وشكرا جزيلا

  4. #4
    عضو برونزي الصورة الرمزية Gawad
    تاريخ التسجيل
    Nov 2009
    المشاركات
    1,933
    معدل تقييم المستوى
    18

    رد: سؤال حول static routuing و rip2

    بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه أجمعين

    بالنسبة للنقطة الثانية:
    الـRIPv1 عبارة عن classful routing protocol يعني مبيفهمش حاجة غير 255.0.0.0، 255.255.0، 255.255.255.0 أي subnetmask أخر مثل 255.255.255.192 مثلاً لايفهمه ويحوله إلي classful يعني مبيفهمش VLSM فلو حضرتك وضعت الآتي:
    Router(config-router)#network 172.16.10.0
    Router(config-router)#exit
    يقوم بتحويله إلي الآتي:
    Router#show ip prot
    Routing Protocol is "rip"
    **omitted**
    Redistributing: rip
    Default version control: send version 1, receive any version
    Interface Send Recv Triggered RIP Key-chain
    Loopback0 1 2 1
    Automatic network summarization is in effect
    Maximum path: 4
    Routing for Networks:
    172.16.0.0
    192.168.10.0
    لأن 172.16.0.0 هذه في class B يعني الـdefualt subnet mask يساوي 255.255.0.0.

    بالنسبة للنقطة الأولي:
    علشان حضرتك تنشر static route معين في rip advertisement عن طريق الأمر
    R2(config)#route rip
    R2(config-router)#redistribute static
    بس ملاحظة، انا ملاحظ إن حضرتك مش مفعل الـrip علي Router 1
    ممكن تجرب اللاب تاني بس تأكد من النقطة السابقة.
    [CENTER][SIZE=4][COLOR=Blue]اللهم صلي على محمد وعلى آل محمد كما صليت على آل إبراهيم وبارك على محمد وعلى آل محمد كما باركت على آل إبراهيم في العالمين إنك حميد مجيد[/COLOR][/SIZE]

    [B][SIZE=4]اللهم احفظ مصر آمنة مطمئنة وسائر بلاد المسلمين
    اللهم قنا الفتن ما ظهر منا وما بطن
    [/SIZE][/B]
    [/CENTER]

  5. #5
    عضو
    تاريخ التسجيل
    Feb 2006
    المشاركات
    53
    الدولة: Morocco
    معدل تقييم المستوى
    0

    رد: سؤال حول static routuing و rip2

    جزاك الله خيرا فعلا لقد نجح الأمر مع هذا الأمر
    R2(config)#route rip

    R2(config-router)#redistribute static

    عملية ping ناجحة وجزاك الله خيرا


    وبالنسبة ل RIPv1 أفهم بأنه classfuمlrouting protocol ولايقبل غير classful
    أما سؤالي فيتعلق ب rip2 هل نضع ونكتفي Router(config-router)#network
    بصيغة classful أم نعمل ب classless

    وجزاك الله خيرا أخي مصطفي على التجاوب السريع والمفيد

  6. #6
    عضو
    تاريخ التسجيل
    Feb 2006
    المشاركات
    53
    الدولة: Morocco
    معدل تقييم المستوى
    0

    رد: سؤال حول static routuing و rip2

    عملية ping من جهة R1و R3 ناجحة
    لكن من جهة R2 تعطيني مايلي
    PC>ping 192.168.0.130

    Pinging 192.168.0.130 with 32 bytes of data:

    Reply from 160.10.0.129: Destination host unreachable.
    Reply from 160.10.0.129: Destination host unreachable.
    Reply from 160.10.0.129: Destination host unreachable.
    Reply from 160.10.0.129: Destination host unreachable.

    Ping statistics for 192.168.0.130:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

    PC>ping 192.168.0.0

    Pinging 192.168.0.0 with 32 bytes of data:

    Reply from 160.10.0.129: Destination host unreachable.
    Reply from 160.10.0.129: Destination host unreachable.
    Reply from 160.10.0.129: Destination host unreachable.
    Reply from 160.10.0.129: Destination host unreachable.

    Ping statistics for 192.168.0.0:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

    و
    أدخلت RIP على R1
    وآضفت
    R1(config)#route rip

    R1config-router)#redistribute static


    معنى بأن lab كله يعمل ب RIP
    ولم تتغير عملية ping من جهة R2
    وعذرا على الإزعاج


  7. #7
    عضو
    تاريخ التسجيل
    Feb 2006
    المشاركات
    53
    الدولة: Morocco
    معدل تقييم المستوى
    0

    رد: سؤال حول static routuing و rip2

    هذه النتيجة النهائية للتغييرات على R2و R3
    لتكون عملية ping ناجحة وجزاك الله خيرا مرة أخرى ألخ مصطفى


    R1#show startup-config
    Using 796 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname R1
    !
    !!
    !
    interface FastEthernet0/0
    ip address 160.10.0.1 255.255.255.128
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/1/0
    ip address 13.0.0.5 255.255.255.252
    clock rate 64000
    !
    interface Serial0/1/1
    ip address 13.0.0.1 255.255.255.252
    !
    interface Vlan1
    no ip address
    shutdown
    !
    ip classless
    ip route 13.0.0.8 255.255.255.252 Serial0/1/0
    ip route 160.10.0.128 255.255.255.192 Serial0/1/0
    ip route 160.10.0.192 255.255.255.224 Serial0/1/1
    ip route 13.0.0.8 255.255.255.255 Serial0/1/1
    !
    !

    !
    line con 0
    line vty 0 4
    login
    !
    !
    !
    end






    R3#show startup-config
    Using 925 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname R3
    !!
    !
    interface FastEthernet0/0
    ip address 160.10.0.193 255.255.255.224
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/1/0
    ip address 13.0.0.10 255.255.255.252
    clock rate 64000
    !
    interface Serial0/1/1
    ip address 13.0.0.2 255.255.255.252
    clock rate 64000
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router rip
    version 2
    redistribute static metric 1
    network 13.0.0.0
    network 160.10.0.0
    no auto-summary
    !
    ip classless
    ip route 13.0.0.4 255.255.255.252 Serial0/1/1
    ip route 160.10.0.0 255.255.255.128 Serial0/1/1
    ip route 160.10.0.128 255.255.255.192 Serial0/1/0
    ip route 13.0.0.4 255.255.255.252 Serial0/1/0
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !

    !
    end

    R2#show startup-config
    Using 694 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname R2
    !

    !
    interface FastEthernet0/0
    ip address 160.10.0.129 255.255.255.192
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/1/0
    ip address 13.0.0.6 255.255.255.252
    !
    interface Serial0/1/1
    ip address 13.0.0.9 255.255.255.252
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router rip
    version 2
    redistribute static metric 1
    network 13.0.0.0
    network 160.10.0.0
    no auto-summary
    !
    ip classless
    !
    !
    line con 0
    line vty 0 4
    login
    !
    end

  8. #8
    عضو
    تاريخ التسجيل
    Feb 2006
    المشاركات
    53
    الدولة: Morocco
    معدل تقييم المستوى
    0

    رد: سؤال حول static routuing و rip2

    عملية ping
    PC>ping 160.10.0.2

    Pinging 160.10.0.2 with 32 bytes of data:

    Reply from 160.10.0.2: bytes=32 time=93ms TTL=126
    Reply from 160.10.0.2: bytes=32 time=156ms TTL=126
    Reply from 160.10.0.2: bytes=32 time=187ms TTL=126
    Reply from 160.10.0.2: bytes=32 time=172ms TTL=126

    Ping statistics for 160.10.0.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 93ms, Maximum = 187ms, Average = 152ms

    PC>ping 160.10.0.194

    Pinging 160.10.0.194 with 32 bytes of data:

    Reply from 160.10.0.194: bytes=32 time=125ms TTL=126
    Reply from 160.10.0.194: bytes=32 time=156ms TTL=126
    Reply from 160.10.0.194: bytes=32 time=156ms TTL=126
    Reply from 160.10.0.194: bytes=32 time=171ms TTL=126

    Ping statistics for 160.10.0.194:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 125ms, Maximum = 171ms, Average = 152ms



    PC>ping 160.10.0.130

    Pinging 160.10.0.130 with 32 bytes of data:

    Reply from 160.10.0.130: bytes=32 time=141ms TTL=126
    Reply from 160.10.0.130: bytes=32 time=125ms TTL=126
    Reply from 160.10.0.130: bytes=32 time=156ms TTL=126
    Reply from 160.10.0.130: bytes=32 time=156ms TTL=126

    Ping statistics for 160.10.0.130:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 125ms, Maximum = 156ms, Average = 144ms

    PC>ping 160.10.0.2

    Pinging 160.10.0.2 with 32 bytes of data:

    Reply from 160.10.0.2: bytes=32 time=157ms TTL=126
    Reply from 160.10.0.2: bytes=32 time=172ms TTL=126
    Reply from 160.10.0.2: bytes=32 time=156ms TTL=126
    Reply from 160.10.0.2: bytes=32 time=156ms TTL=126

    Ping statistics for 160.10.0.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 156ms, Maximum = 172ms, Average = 160ms


    PC>ping 160.10.0.194

    Pinging 160.10.0.194 with 32 bytes of data:

    Reply from 160.10.0.194: bytes=32 time=156ms TTL=126
    Reply from 160.10.0.194: bytes=32 time=125ms TTL=126
    Reply from 160.10.0.194: bytes=32 time=141ms TTL=126
    Reply from 160.10.0.194: bytes=32 time=127ms TTL=126

    Ping statistics for 160.10.0.194:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 125ms, Maximum = 156ms, Average = 137ms

    PC>ping 160.10.0.128

    Pinging 160.10.0.128 with 32 bytes of data:

    Reply from 13.0.0.9: bytes=32 time=125ms TTL=253
    Reply from 13.0.0.9: bytes=32 time=108ms TTL=253
    Reply from 13.0.0.9: bytes=32 time=93ms TTL=253
    Reply from 13.0.0.9: bytes=32 time=109ms TTL=253

    Ping statistics for 160.10.0.128:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 93ms, Maximum = 125ms, Average = 108ms





  9. #9
    عضو
    تاريخ التسجيل
    Feb 2006
    المشاركات
    53
    الدولة: Morocco
    معدل تقييم المستوى
    0

    رد: سؤال حول static routuing و rip2

    السلام عليكم ورحمة الله وبركاته الأخ أحمد مصطفى
    هذا الصباح اضفت فقط ماأشرت به علي وكانت النتيجة إيجابية 100/100
    اقتباس المشاركة الأصلية كتبت بواسطة abdellaah مشاهدة المشاركة
    هذه النتيجة النهائية للتغييرات على R2و R3
    لتكون عملية ping ناجحة وجزاك الله خيرا مرة أخرى ألخ مصطفى


    R1#show startup-config
    Using 796 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname R1
    !
    !!
    !
    interface FastEthernet0/0
    ip address 160.10.0.1 255.255.255.128
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/1/0
    ip address 13.0.0.5 255.255.255.252
    clock rate 64000
    !
    interface Serial0/1/1
    ip address 13.0.0.1 255.255.255.252
    !
    interface Vlan1
    no ip address
    shutdown
    !
    ip classless
    ip route 13.0.0.8 255.255.255.252 Serial0/1/0
    ip route 160.10.0.128 255.255.255.192 Serial0/1/0
    ip route 160.10.0.192 255.255.255.224 Serial0/1/1
    ip route 13.0.0.8 255.255.255.255 Serial0/1/1
    !
    !

    !
    line con 0
    line vty 0 4
    login
    !
    !
    !
    end






    R3#show startup-config
    Using 925 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname R3
    !!
    !
    interface FastEthernet0/0
    ip address 160.10.0.193 255.255.255.224
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/1/0
    ip address 13.0.0.10 255.255.255.252
    clock rate 64000
    !
    interface Serial0/1/1
    ip address 13.0.0.2 255.255.255.252
    clock rate 64000
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router rip
    version 2

    network 13.0.0.0
    network 160.10.0.0
    no auto-summary
    !
    ip classless
    ip route 13.0.0.4 255.255.255.252 Serial0/1/1
    ip route 160.10.0.0 255.255.255.128 Serial0/1/1
    ip route 160.10.0.128 255.255.255.192 Serial0/1/0
    ip route 13.0.0.4 255.255.255.252 Serial0/1/0
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !

    !
    end

    R2#show startup-config
    Using 694 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname R2
    !

    !
    interface FastEthernet0/0
    ip address 160.10.0.129 255.255.255.192
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/1/0
    ip address 13.0.0.6 255.255.255.252
    !
    interface Serial0/1/1
    ip address 13.0.0.9 255.255.255.252
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router rip
    version 2
    redistribute static
    network 13.0.0.0
    network 160.10.0.0
    no auto-summary
    !
    ip classless
    !
    !
    line con 0
    line vty 0 4
    login
    !
    end

  10. #10
    عضوية جديدة
    تاريخ التسجيل
    Jan 2011
    المشاركات
    3
    معدل تقييم المستوى
    0

    رد: سؤال حول static routuing و rip2



    السلام عليكم و رحمة الله الاخ الكريم احمد مصطفى
    اما انا فلم استعمل
    R1(config)#route rip

    R1config-router)#redistribute static


    لكن نجح ping

    Roter1#show startup-config
    sing 670 bytes
    !
    version 12.2
    no service password-encryption
    !
    hostname Router1
    !
    !
    !
    !
    !
    ip ssh version 1
    !
    !
    interface FastEthernet0/0
    ip address 160.10.0.1 255.255.255.128
    duplex auto
    speed auto
    !
    interface FastEthernet1/0
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial2/0
    ip address 13.0.0.1 255.255.255.252
    clock rate 128000
    !
    interface Serial3/0
    ip address 13.0.0.9 255.255.255.252
    !
    interface FastEthernet4/0
    no ip address
    shutdown
    !
    interface FastEthernet5/0
    no ip address
    shutdown
    !
    ip classless
    ip route 160.10.0.128 255.255.255.192 Serial2/0
    ip route 160.10.0.192 255.255.255.224 Serial3/0
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !
    !
    end

    Router2>
    >
    Router2#show startup-config
    Using 653 bytes
    !
    version 12.2
    no service password-encryption
    !
    hostname Router2
    !
    !
    !
    !
    !
    ip ssh version 1
    !
    !
    interface FastEthernet0/0
    ip address 160.10.0.129 255.255.255.192
    duplex auto
    speed auto



    !
    interface FastEthernet1/0
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial2/0
    ip address 13.0.0.2 255.255.255.252
    !
    interface Serial3/0
    ip address 13.0.0.5 255.255.255.252
    clock rate 128000
    !
    interface FastEthernet4/0
    no ip address
    shutdown
    !
    interface FastEthernet5/0
    no ip address
    shutdown
    !
    router rip
    version 2
    network 13.0.0.0
    network 160.10.0.0
    no auto-summary
    !
    ip classless
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !
    !

    Router3#show startup-config
    Using 701 bytes
    !
    version 12.2
    no service password-encryption
    !
    hostname Router3
    !
    !
    !
    !
    !
    ip ssh version 1
    !
    !
    interface FastEthernet0/0
    ip address 160.10.0.193 255.255.255.224
    duplex auto
    speed auto
    !
    interface FastEthernet1/0
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial2/0
    ip address 13.0.0.6 255.255.255.252
    !
    interface Serial3/0
    ip address 13.0.0.10 255.255.255.252
    clock rate 128000
    !
    interface FastEthernet4/0
    no ip address
    shutdown
    !
    interface FastEthernet5/0
    no ip address
    shutdown

    Router3#show startup-config
    Using 701 bytes
    !
    version 12.2
    no service password-encryption
    !
    hostname Router3
    !
    !
    !
    !
    !
    ip ssh version 1
    !
    !
    interface FastEthernet0/0
    ip address 160.10.0.193 255.255.255.224
    duplex auto
    speed auto
    !
    interface FastEthernet1/0
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial2/0
    ip address 13.0.0.6 255.255.255.252
    !
    interface Serial3/0
    ip address 13.0.0.10 255.255.255.252
    clock rate 128000
    !
    interface FastEthernet4/0
    no ip address
    shutdown
    !
    interface FastEthernet5/0
    no ip address
    shutdown
    !
    router rip
    version 2
    network 13.0.0.0
    network 160.10.0.0
    no auto-summary
    !
    ip classless
    ip route 160.10.0.0 255.255.255.128 Serial3/0
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !
    !
    end




المواضيع المتشابهه

  1. سؤال VPN لماذا كل هذه ال Static Routing ؟
    بواسطة abo Abdullah في المنتدى منتدى الشهادات العام
    مشاركات: 4
    آخر مشاركة: 22-05-2014, 21:40
  2. سوال بخصوص ال static routes
    بواسطة bll_hb في المنتدى الأرشيف
    مشاركات: 8
    آخر مشاركة: 31-05-2011, 16:15
  3. سؤال عن Trace route & Static IP
    بواسطة fatehalmsddi في المنتدى الأرشيف
    مشاركات: 0
    آخر مشاركة: 05-12-2010, 13:00
  4. سؤال عن Static Routing
    بواسطة fatehalmsddi في المنتدى الأرشيف
    مشاركات: 6
    آخر مشاركة: 04-12-2010, 20:10
  5. سؤال فى static Routing بالصورة !
    بواسطة the_way2allah في المنتدى الأرشيف
    مشاركات: 6
    آخر مشاركة: 13-02-2009, 01:07

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •