النتائج 1 إلى 2 من 2

الموضوع: مشكلة برجاء المساعدة من اصحاب الخبرة

  1. #1
    عضو
    تاريخ التسجيل
    Feb 2006
    المشاركات
    38
    الدولة: Egypt
    معدل تقييم المستوى
    0

    مشكلة برجاء المساعدة من اصحاب الخبرة



    الاخوة الاعزاء

    المشكلة تتعلق بموضوع intervlan حيث قمت بعمل 2 vlan وتم بنجاح عمل routing بينهم ولكن المشكلة تكمن فى أن vlan 1 تحتوى على router خاص بخدمة الإنترنت و ال ip الخاص به يعتبر getway للأجهزة التى تريد الخروج للإنترنت ويوجد جهاز فى vlan 2 يريد الخروج للإنترنت وبالتالى يجب أن يحتوى على ال Getway الخاص بال
    supinterface الخاص ب vlan 2 وبالتالى فلن يستطبع الخروج للإنترنت لانه لا يملك ال Getway الخاص بالروتر الموجود فى vlan1 .مع العلم بأننى قمت بإعطاء الجهاز كلا من ال getway الخاص يالروتر و الgetway الخاص ب ال vlan2 ولكن أيضا بدون نتيجة .
    ملحوطة :- ال switch المستخدم هو D-LINK 6500 LAYER 3

    برجاء الإفادة من أصحاب الخبرة


    مع الشكر للجمبع ،،،،

  2. #2
    عضو
    تاريخ التسجيل
    Jan 2005
    المشاركات
    789
    الدولة: Egypt
    معدل تقييم المستوى
    13

    رد: مشكلة برجاء المساعدة من اصحاب الخبرة



    اخى العزيز:

    انت بتقول ان عندك روتر والروتر ده رابط فى سوتش والسوتش ده

    عليه vlan 1 وعليه vlan 2 وفى اجهزه متصله بكل vlan وكلهم عاوزين يخرجوا

    النت.

    باذن الله بسيطه اخى:

    اولا يجب اعطاء ال real ip اللى اخذته من internet service provier تعطيه

    exit interface(the interface which will linked directly to to the isp)

    اتفضلك الانترفيس التانى بتاع الروتر:

    اللى هتوصله بالسوتش بتاعك تمام كدا؟
    بس يا سيدى توصله متديش ليه ip
    no ip address
    no shutdown
    وبعد كده تشتغل عادى ذى محنا بنشتغل وتعمل subinterfaces وكل اللى انت عارفوا
    دى كدا هتخليلك ال intervlan يقدروا يكلموا بعضهم عن طريق السوتش

    تعالى بقا على موضوع ال nat

    هتعمل nat(pat)
    بالاوامر اللى انت عارفها وتستخدم ال real ip وتعمله خاصية ال overload
    ومتنساشى تعمل access -list
    وحط فيها ال range
    اللى انت سامحج له انه يخرج للنترنت

    واخيرا متنساشى تعرف الروتر بتاعك الطريق لل isp سواء عرفتهوله ب اى بروتكول روتنج او
    ب static route

    جرب وهتلاقى كل شىء ماشى ذى الفل
    على فكره انا بكلمك من خلال تجربتى العمليه على ال emulation انا نفزتها وبفضل الله نجح
    ال intervlan
    وكمان نجح انه يعمل nat
    عموما انه هرفق ليق ال configuration

    والرسمه كمان عشان تجرب


    Uploaded with ImageShack.us


    وده ال configuration for router 0 and router 1 and the switche


    Router0#sh run
    Building configuration...
    Current configuration : 910 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 128.1.1.1 255.255.255.0
    ip nat outside
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    ip nat inside
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.1
    encapsulation dot1Q 1 native
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    !
    interface FastEthernet0/1.2
    encapsulation dot1Q 2
    ip address 192.168.4.1 255.255.255.0
    ip nat inside
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router rip
    version 2
    network 128.1.0.0
    no auto-summary
    !
    ip nat inside source list 1 interface FastEthernet0/0 overload
    ip classless
    !
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 1 permit 192.168.4.0 0.0.0.255
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !
    !
    !
    end
    ******************************************
    Router1#sh run
    Building configuration...
    Current configuration : 591 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 128.1.1.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 192.168.3.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router rip
    version 2
    network 128.1.0.0
    network 192.168.3.0
    no auto-summary
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 128.1.1.1
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !
    !
    !
    end
    *********************************

    Switch#sh run
    Building configuration...
    Current configuration : 1156 bytes
    !
    version 12.1
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Switch
    !
    !
    !
    interface FastEthernet0/1
    switchport mode trunk
    !
    interface FastEthernet0/2
    switchport mode access
    !
    interface FastEthernet0/3
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/4
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    interface Vlan1
    no ip address
    shutdown
    !
    !
    line con 0
    !
    line vty 0 4
    login
    line vty 5 15
    login
    !
    !
    end

    ****************************

    ولا تنسى اخى الكريم ان تتابع وترى عملية ال translation وذلك ببساطه اذا قمت بعمل ping من اى pc على ال
    server

    وطبعا ده هيتم بالامر المعروف

    show ip nat translation

    دمتم بود
    the light in the end of the tunnel


    من
    يعين الناس . لابد ان تأتيه المعونه.

المواضيع المتشابهه

  1. ارجو المساعدة مشكلة فى الحرارة
    بواسطة metro2033 في المنتدى الأرشيف
    مشاركات: 8
    آخر مشاركة: 02-06-2011, 16:28
  2. برجاء المساعدة
    بواسطة wada في المنتدى الأرشيف
    مشاركات: 16
    آخر مشاركة: 31-05-2011, 17:13
  3. برجاء المساعدة في شراء كارت
    بواسطة master_sn في المنتدى الأرشيف
    مشاركات: 3
    آخر مشاركة: 28-05-2011, 20:45

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •