النتائج 1 إلى 13 من 13

الموضوع: شكر عرفان ،وتساؤلات حيران حول ال NAT

  1. #1
    عضو
    تاريخ التسجيل
    Jul 2011
    المشاركات
    107
    الدولة: Egypt
    معدل تقييم المستوى
    7

    Question شكر عرفان ،وتساؤلات حيران حول ال NAT



    بسم الله الرحمن الرحيم

    السلام عليكم ورحمة الله وبركاته
    في البداية اهنئ الجميع بمناسبة قرب شهر رمضان الكريم ، فكل عام وانتم بخير :cdcd::cdcd::cdcd:

    كما اشكر المهندسين الكرام على ما تفضلوا به من الشرح والتوضيح لمعظم مواضيع الشبكات

    ولكنني ارجو من اعضاء المنتدى الكريم على هذه الصفحة توضيح موضوع ال NAT
    من خلال الحوار المباشر لصعوبته الشديدة بالنسبة لي
    فانا لا اعرف الفرق بين
    inside local
    outside local
    inside global
    outside global

    كما لا اعرف الفرق بين
    dynamic nat
    و
    port nat

    كما لا اعرف اهمية استخدام اوامر ACL مع العناوين الخاصة قبل دخول النت العام
    كما لا اعرف معنى استخدام امر static default route مع ال NAT


    ارجو المساعدة ولكم جزيل الشكر

    وانتظروني مع مجموعة اخرى من الاسئلة حول المنهج :confused:
    الذي يحتاج للحفظ اكثر من الفهم بصراحة من وجهة نظري الشخصية ......

  2. #2
    عضوية جديدة
    تاريخ التسجيل
    Jul 2011
    المشاركات
    42
    معدل تقييم المستوى
    0

    رد: شكر عرفان ،وتساؤلات حيران حول ال NAT

    السلام عليكم
    اولا شكرا اخي الكريم على هذا الموضوع الجميل ,,
    انا اخذت اليوم محاضرة عن الــ NAT وللأسف عندي نفس التساؤلات
    وبإذن الله متاكده انك راح تلقى اجابة لكل تساؤلاتك لانه هذا المنتدى ارائع مليء بالأساتذه الرائعين جزاهم الله كل خير

    متابعة

  3. #3
    عضو
    تاريخ التسجيل
    Jul 2007
    المشاركات
    339
    الدولة: Jordan
    معدل تقييم المستوى
    0

    رد: شكر عرفان ،وتساؤلات حيران حول ال NAT

    ال NAT هو عبارة عن تحويل ال Private IP والذي يستخدم بالشبكة الداخلية لعناوين IP Public والتي تستخدم في الانترنت، ويتم التحويل بواحد من ثلاثة اشكال:

    1-"Static Network Address Translation "NAT
    وهنا يتم تحويل private ip الى ما يقابله public ip اي واحد لواحد (One-to-one) وهنا يتم تحويل عنوان المرسل فقط

    2- Daynamic NAT
    وهذا النوع يكون فيه التحويل لمجموعة عناوين داخلية private IPs لمجموعة عناوين خارجية public IPs دون أن يتم تحديد اي عنوان داخلي مع ما يقابله من العناوين الخارجية، بحيث يكون عدد العناوين على الطرفين متساويان، وهنا يتم تحويل عنوان المرسل فقط

    3- Overload Port Address Translation "PAT"
    وهنا يتم تحويل عنوان المرسل ورقم منفذه (Source Port number) لأنه العنوان الخارجي public ip يمثل عدة عناوين داخلية

  4. #4
    عضو فضي
    تاريخ التسجيل
    May 2007
    المشاركات
    595
    الدولة: Egypt
    معدل تقييم المستوى
    11

    رد: شكر عرفان ،وتساؤلات حيران حول ال NAT

    تسطيع فهمه بكل سهولة من فيديوهات المهندس محمد عزت والمهندس ياسر رمزي
    ahmednegm.4shared.com
    www.Negm.ourtoolbar.com

  5. #5
    عضو
    تاريخ التسجيل
    Jul 2011
    المشاركات
    107
    الدولة: Egypt
    معدل تقييم المستوى
    7

    رد: شكر عرفان ،وتساؤلات حيران حول ال NAT

    اولا :
    اشكر العضو fastory
    على التوضيح
    لكني اريد ان اعرف كيفية استخدام اوامر الكونفجريشن الخاصة بكل نوع من انواع ال NAT

    ثانيا:
    اشكر كلا من
    bronzag
    و
    Eng4ahmed
    على مشاركتهما الطيبة



    مازلت لا اعرف الفرق بين
    inside local
    inside global
    outside local
    outside global

    ارجو المساعدة

  6. #6
    عضو
    تاريخ التسجيل
    Jul 2007
    المشاركات
    339
    الدولة: Jordan
    معدل تقييم المستوى
    0

    رد: شكر عرفان ،وتساؤلات حيران حول ال NAT

    لاجراء التعريف يجب تحديد الشبكة الداخلية (Inside) والشبكة الخارجية (Outside)، كون الراوتر لا يستطيع تحديد ذلك من تلقاء نفسه لأنه قد يملك عدة interfaces، وبالتالي يجب تحديد الانترفيس الموصول بالشبكة الداخلية ولنفرض أنه (Fastethernet) وذلك كما يلي:
    Router(config)#interface fa0/0
    Router(config-if)#ip nat inside

    الخطوة الثانية يجب تحديد outside interface ولنفرض أنه serial 0/0 كما يلي:
    Router(config)#interface s0/0
    Router(config-if)#ip nat outside

    الخطوة الثالثة تنقيذ عملية التحويل وهنا يتم حسب نوع ال NAT:
    Static NAT سيتم تحويل Source IP address وقيمته (11.1.1.1) محليا (Local) والقادم من ال inside بحيث يصبح قيمته (200.1.1.1) عالميا (Global) وذلك كما يلي
    Router(config)# ip nat inside source static 11.1.1.1 200.1.1.1
    Dynamic NAT سيتم تحويل مجموعة ال Source IP addresses المحلية (Local) والمحددة ب Access-list number 10 والقادمة من ال inside بحيث تصبح تأخذ IP addresses جديدة وعالمية (Global) والمحددة بمجموعة العناوين الموجودة داخل pool_a وذلك كما يلي

    R(config)# access-list 10 permit 11.1.1.0 0.0.0.255
    R(config)# ip nat pool pool_a 200.1.1.1 200.1.1.254 netmask 255.255.255.0
    R(config)# ip nat inside source list 10 pool pool_a

    PAT هي نفس الاوامر في الطريقة السابقة لكن يكون الفرق في عدد العناوين في pool_a بحيث يكون اقل من العناوين الداخلية بكثير وبالغالب تكون عنوان واحد:
    R(config)# ip nat pool pool_a 200.1.1.1 200.1.1.1 netmask 255.255.255.0


  7. #7
    عضو فضي
    تاريخ التسجيل
    May 2007
    المشاركات
    595
    الدولة: Egypt
    معدل تقييم المستوى
    11

    رد: شكر عرفان ،وتساؤلات حيران حول ال NAT

    صدقني لكي تعرف الفرق بينهما وكيف تستخدمهما ذاكر الفديو الخاص بهم من المهندس محمد عزت وياسر رمزي
    ahmednegm.4shared.com
    www.Negm.ourtoolbar.com

  8. #8
    عضو
    تاريخ التسجيل
    Jul 2011
    المشاركات
    107
    الدولة: Egypt
    معدل تقييم المستوى
    7

    رد: شكر عرفان ،وتساؤلات حيران حول ال NAT

    عموما هدور على فيديوهات البشمهندسين محمد عزت وياسر رمزي لاني مستجد ولا اعرف خريطة الموقع جيدا:eek:
    حيث انني اعتمد على كتاب سايبكس وفيديوهات بشمهندس محمد سمير فقط :D
    لكن اذا امكن توضيح الفرق بين المصطلحات الاربعة نظريا هنا اكون شاكر فضلكم كثيرا :ah4:

  9. #9
    عضو
    تاريخ التسجيل
    Jul 2007
    المشاركات
    339
    الدولة: Jordan
    معدل تقييم المستوى
    0

    رد: شكر عرفان ،وتساؤلات حيران حول ال NAT

    اخ احمد
    بردي الاخير شرحت ضمنيا الفرق بين الاربع مسميات



  10. #10
    عضو
    تاريخ التسجيل
    Mar 2010
    المشاركات
    106
    الدولة: Jordan
    معدل تقييم المستوى
    0

    رد: شكر عرفان ،وتساؤلات حيران حول ال NAT

    NATING :هي عملية تحويل ال Private IP address الى ال Public IP ADdress
    انوعه :
    Static NATING : يحول كل private IP واحد الى Public IP واحد
    و يسمى : mapping one to one
    automatic NATIN : يكون فيه اوحد او اثنين من public IP address يتم الاختيار منهم ويسمى Overloading nating
    over loading nating : يعني كل الشبكة تخرج على النت ب public Ip address واحد ويتم الفصل بين كل جهاز خارج الى النت عن طريق Port ID الذي يعمل عند LAyer 4

    inside local : هو ال private ip للجهاز داخل الشبكة
    inside global: هو ال public Ip اللي اخذو الجهاز لما خرج على النت
    outside global: هو ال Public IP للجهاز المطلوب الوصول اليه (Destination )
    outside local: هو private Ip للجهاز المطلوب الوصول اليه( Destination )

    port nat : في بعض الاحيان عملية NATING تعمل تأخير كبير .... و في بعض الخدمات مثل Broadcasting لا تتحمل اي تأخير
    port nat يخلي ال port دايما مفتوح عشان ما يحصل اي تأخير

    ACL : يفضل و ضع ACL و ذلك لتحديد اي اجهزة التي يجب ان تأخذ public IP
    بمعنى : هو نوع من security بتحديد اي الاجهزة التي تستطسع ان تصل الى الانترنت

    ان شاء الله تستفيد و تحصل على الاجابة
    و اي اسئلة انا جاهز

  11. #11
    عضو
    تاريخ التسجيل
    Jul 2011
    المشاركات
    107
    الدولة: Egypt
    معدل تقييم المستوى
    7

    رد: شكر عرفان ،وتساؤلات حيران حول ال NAT

    الحمد لله رب العالمين
    اخيرا فهمت الفرق بين المصطلحات الاربعة
    باقي عدة تساؤولات حول نفس الموضوع ثم انتقل الى مجموعة اسئلة اخرى ان شاء الله

    بالنسبة ل ACL
    هل هي ستاندرد ام اكستيندد ام اى حاجة ؟؟؟
    وعلى اى انتير فيس يتم تطبيق هذا ال ACL

    كما انني الاحظ وجود اوامر
    Static default route
    مع ال NAT
    فعلى اي راوتر يتم تنفيذ هذا الامر ؟
    وما علاقة ال NAT ب الموجهات ؟

  12. #12
    عضو
    تاريخ التسجيل
    Mar 2010
    المشاركات
    106
    الدولة: Jordan
    معدل تقييم المستوى
    0

    رد: شكر عرفان ،وتساؤلات حيران حول ال NAT

    اخي الكريم..انت قصدك الموجهات يعني راوتر؟؟

    الروتر يعرف عليه نات .... يسمى boundary لأنو بكون على حدود الشبكة

    بالنسبة لل ACL يفضل تكون ستاندرد.... لأنو الاشي المهم الوحيد اللي بدنا ياه source IP address عشان اعرف مين راح ينعملو NATING ومين ما بنقدر نعملو NATING
    بدي لستعين بالكونفغريشن اللي و ضعو الاخ
    fastory عشان نوضح بعض الامور
    R(config)# access-list 10 permit 11.1.1.0 0.0.0.255

    في هذا السطر بنحدد الرانج ال اي بي الممكن ينعمل الوو آِNATING لاحظ انها ستاندرد لأنو احنا بحاجة بس الى source IP


    R(config)# ip nat pool pool_a 200.1.1.1 200.1.1.254 netmask 255.255.255.0

    في هذا السطر عرفنا POOL يعني هذا المجال اللي من 200.1.1.1 الى 200.1.1.254
    هذا هو ال Public IP address اللي راح يطلع على النت


    R(config)# ip nat inside source list 10 pool pool_a

    في هذا السطر تم تعريف اي ACL اللي راح تنطبق على هاي ال POOL
    بمعنى ... اي IP ADDRESS RANGE ممكن يستفيد من ال POOL \


    Router(config)#interface fa0/0
    Router(config-if)#ip nat inside
    هون بعرف النات على interface ..... بمعنى و انت داخل على الراوتر طبق النات..بتكون هاي الانترفيس اللي بتدخل على الراوتر من الشبكة
    Router(config)#interface s0/0/1
    Router(config-if)#ip nat outside
    هاي بتكون على الانتر فيس اللي طالعة على النت


  13. #13
    عضو
    تاريخ التسجيل
    Jul 2011
    المشاركات
    107
    الدولة: Egypt
    معدل تقييم المستوى
    7

    رد: شكر عرفان ،وتساؤلات حيران حول ال NAT



    شكرا جزيلا وبارك الله فيك
    وبكده تكون اتحلت كل مشاكلي في هذا الموضوع
    ما عدا مشكلة واحدة
    سأحاول ان اكتبها بصيغة جديدة
    ان شاء الله
    وكل عام وانتم بخير

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •