النتائج 1 إلى 14 من 14

الموضوع: كيف يتم انتخاب ال DR&BDR فى ال osPF

  1. #1
    عضو
    تاريخ التسجيل
    Dec 2010
    المشاركات
    70
    الدولة: Egypt
    معدل تقييم المستوى
    0

    Angry كيف يتم انتخاب ال DR&BDR فى ال osPF



    بمعنى اخر ما هى القاعده التى على اساسها اختار ال DR وال BDR انا اعرف الخطوات اعرف انا الاختيار يكون على اساس البريورتى او على اساس الid اذا السؤال هل البريورتى تكون للروتر ككل ام تكون للانترفيس لو كانت للروتر ككل كيف اضع الامر بتاعها لو كانت لانترفيس اى انترفيس سأختاره وارجو شرح ال id
    انا بتلخبط فى الموضوع ده ارجو التوضيح

  2. #2
    عضو
    تاريخ التسجيل
    Dec 2010
    المشاركات
    70
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: كيف يتم انتخاب ال DR&BDR فى ال osPF

    ايه يا بشمهندسين هو السؤال صعب للدرجه دى ارجو الرد الانى مقبل على امتحان جزاكم الله خيرا

  3. #3
    عضو
    تاريخ التسجيل
    Jun 2009
    المشاركات
    114
    معدل تقييم المستوى
    0

    رد: كيف يتم انتخاب ال DR&BDR فى ال osPF

    القاعدة اللى بتم بهااختيار DR بتبقى بالترتيب ده

    1- اكبر RID ل loopback int
    2 - اكبر priority ل int
    3 - اكبر RID ل int


    RID هو اكبر ip موجود على int بتاع الروتر
    loopback int هو انترفيس وهمى وليس حقيقى (سوفتوير فقط) وهو دائما اكتف فى عمليات ospf
    priority هى ممكن تستخدمها بدل من loopback int فى تحديد DR و هى بتبقى رقم (1) فى الطبيعي لكل انترفيس


  4. #4
    عضو
    تاريخ التسجيل
    Jun 2009
    المشاركات
    114
    معدل تقييم المستوى
    0

    رد: كيف يتم انتخاب ال DR&BDR فى ال osPF

    مثال للتوضيح


    http://www.4shared.com/photo/8j-hXBa...ected_lab.html


    هنحدد اولا مين DR فى شبكة داخلية 172.16.1.0 عن طريق 3 خطوات اللى مكتوبين فوق
    1 - اختيار RID ل loopback int ----- لا يوجد loopback int اذا نشوف الاختيار التالى

    2 - اختيار اكبر priority --- هنلاقى ان كلهم يساوى الرقم default = 1 عن طريق الامر
    R1#sh ip ospf int f0/0
    اذا نشوف الاختيار التالى

    3- اختيار اكبر قيمة ل RID ---- اللى هو 192.168.11.254

    اذا R3 هو DR

    طب لو فى المثال السابق عايز اخلى R2 هو DR اعمل ايه
    هستخدم طريقة واحدة فقط لكى اغير DR من R3 واخليه R2
    loopback int or priority


    priority


    R2>
    R2>ena
    R2#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    R2(config)#int f0/0
    R2(config-if)#ip ospf priority 2

    وبعد كدا تعمل ريلود للروتر بس متنساش تعمل حفظ للكونفجريشن

    R2#reload
    Proceed with reload? [confirm
    ]
    ملحوظة كان ممكن تخلى R1,R3 بريورتى بتاعتهم تساوى صفر وكدا هيبقى R2 اكبر لان ديفولت بتاعته بتساوى 1

    ------------------------------------------------------

    loopback int


    R2(config)#int loop
    R2(config)#int loopback 0%LINK-5-CHANGED: Interface Loopback0, changed state to up%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to upR2(config-if)#ip add 192.1.1.5 255.255.255.255
    -----------------------------------------------------------




  5. #5
    عضو
    تاريخ التسجيل
    Dec 2010
    المشاركات
    70
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: كيف يتم انتخاب ال DR&BDR فى ال osPF

    اشكرك كثيرا انا الحمد لله فهمتهم كويس جدا بس القاعه الاساسيه التى يتبعها الروتر هى الاتى
    1-priority
    2-router id
    لولا لو البريورتى متلعبش فيها هتكون by default =1
    وانا ممكن اغيرها من الاوامر اللى قلتها حضرتك وهى من الرقم 0الى 255 يعنى لو روتر اديته 255 هضمن انه هيكون ال dr وبعدين الاختيار هيكون على اسا الروتر اى دى وده له2 طرق لوضعه الطريقه الاولى
    لوضعه وهو اساسا by defalt بيختار اعلى اى بى ليكون الاى دى فلو كانت البريورتى 1 اذا هنختار بناء على الروتر اى دى وممكن اعمل لوب بالك انترفيس من خلال الامر اللى حضرتك ذكرته وفى هذه الحاله الروتر سيتجاهل الوضع الافتراضى له وهو اختيار اعلى اى بى وهيخلى الاى بى اللى وضعته كلوب انترفيس هو الروتر اى دى وممكن كمان اضع الاى دى بتاعى تحت الامر router ospf

    R3#config t
    R3(config)#router ospf 1
    R3(config-router)#router-id 172.31.1.4
    R3(config-router)#Reload or use "clear ip ospf process" command, for
    this to take effect
    R3(config-router)#do clear ip ospf process
    Reset ALL OSPF processes? [no]: yes
    20:16:35: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.5.1 on FastEthernet0/0
    from FULL to DOWN, Neighbor Down: Adjacency forced to reset
    20:16:35: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.5.1 on FastEthernet0/0
    from FULL to DOWN, Neighbor Down: Interface down or detached
    R3(config-router)#do sh ip ospf
    Routing Process "ospf 1" with ID 172.31.1.4
    ده اللى انا فاهمه واشكرك كثيرا يا اخى ونظرا لان الرد تأخر قليلا فأنا اضطررت انا اعتمد على نفسى والف شكر لك (والله المستعان)


  6. #6
    عضو
    تاريخ التسجيل
    Jun 2009
    المشاركات
    114
    معدل تقييم المستوى
    0

    رد: كيف يتم انتخاب ال DR&BDR فى ال osPF

    العفو ولا شكرا على الواجب
    وكويس جدا جدا انك اعتمد على نفسك وعملت سيرش على الموضوع ومفضلتش ساكت
    والمهم انك فهمت فى الاخر

  7. #7
    عضو
    تاريخ التسجيل
    Jun 2009
    المشاركات
    114
    معدل تقييم المستوى
    0

    رد: كيف يتم انتخاب ال DR&BDR فى ال osPF

    ملحوظة بس انا نسيت اقولها ليك

    ان DR , BDR بيظهروا فقط لما يكون الروترات متوصلة بالطريقى دى
    brodcast or non-brodcast multi-acess network مثال لكدا ethernet , frame relay

    اما لو تم توصيل الروترات بهذه الطريقة فلا يكون هناك DR , BDR
    لكن لو الروترات متوصلة ببعص point to point عن طريق serial wan

  8. #8
    عضو
    تاريخ التسجيل
    Dec 2010
    المشاركات
    70
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: كيف يتم انتخاب ال DR&BDR فى ال osPF

    شكرا جدا انا ذاكرات سايبكس الاصدار السابع فى الحته دى وفهمتها كويس جدا وعندى سؤال تانى عايز افهمه لانى مفهمتهوش من الكتاب انا اعرف انه eigrp بيعمل ل by default الاوتو سمرى طيب امتى انا اتركه كما هو وامتى انا اغيره عن طريق الامر نو اوتو سمرى وهل فى ال ospf ممكن اعمل اوتو سمرى لانه لا يدعم الاوتو سمرى ارجو الرد ويتسع صدرك للاجابه عن هذا السؤال بالتفصيل (والله المستعان)

  9. #9
    عضو
    تاريخ التسجيل
    Jun 2009
    المشاركات
    114
    معدل تقييم المستوى
    0

    رد: كيف يتم انتخاب ال DR&BDR فى ال osPF

    طب فى الاول ابل ما اقولك اوتوسمرى فى eigrp احب الاول اتاكد انك عارف يعنى ايه discontiguous network

    هى فيها 2 او اكتر subnetworks ل classful network مربوطين مع بعض عن طريق classful network مختلف

    مثال للتوضيح لنيتورك مستخدمتش فيها نو اوتو سمرى ايه اللى هيحصل

    http://www.4shared.com/photo/IT7j26F...s_network.html

    لكن لما استخدم الامر نو اوتو سمرى سوف يختلف الوضع

    R2(config)#router eigrp 10
    R2(config-router)#net
    R2(config-router)#network 172.16.0.0
    R2(config-router)#network 10.0.0.0
    R2(config-router)#no auto-summary

    R1(config)#router eigrp 10
    R1(config-router)#net
    R1(config-router)#network 172.16.0.0
    R1(config-router)#network 10.0.0.0
    R1(config-router)#no auto-summary


    http://www.4shared.com/photo/AzTUhgP..._no_auto_.html

    -------------------------------------------------------------------------------------------------------------------------------------------

    RIPv2 , EGIRP شغلين مع discontiguous network بس مش فى ديفولت لانهم اوتو سمرى للكلاس فل باى ديفولت عشان كدا بنتستخدم نو اوتو سمرى
    اما OSPF فهو شغال مع discontiguous network فى دبفولت لانه مش اوتوا سمر للكلاس فل باى ديفولت زى


    يارب اكون وفقت فى الشرح



  10. #10
    عضو
    تاريخ التسجيل
    Dec 2010
    المشاركات
    70
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: كيف يتم انتخاب ال DR&BDR فى ال osPF

    :ah4::ah4::ah4::ah4::ah4: مش عارف اقولك ايه بصراحه اشكرك جدا وجزاك الله خيرا بالفعل قد وفقت فى الشرح زادك الله علما وكل سنه وانت بخير وتقبل الله صيامك واشكرك جدا (والله المستعان)

  11. #11
    عضو
    تاريخ التسجيل
    Jun 2009
    المشاركات
    114
    معدل تقييم المستوى
    0

    رد: كيف يتم انتخاب ال DR&BDR فى ال osPF

    ممكن الاميل بتاعك للتواصل مع بعض

  12. #12
    عضو
    تاريخ التسجيل
    Dec 2010
    المشاركات
    70
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: كيف يتم انتخاب ال DR&BDR فى ال osPF

    ممكن طبعا ده انا اتشرف
    aaasssahmed@

    yahoo.com

  13. #13
    عضو
    تاريخ التسجيل
    Jul 2012
    المشاركات
    34
    معدل تقييم المستوى
    0

    رد: كيف يتم انتخاب ال DR&BDR فى ال osPF

    الاخ baher 1
    ش يعني ?non-brodcast multi-acess network
    كم عدد الdr في ال area الوحده ؟

  14. #14
    عضو
    تاريخ التسجيل
    Jan 2005
    المشاركات
    789
    الدولة: Egypt
    معدل تقييم المستوى
    13

    رد: كيف يتم انتخاب ال DR&BDR فى ال osPF



    اقتباس المشاركة الأصلية كتبت بواسطة khrbji مشاهدة المشاركة
    الاخ baher 1
    ش يعني ?non-brodcast multi-acess network
    كم عدد الdr في ال area الوحده ؟
    Non - broad multi ccess lik ethe framrelay networks which by default
    defeat the broadcast

    and its called multiaccess coz more than one device can share th elinks together

    -------------
    سؤالك التانى

    area has only one DR
    the light in the end of the tunnel


    من
    يعين الناس . لابد ان تأتيه المعونه.

المواضيع المتشابهه

  1. اسئلة فى ال ospf
    بواسطة happiness2all في المنتدى الأرشيف
    مشاركات: 1
    آخر مشاركة: 09-06-2011, 02:43

الكلمات الدلالية لهذا الموضوع

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •