النتائج 1 إلى 6 من 6

الموضوع: question about vlans

  1. #1
    عضو
    تاريخ التسجيل
    Apr 2006
    المشاركات
    28
    الدولة: Jordan
    معدل تقييم المستوى
    0

    question about vlans



    if we have one switch and there are 2 vlans how they can see each others
    and can we make router let them sea each others?

  2. #2
    عضو محترف
    تاريخ التسجيل
    Aug 2009
    المشاركات
    504
    الدولة: Saudi Arabia
    معدل تقييم المستوى
    10

    رد: question about vlans

    السلا م عليكم ورحمة الله وبركاته
    طبعا حضرتك هتحتاج Router او layer 3 switch فى الحالة دى هتقدر تخلى كل Vlan تكلم بعضها لو عايز تمنع اى حد منهم هتحتاج

    تحط Access list

    CISCO : CCNA R&S CCNA security CCNP Security
    CCNP R&S CCIP CCIE R&S in Progress

    MICROSOFT : MCT MCTS MCITP Enterprise Admin Exchange 2010 Virtualization administrator SharePoint administrator


  3. #3
    عضو الصورة الرمزية سمرمون_2010
    تاريخ التسجيل
    Jan 2010
    المشاركات
    136
    معدل تقييم المستوى
    0

    رد: question about vlans

    السلام عليكم ورحمة الله وبركاته
    انت طبعا عملت ال2vlan وكل vlan مثلا متول بها pc كل pc هيكون الgateway بتاعه هو ال router ip
    والسويتش متوصل طبعا بالروتر ال port اللي بين الروتر والسويتش بتخليها trunk port البورت دي هي اللي بتخلي ال2 vlan يكلموا بعض الأوامر اللي هتعملها وليكن ان البورت الواصلة بين الروتر والسويتش f 0/1
    يبقى هتيجي على السويتش
    sw(config)#interface f 0/1
    sw(config-if)#switchport mode access
    sw(config-if)#switchport mode trunk
    كده أصبحت البورت ترنك
    وعلى ال2pc ما تنساش يكون الgateway بتاعهم هو router ip
    ربنا لا تؤاخذنا إن نسينا أو أخطأنا ربنا ولا تحمل علينا إصرا كما حملته على الذين من قبلنا ربنا ولا تحملنا ما لا طاقة لنا به واعف عنا واغفر لنا وارحمنا أنت مولانا فانصرنا على القوم الكافرين

  4. #4
    عضو
    تاريخ التسجيل
    Apr 2006
    المشاركات
    28
    الدولة: Jordan
    معدل تقييم المستوى
    0

    رد: question about vlans

    that mean we need to put Ip for vlan right and let router let them connecting to each others

  5. #5
    عضو
    تاريخ التسجيل
    Jan 2005
    المشاركات
    789
    الدولة: Egypt
    معدل تقييم المستوى
    13

    رد: question about vlans

    اخى العزيز

    من الواضح ان هناك التباس عندك ما بين ال switch layer 3 وما بين switch layer2

    فان كنت ستعطى ip لكل vlan معنى ذلك ان جهاذك المستخدم هوا switch layer 3 وبالتالى انت لست فى حاجه لوجد روتر

    لان الروتنج سيتم مباشرتا فيما بينهم بعد ظبط الاعدادات الازمه لذلك

    اما اذا كنت تقصد ان عندك سوتش layer 2 switch

    فانت لست بحاجه لاعطاء اى بى لل vlan ولكن ستقوم باعداد ما نسميه ب
    router on stick configuration
    (intervlan routing)

    تمنياتى بالتوفيق
    التعديل الأخير تم بواسطة sheno ; 19-01-2012 الساعة 15:29
    the light in the end of the tunnel


    من
    يعين الناس . لابد ان تأتيه المعونه.

  6. #6
    عضو
    تاريخ التسجيل
    Jun 2009
    المشاركات
    50
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: question about vlans



    أخي في الله


    هناك طريقتان و هذا ترتيبهم من بداية بالافضل

    1 - use Layer 3 Switch

    create vlan interfaces and give each an Ip ( in different subnets)
    example :
    interface Vlan 20
    sw(config-if)#ip add 192.168.1.1 255.255.255.0

    this ip should be the default gateway for all vlan 20 devices

    and dont forget to enable routing like this

    sw(config)# ip routing



    2 - Use Router on a stick

    فيما معناة

    اللينك اللي واصل بين السويتش و الراوتر اعملة Trunk علي السويتش

    In interface subcommand mode :

    sw(config-if)#switchport mode trunk

    اما بالنسبة للراوتر

    create sub interfaces and give each an Ip in the vlan subnet

    for example vlan 20 >>> subnet 192.168.1.0

    so on a router

    R1(config)# interface fa 0/0.20
    R1(config-subif)# ip add 192.168.1.1 255.255.255.0
    R1(config-subif)# encapsulation dot1q vlan 20


    encapsulation dot1q vlan 20 >>> This is to tell the router that the subinterface fa 0/0.20 wil be receiving from vlan 20

    you should give 192.168.1.1 as the default gateway for vlan 20 devices

    اتبع نفس الطريقة مع باقي ال Vlans


المواضيع المتشابهه

  1. شرح عن ال Native VLANs
    بواسطة Azzawi في المنتدى الأرشيف
    مشاركات: 34
    آخر مشاركة: 05-11-2011, 19:04
  2. Vlans and Isa server
    بواسطة abadsharona82 في المنتدى منتدى الشهادات العام
    مشاركات: 28
    آخر مشاركة: 19-01-2010, 08:24
  3. about VLANs
    بواسطة modather في المنتدى الأرشيف
    مشاركات: 3
    آخر مشاركة: 14-04-2009, 06:24
  4. سؤال عن VLANs
    بواسطة BlackHack في المنتدى الأرشيف
    مشاركات: 3
    آخر مشاركة: 23-02-2008, 18:52

الكلمات الدلالية لهذا الموضوع

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •