النتائج 1 إلى 12 من 12

الموضوع: كيفيه عمل Easy Vpn على روتر 877 ؟؟؟

  1. #1
    عضو
    تاريخ التسجيل
    Aug 2007
    المشاركات
    14
    معدل تقييم المستوى
    0

    كيفيه عمل Easy Vpn على روتر 877 ؟؟؟



    عندي سايت في السعودية و عندي public ip

    و سايت في الكويت و مفيش فيه Public ip

    و عاوز اعمل Easy VPN على راوتر في الكويت يشبك على الراوتر اللي عليه public IP في السعوديه

    ممكن تساعدوني في ال configuration ??

  2. #2
    عضو برونزي الصورة الرمزية Gawad
    تاريخ التسجيل
    Nov 2009
    المشاركات
    1,933
    معدل تقييم المستوى
    18

    رد: كيفيه عمل Easy Vpn على روتر 877 ؟؟؟

    بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

    تحتاج شراء real ip في موقع الكويت، وبرضوا علشان نبقوا ماشيين صح، انت محتاج راوتر سيسكو في كل موقع والكونفجريشن بتاعه سهل إن شاء الله، مجرد انك بتعمل tunnel فقط، او اقولك اسهل من كده ممكن تستخدم برنامج الSDM هو عبارة عن ابلكيشن GUI

    وصلي الله وسلم وبارك علي المصطفي وآله وصحبه وإخوانه وسلم
    [CENTER][SIZE=4][COLOR=Blue]اللهم صلي على محمد وعلى آل محمد كما صليت على آل إبراهيم وبارك على محمد وعلى آل محمد كما باركت على آل إبراهيم في العالمين إنك حميد مجيد[/COLOR][/SIZE]

    [B][SIZE=4]اللهم احفظ مصر آمنة مطمئنة وسائر بلاد المسلمين
    اللهم قنا الفتن ما ظهر منا وما بطن
    [/SIZE][/B]
    [/CENTER]

  3. #3
    عضو
    تاريخ التسجيل
    Aug 2007
    المشاركات
    14
    معدل تقييم المستوى
    0

    رد: كيفيه عمل Easy Vpn على روتر 877 ؟؟؟

    اقتباس المشاركة الأصلية كتبت بواسطة Ahmed.Mustafa مشاهدة المشاركة
    بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

    تحتاج شراء real ip في موقع الكويت، وبرضوا علشان نبقوا ماشيين صح، انت محتاج راوتر سيسكو في كل موقع والكونفجريشن بتاعه سهل إن شاء الله، مجرد انك بتعمل tunnel فقط، او اقولك اسهل من كده ممكن تستخدم برنامج الSDM هو عبارة عن ابلكيشن GUI

    وصلي الله وسلم وبارك علي المصطفي وآله وصحبه وإخوانه وسلم



    اخي الكريم .. شكرا لردك بس انا عملت قبل كده easy vpn على asa 5505 و كان عندي public ip واحد بس في موقع من الاتنين
    بس المشكلة المرة دي اني عاوز اعملها بين راوترين و الراوتيرن موجودين في الموقعين و زي ما قلتلك واحد عليه public ip و التاني لا

    و شكراااااا لك لتعاونك

  4. #4
    عضو
    تاريخ التسجيل
    Feb 2005
    المشاركات
    198
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: كيفيه عمل Easy Vpn على روتر 877 ؟؟؟

    السناريو اللى انت عاوزه vpn site to site
    علشان يشتغل معاك على الروترين اللى فى الفرعين
    لو انت موش هتقدر تشترى ريال ايبى فى الكويت
    يبقى ممكن تحتاج ddns
    تشترك فى موقع وتحجز هوست
    ولو عندك روتر سيسكو فى الفرع اللى فى الكويت ممكن تشغل عليه الخدمه
    انصحك بروتر small bussiness
    تقدر تعمله بسهوله بالجرافيك انترفيس

  5. #5
    عضو
    تاريخ التسجيل
    Aug 2007
    المشاركات
    14
    معدل تقييم المستوى
    0

    رد: كيفيه عمل Easy Vpn على روتر 877 ؟؟؟

    اقتباس المشاركة الأصلية كتبت بواسطة زلزال الشرقيه مشاهدة المشاركة
    السناريو اللى انت عاوزه vpn site to site
    علشان يشتغل معاك على الروترين اللى فى الفرعين
    لو انت موش هتقدر تشترى ريال ايبى فى الكويت
    يبقى ممكن تحتاج ddns
    تشترك فى موقع وتحجز هوست
    ولو عندك روتر سيسكو فى الفرع اللى فى الكويت ممكن تشغل عليه الخدمه
    انصحك بروتر small bussiness
    تقدر تعمله بسهوله بالجرافيك انترفيس


    انا عندي راوتر cisco 877 هل ممكن اعمل عليه ddns
    و لو ينفع ممكن تعطيني اي decumintation يساعدني

  6. #6
    عضو برونزي الصورة الرمزية sherif-magdy
    تاريخ التسجيل
    Sep 2009
    المشاركات
    1,027
    الدولة: Egypt
    معدل تقييم المستوى
    18

    رد: كيفيه عمل Easy Vpn على روتر 877 ؟؟؟

    هناك فرق بين Site-To-Site VPN ودة لو حبيت تطبقه هتحتاج Real IP لكل طرف علشان تعمل ال Tunnel
    وبين Easy VPN و هى من ال Remote Access هتحتاج بس Real IP على VPN Server وباقى الفروع هتربطها على أنها Clients عادية
    فى سيناريو تانى ممكن تطبقه وهى DMVPN النوع ده هيساعدك لو انت ناوى تتوسع فى توصيل فروع اخرى فى المستقبل ابحث عنه فى جوجل
    اخيرا انصحك تتدرب على تطبيق اللاب الاول على GNS3 علشان لو واجهتك مشاكل تتعرف عليها
    بالنسبة للكونفجريشن http://www.cisco.com/en/US/docs/rout...ide/ezvpn.html

    ولو محتاج اى مساعدة قولى - انا كنت كاتب رد اكثر تفصيلا بس للاسف ضاع اثناء عمل الترقية للمنتدى
    بالتوفيق

  7. #7
    عضو
    تاريخ التسجيل
    Aug 2007
    المشاركات
    14
    معدل تقييم المستوى
    0

    رد: كيفيه عمل Easy Vpn على روتر 877 ؟؟؟

    اقتباس المشاركة الأصلية كتبت بواسطة sherif-magdy مشاهدة المشاركة
    هناك فرق بين Site-To-Site VPN ودة لو حبيت تطبقه هتحتاج Real IP لكل طرف علشان تعمل ال Tunnel
    وبين Easy VPN و هى من ال Remote Access هتحتاج بس Real IP على VPN Server وباقى الفروع هتربطها على أنها Clients عادية
    فى سيناريو تانى ممكن تطبقه وهى DMVPN النوع ده هيساعدك لو انت ناوى تتوسع فى توصيل فروع اخرى فى المستقبل ابحث عنه فى جوجل
    اخيرا انصحك تتدرب على تطبيق اللاب الاول على GNS3 علشان لو واجهتك مشاكل تتعرف عليها
    بالنسبة للكونفجريشن http://www.cisco.com/en/US/docs/rout...ide/ezvpn.html

    ولو محتاج اى مساعدة قولى - انا كنت كاتب رد اكثر تفصيلا بس للاسف ضاع اثناء عمل الترقية للمنتدى
    بالتوفيق


    شكرا مرة اخرى لتعاونك
    انا اريد مساعدتك معلش .. انا عاوز اعمل Easy VPN على الراوتر اللي عليه ال public ip و عاوز اعمل client على الراوتر التاني ..
    بالنسبة للمثال اللي حضرتك حطيتو انا شوفتو بس بردو موجود مستخدم public ip في ال client فياريت تعرفني ازاي اعمل ال clients
    معلش بتعبك معايا و جزاك الله خيرا

  8. #8
    عضو برونزي الصورة الرمزية sherif-magdy
    تاريخ التسجيل
    Sep 2009
    المشاركات
    1,027
    الدولة: Egypt
    معدل تقييم المستوى
    18

    رد: كيفيه عمل Easy Vpn على روتر 877 ؟؟؟

    يعنى الكونفجريشن على الكلينت هيكون شبيه بكدة

    VPN_Client configuration

    !
    crypto isakmp invalid-spi-recovery
    !
    crypto ipsec client ezvpn EzVPN
    connect manual
    group EzVPN key cisco123
    mode client
    peer 31.1.1.2
    username cisco password cisco
    xauth userid mode interactive
    !

    لاحظ ان ال IP بتاع ال Peer او ال VPN Server لازم يكون Static وهو فى المثال 31.1.1.2 , اوممكن تستخدم خدمة DDNS والموضوع ده ليه شرح على مدونة نتوركسيت
    وفى كل مرة هتتصل على السيرفر هيطلب منك اليوزرنيم والباسورد بشكل Interactive



    interface FastEthernet0/0
    crypto ipsec client ezvpn EzVPN outside
    ! الامر ده هتطبقه على الانترفيس اللى واصل على النت اواى شبكة خارجية




    interface FastEthernet0/1
    crypto ipsec client ezvpn EzVPN inside
    والامر ده علشان تحدد الشبكة الداخلية اللى هتتربط مع الفرع الاخر بال VPN
    !

    ديه طبعا الاوامر الاساسية للموضوع والاوامر بالاسود هى الاهم ولو حاسس ان الموضوع صعب ممكن تستخدم ال SDM لتسهيل الامور

  9. #9
    عضو
    تاريخ التسجيل
    Feb 2005
    المشاركات
    198
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: كيفيه عمل Easy Vpn على روتر 877 ؟؟؟

    الاستاذ شريف شرح ولا اروع
    بس لو انت عاوز تشغل ddns على سيسكو روتر
    http://www.cisco.com/en/US/docs/ios/...8/gt_ddns.html

  10. #10
    عضو
    تاريخ التسجيل
    Aug 2007
    المشاركات
    14
    معدل تقييم المستوى
    0

    رد: كيفيه عمل Easy Vpn على روتر 877 ؟؟؟

    شكرااا مرة اخرى لتعاونكم ..
    انا حاولت اعمل الكونفجريشن و خلصتو بس طلعلي error
    مش عارف سببو بالظبط
    و دي الconfiguration بتاعتي


    EZ-SERVER#
    Building configuration...

    Current configuration : 1368 bytes
    !
    version 12.4
    service timestamps
    debug datetime msec
    service timestamps log datetime msec
    no service
    password-encryption
    !
    hostname
    Router
    !
    boot-start-marker
    boot-end-marker
    !
    enable password
    cisco
    !
    aaa new-model
    !
    !
    aaa authentication login cisco
    local
    aaa authorization network cisco local
    !
    aaa session-id
    common
    !
    resource policy
    !
    ip subnet-zero
    ip
    cef
    !
    !
    !
    !
    !
    !
    !
    !
    username XXXX password 0
    XXXX
    !
    !
    !
    crypto isakmp policy 3
    encr 3des
    authentication
    pre-share
    group 2
    !
    crypto isakmp client configuration group
    cisco
    key cisco
    !
    !
    crypto ipsec transform-set cisco esp-3des
    esp-sha-hmac
    !
    crypto dynamic-map cisco 10
    !
    !
    crypto map cisco
    client authentication list cisco
    crypto map cisco isakmp authorization list
    cisco
    crypto map cisco 10 ipsec-isakmp dynamic cisco

    !
    !
    !
    interface Loopback1
    ip address 30.30.30.30
    255.255.255.0
    !
    interface GigabitEthernet0/0
    no ip
    address
    shutdown
    duplex auto
    speed auto
    media-type
    rj45
    negotiation auto
    !
    interface GigabitEthernet0/1
    ip address
    62.150.168.222 255.255.255.0
    duplex auto
    speed
    auto
    media-type rj45
    negotiation auto
    crypto map cisco
    !
    ip
    default-gateway 62.150.168.1
    ip classless
    ip route 0.0.0.0 0.0.0.0
    62.150.168.1
    !
    ip http server
    no ip http
    secure-server
    !
    !
    !
    control-plane
    !
    !
    !
    line con
    0
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    !
    scheduler
    allocate 20000 1000
    !
    end





    EZ-Client#


    Building configuration...

    Current configuration : 1286 bytes
    !
    version 12.4
    no service
    pad
    service timestamps debug datetime msec
    service timestamps log datetime
    msec
    no service password-encryption
    !
    hostname
    EZ-Client
    !
    boot-start-marker
    boot-end-marker
    !
    enable password
    cisco
    !
    no aaa new-model
    memory-size iomem 20
    !
    !
    dot11
    syslog
    !
    !
    ip cef
    ip auth-proxy max-nodata-conns 3
    ip admission
    max-nodata-conns 3
    !
    !
    !
    username XXXX password 0 XXXX
    !

    !
    !
    !
    !
    !
    crypto ipsec client ezvpn cisco
    connect
    auto
    group cisco key cisco
    mode network-extension
    peer
    62.150.168.222
    xauth userid mode
    interactive
    !
    archive
    log config

    hidekeys
    !
    !
    !
    !
    !
    interface Loopback0
    ip address
    20.20.20.20 255.255.255.0
    crypto ipsec client ezvpn cisco
    inside
    !
    interface ATM0
    no ip address
    shutdown
    no atm
    ilmi-keepalive
    dsl operating-mode auto
    !
    interface
    FastEthernet0
    !
    interface FastEthernet1
    !
    interface
    FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan1
    ip
    address dhcp
    crypto ipsec client ezvpn cisco
    !
    ip forward-protocol
    nd
    ip route 30.30.30.0 255.255.255.0 62.150.168.222
    !
    no ip http
    server
    no ip http secure-server
    !
    !
    control-plane
    !
    !
    line
    con 0
    exec-timeout 15 0
    logging synchronous
    login local
    no modem
    enable
    line aux 0
    line vty 0 4
    exec-timeout 15 0
    logging
    synchronous
    login local
    !
    scheduler max-task-time 5000
    end





    and this is the error message

    %CRYPTO-6-EZVPN_CONNECTION_DOWN: (Client) User= Group=cisco
    Client_public_addr=10.237.101.131
    Server_public_addr=62.150.168.222





    note : in error message (Client_public_addr=10.237.101.131)
    this is not public ip for client it is private ip router toke from DHCP server
    because in client side i dont have dedicated public ip for vpn because it is dsl
    ..


    as i mentioned in first discussion i have only 1 public ip in
    the side of 1841 router

  11. #11
    عضو برونزي الصورة الرمزية sherif-magdy
    تاريخ التسجيل
    Sep 2009
    المشاركات
    1,027
    الدولة: Egypt
    معدل تقييم المستوى
    18

    رد: كيفيه عمل Easy Vpn على روتر 877 ؟؟؟

    معلش ممكن توضح هذا الجزء
    الروتر الكلينت اللى فى الكويت بيطلع ازاى على الانترنت هل ليه Gateway بيعدى من خلاله ؟
    ياريت لو الشبكة فيها اجهزة اخرى تحط صورة مبسطة للتوبولجى كلها وانا هعملك الكونفجريشن .

  12. #12
    عضو
    تاريخ التسجيل
    Aug 2007
    المشاركات
    14
    معدل تقييم المستوى
    0

    رد: كيفيه عمل Easy Vpn على روتر 877 ؟؟؟



    اقتباس المشاركة الأصلية كتبت بواسطة sherif-magdy مشاهدة المشاركة
    معلش ممكن توضح هذا الجزء
    الروتر الكلينت اللى فى الكويت بيطلع ازاى على الانترنت هل ليه Gateway بيعدى من خلاله ؟
    ياريت لو الشبكة فيها اجهزة اخرى تحط صورة مبسطة للتوبولجى كلها وانا هعملك الكونفجريشن .

    شكراااا جدااا لاهتمامك و يا ريت تساعدني لاني دورت كتير و موصلتش لحل



    Uploaded with ImageShack.us

المواضيع المتشابهه

  1. (مصر -الجيزة ) للبيع روتر netgear DM111PUSP +روتر SPEED TOUCH 530V6
    بواسطة engineertarek في المنتدى الأرشيف
    مشاركات: 0
    آخر مشاركة: 08-10-2011, 15:26
  2. كيفيه تعريف اكثر من انترفيس على روتر سبيدتاتش
    بواسطة himaking في المنتدى الأرشيف
    مشاركات: 0
    آخر مشاركة: 17-01-2011, 01:09
  3. طلب مساعدة في تغير configuration من روتر الى روتر جديد
    بواسطة beta group في المنتدى الأرشيف
    مشاركات: 3
    آخر مشاركة: 11-09-2009, 01:45
  4. رجاءا اريد شرح كيفيه فتح بورت فى روتر tp-link
    بواسطة seneen_sodah في المنتدى الأرشيف
    مشاركات: 2
    آخر مشاركة: 21-04-2009, 20:50
  5. ربط روتر لاسلكي مع روتر سلكي
    بواسطة data في المنتدى الأرشيف
    مشاركات: 8
    آخر مشاركة: 06-01-2008, 07:55

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •