النتائج 1 إلى 5 من 5

الموضوع: EFFECT OF NAT

  1. #1
    عضو الصورة الرمزية 3BADI750
    تاريخ التسجيل
    Sep 2007
    المشاركات
    88
    معدل تقييم المستوى
    0

    Exclamation EFFECT OF NAT



    السلام عليكم ورحمة الله وبركاته
    اخواني الاعزاء
    هذا شرح لجزء مهم جدا جدا خاصة في الحياة العملية

    Effect of NAT over Static Routing



    ip route 172.16.30.0 255.255.255.0 172.16.20.1
    ip route 172.16.10.0 255.255.255.0 172.16.20.2

    دي الطريقة العادية اللي بعرف بيها Static Route

    لكن تعالوا بقا نشوف بعد ما نحط ال nat بتاعتنا ايه اللي هيحصل



    اولا : نفرض مثلا ان ال ip الي هوا 172.16.10.3 عاوز يبعت داتا ل 172.16.30.7
    زي ما شفنا في الرسمة ال NAT هتديله real ip وتبعت ال packet
    طيب لغاية هنا اوكي مفيش اي مشاكل
    لكن تعالوا نشوف لما 172.16.30.7 يجي يرد علي 172.16.10.3
    برضوا هيبعت الpacket زي ما هو باين في الرسمة
    وهنا هيجي الراوتر يدور علي 1.1.1.5 في الجدول بتاعه مش هيلاقيه
    فيقوم عامل ايه Discard للداتا

    لان اللي كان مفروض يتعرف علي الراوتر
    ip route 1.1.1.0 255.255.255.0 172.16.20.2

    ودي طبعا حاجة مهمة جدا لازم ناخد بالنا منها

    Effect of NAT over Dynamic Routing



    مثلا احنا هنستخدم ال RIP

    router rip
    network 172.16.0.0
    network 192.168.1.0

    وبالتالي كدا هنبعت update عن 172.16.0.0 وهي اساسا مش موجودة
    طيب مش موجودة ليه ؟؟؟
    لانها دي اي بيهات private والتعامل ع الشبكة هيكون ب real

    طيب ايه الحل ....!

    router rip
    network 1.1.1.0
    network 192.168.1.0

    طيب تمام بس هنا في مشكلة
    بعد ما اكتب الاوامر دي ال RIP هيعمل Reinitialization للراوتر
    وهنا هيلاقي ان مفيش شبكة متوصلة بيه اسمها 1.1.1.0
    وكدا الراوتر مش هيقبل الحوار دا

    طيب ايه الحل يا عمنا ...!

    الحل اننا نعرف logical Interface
    loop back 0
    ونديله ال ip بتاع 1.1.1.0
    وكدا هو هيتعرف عليها

    اتمني من الله انكوا تستفادوا منها شئWink:
    ولا تنسونا بدعواتكم في ظهر الغيب
    عبـدالله الــعــبـــــادي
    --------------------


    THE BEST THING ABOUT PAIN
    IT TELLS YOU THAT YOU STILL ALIVE

  2. #2
    عضو
    تاريخ التسجيل
    Apr 2007
    المشاركات
    532
    معدل تقييم المستوى
    0

    رد: EFFECT OF NAT

    مشكور على الشرح ويعطيك العافيه

  3. #3
    عضو الصورة الرمزية 3BADI750
    تاريخ التسجيل
    Sep 2007
    المشاركات
    88
    معدل تقييم المستوى
    0

    رد: EFFECT OF NAT

    اخ hamodii
    متشكر جدا واتمني انك تكون استفدت ولو القليل
    عبـدالله الــعــبـــــادي
    --------------------


    THE BEST THING ABOUT PAIN
    IT TELLS YOU THAT YOU STILL ALIVE

  4. #4
    عضو الصورة الرمزية 3BADI750
    تاريخ التسجيل
    Sep 2007
    المشاركات
    88
    معدل تقييم المستوى
    0

    رد: EFFECT OF NAT

    تم تعديل لينكات الصور لحدوث بعض المشاكل
    لو في اي مشاكل تانية يا ريت حد يقولي
    عبـدالله الــعــبـــــادي
    --------------------


    THE BEST THING ABOUT PAIN
    IT TELLS YOU THAT YOU STILL ALIVE

  5. #5
    عضو فضي الصورة الرمزية memoragaa
    تاريخ التسجيل
    Jan 2005
    المشاركات
    1,302
    الدولة: Egypt
    معدل تقييم المستوى
    14

    رد: EFFECT OF NAT



    جزاك الله خيرا
    شبكاوى قديم مع إيقاف التنفيذ
    لا تنسونا من صالح الدعاء

المواضيع المتشابهه

  1. تأجيل Mass Effect 3 !
    بواسطة Mohamed.Ashmawy في المنتدى الأرشيف
    مشاركات: 0
    آخر مشاركة: 04-05-2011, 21:23
  2. مشكلة في mass effect 2
    بواسطة ammaR80 في المنتدى الأرشيف
    مشاركات: 1
    آخر مشاركة: 19-02-2010, 14:27
  3. مشكلة فى mass effect 2
    بواسطة abdo201055 في المنتدى الأرشيف
    مشاركات: 4
    آخر مشاركة: 13-02-2010, 10:47
  4. The GeForce Effect
    بواسطة demarco في المنتدى البرمجه والتصميمات الفنيه ( الجرافيكس )
    مشاركات: 3
    آخر مشاركة: 17-12-2006, 16:09
  5. adobe after effect.bin
    بواسطة ابو سلاح في المنتدى الأرشيف
    مشاركات: 3
    آخر مشاركة: 30-08-2006, 19:19

الكلمات الدلالية لهذا الموضوع

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •