صفحة 1 من 2 1 2 الأخيرةالأخيرة
النتائج 1 إلى 15 من 16

الموضوع: distribute-list,redistribute rip,redistribute ospf

  1. #1
    عضو
    تاريخ التسجيل
    Dec 2006
    المشاركات
    171
    معدل تقييم المستوى
    0

    Arrow distribute-list,redistribute rip,redistribute ospf



    أرجو شرح من أخوانى الكرام ما قيل من خلال بحثى فى منتدى من موقع كوماند
    distribute-list
    redistribute rip subnets
    distribute-list 11 out rip
    و بالمثل على ospf
    ??????????????????????
    و هذا شرح باللغة الانجليزية و للاسف لم أستوعبة استيعاب كامل.


    In the beloew example, I think I can use route-map to
    filter the route in redistribution. What is the
    advantage of using "distribute-list out" ?


    interface serial 0
    ip add 130.10.62.1 255.255.255.0
    !
    interface serial 1
    ip add 130.10.63.1 255.255.255.0
    !
    interface ethernet 0
    ip add 130.10.8.1 255.255.255.0
    !
    interface tokenring 0
    ip add 130.10.9.1 255.255.255.0
    !
    router rip
    default-metric 10
    network 130.10.0.0
    passive-interface serial 0
    passive-interface serial 1
    redistribute ospf 109
    distribute-list 10 out ospf 109
    !
    router ospf 109
    network 130.10.62.0 0.0.0.255 area 0
    network 130.10.63.0 0.0.0.255 area 0
    redistribute rip subnets
    distribute-list 11 out rip
    !
    access-list 10 deny 130.10.8.0 0.0.7.255
    access-list 10 permit 0.0.0.0 255.255.255.255
    access-list 11 permit 130.10.8.0 0.0.7.255
    access-list 11 deny 0.0.0.0 255.255.255.255

  2. #2
    عضو
    تاريخ التسجيل
    Dec 2006
    المشاركات
    171
    معدل تقييم المستوى
    0

    رد: distribute-list,redistribute rip,redistribute ospf

    باقى الشرح باللغة الانجليزية

    There is more similiarity between route-map (using match ip address/match ip address prefix-list) and 'distribut-list in' than with 'distribute-list out'. With both, you can filter the unwanted routes at the point of redistribution into the destination routing protocol.

    'Distribute-list out' tells the source routing protocol not to forward the route in the first place, while route-map filters the route after it has been forwarded and is at the destination router and routing protocol.

    Route-map is more granular than distribute-list out; distribute list affects all routers connected to a given interface or a particular routing protocol (depending on how it is applied), but route-map only affects the routing protocol on which it is configured.

    There are many other differences, others in this group will be able to contribute


    أرجو الافادة

  3. #3
    عضو
    تاريخ التسجيل
    Dec 2006
    المشاركات
    171
    معدل تقييم المستوى
    0

    رد: distribute-list,redistribute rip,redistribute ospf

    offsetهذا الامر متى كتابتة و كيف ؟
    ارجو الاجابة بالتفصيل و انا مرفق فوق مثال ليتم الشرح علية مع أضافة أمر الoffest .
    و شكرا

  4. #4
    عضو
    تاريخ التسجيل
    Dec 2006
    المشاركات
    171
    معدل تقييم المستوى
    0

    رد: distribute-list,redistribute rip,redistribute ospf

    تسألات كثيرة و هل

    distribute-list 10

    distribute-list 11

    لوجود access-list مطبقة على أنترفيس ؟ و هذة الارقام 10&11 هى أرقام تلك الأكسس ليست.

    بجد محتاج أجابة مطبقة على هيئة مثال و توضيح خطوة خطوة لكل تلك الكوماند اللى سالت عنها .

  5. #5
    عضو برونزي
    تاريخ التسجيل
    May 2007
    المشاركات
    1,475
    معدل تقييم المستوى
    12

    رد: distribute-list,redistribute rip,redistribute ospf

    اسف اخي لعدم المساعده حيث هذا الموضوع مكانه اما سيسكو العام او قسم الccnp
    وانا لسه مبدأتش فيها بس كل اللي اعرفه انس
    هي النظم الموزعه
    واسف لعدم الافاده اخي العزيز ولكن منتظر افاده الباقين لعلني اتعلم شئ جديد ان شاء الله
    -------------------------------------------
    [B][SIZE=4]فين الاسئله يا شباب في اقسام Cisco
    عاوزين اسئله في الVoice و الData
    عاوزين نقدر نفدكم [/SIZE][/B]

  6. #6
    عضو
    تاريخ التسجيل
    Feb 2008
    المشاركات
    116
    معدل تقييم المستوى
    0

    رد: distribute-list,redistribute rip,redistribute ospf

    i can not explain arbic but you can see in sybex verision six in roting protocol by simple

    sorryyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy yyyyyyy

  7. #7
    عضو
    تاريخ التسجيل
    Aug 2007
    المشاركات
    206
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: distribute-list,redistribute rip,redistribute ospf

    اسف لعدم المساعدة ولكنى اوافق على كلام هندسة العاشر

  8. #8
    عضو
    تاريخ التسجيل
    Feb 2008
    المشاركات
    116
    معدل تقييم المستوى
    0

    رد: distribute-list,redistribute rip,redistribute ospf

    in ccna

  9. #9
    عضو
    تاريخ التسجيل
    Dec 2006
    المشاركات
    171
    معدل تقييم المستوى
    0

    رد: distribute-list,redistribute rip,redistribute ospf

    no comment....

    i was hope to any one answer to my questions and ....if i choose the wrong place to put my subject .. it did not mean no one answer me.
    and who answers just say ... wrong place to put this subject ... anyway
    thnx

  10. #10
    عضو
    تاريخ التسجيل
    Dec 2006
    المشاركات
    171
    معدل تقييم المستوى
    0

    رد: distribute-list,redistribute rip,redistribute ospf

    قد أكون ايها الاخوة الافاضل كتبت الموضوع فى منتدى خطا و كنت المفروض أن اكتبة فى منتدى الccnp كما قلتكم ... و لكن هل معنى انى اتلخبطت و لاول مرة من اشتراكى فى المنتدى من فترة طـــــــــــــــــــــــويلة جدا ان يكون مجرد رد على اسئلتى
    هندسه العاشر
    عضو نشيط
    رد: distribute-list,redistribute rip,redistribute ospf

    --------------------------------------------------------------------------------

    اسف اخي لعدم المساعده حيث هذا الموضوع مكانه اما سيسكو العام او قسم الccnp
    للعلم أخى انا كنت زميل ليك فى هندسة العاشر ههههههههههه عشان كدة انا بحب دايما تعليقاتك لانك من هندسة العاشر

    wael mohamed el
    عضو

    اسف لعدم المساعدة ولكنى اوافق على كلام هندسة العاشر

    انت صح يا أخ وائل فى انى اتلخبطت فى كتابة موضوعى فى منتدى خطا

    منتظر رد اخى لومارك و الاخ محمد سمير و باقى الاخوة الافاضل على موضوعى اللى اتمنى بجد حد يساعدنى على فهمة

    أخوكمccna76

  11. #11
    عضو فضي الصورة الرمزية lumark_s
    تاريخ التسجيل
    Jan 2005
    المشاركات
    2,624
    معدل تقييم المستوى
    17

    رد: distribute-list,redistribute rip,redistribute ospf

    السلام عليكم

    مافي مشكلة أخي الحبيب، الموضوع في قسم سيسكو وهذا أهم شيء فلا تشغل بالك في موضوع المكان، المهم أن تسأل و تحاور ولا تستلم لضعف اللغة الإنجليزية وأحييك على هذه الروح العالية في حب المعرفة والعلم وسأكون سعيد يا أخي الحبيب أن أجاوبك بعض الشيء، الوقت متأخر هنا وعندي عمل ولكن سأعود لك لتكملة باقي الجواب بعون الله، كون هذا الموضوع هو عصب سيسكو، وبدون فهم كامل وممتاز لهذا الموضوع لن تنجح في هذا الموضوع على الإطلاق، ولكن بعون الله سأشرحه لك بطريقة سهلة وعلى مراحل أخي العزيز.

    هذا الموضوع يا أحبة موضوع جميل جداً ومهم جداً جداً في حياتك العملية، ولكن عليك أولاً فهم ال Redistribution بشكل كامل، وهو موضوع سهل ولكنه بحاجة لتركيز، وبعد أن تتعلم ال Redistribution بشكل ممتاز وتتنقه بإحتراف ستنتقل للخطوة التالية وهي: كيف أتحكم بال Routing Updates بعد أن عملت Redistribution ؟؟ كيف أمنع Routes معينة من الدخول أو الخروج لشبكتي؟؟ كيف أمنع ال Routing Loops في الشبكة بعد أن عملت ال Redisribution ؟؟؟ كيف أجعل الشبكة أكثر إنسيابية ؟؟ هنا يأتي الفن والإبداع بإستخدام إحدى الطرق الثلاث لتحقيق هذه العملية بنجاح، هذه الطرق هي:

    1- Distribute List
    2- Route-Maps
    3- Administrative Distance

    بصراحة يا أخي هذه الامور الثلاث هي عصب وقلب ال Routing وهي سهلة ولكن لابد إستيعابها بشكل كبير جداً والتدريب عليها بشكل مستمر مع التفنن بالذكاء في إستعمال هذه الأدوات.

    المهم أن تفهم أولاً ماهو ال ReDistribution والهدف منه وكيف يتم، ومن ثم بعد أن تتقنه تنتقل للأمور الثلاث التي ذكرتها.


    Distribute تعني توزيع، Re تعني إعادة توزيع شيء بداخل شيء آخر.

    كلمة Redistribute تعني إعادة توزيع Routes تم إنشائها من خلال Routing Protocol معين مثل ال RIP بداخل Routing Protocol آخر .

    يعني تشغيل أكثر من Routing Protocol على نفس الرواتر، عملية ال Redistribution هي العملية التي تسهل على كل من ال Routing Protocols أن يقرأن ويفهمان هذه ال Routes المتختلفة.

    يعني لنفرض أنه عندنا رواتر، هذا الرواتر يوجد عليه Two Interfaces ، أحد هذه الإنترفيس مشغلين عليه RIP وعلى الإنترفيس الآخر مشغلين OSPF ، أقول مثلاً يعني.

    لا يوجد غلط في هذه المعلومة، يوجد حالات تضطر فيها أحيانا أن تشغل أكثر من راوتنج بروتوكول على نفس الرواتر، طيب هل دومين ال RIP يعرف ماهي ال Networks أو ال Prefixes الموجودة في دومين ال OSPF ؟؟

    الجواب طبعاً لا، لماذا؟؟ لأنه ال RIP برتقال و ال OSPF تفاح، هل يجوز أن تقول أن البرتقال هو نفسه التفاح؟؟؟ والراوتنج بروتوكول نفس الشيء، كل راوتنج بروتوكول يختلف عن الآخر، ال RIP له مميزات وخصائص وكذلك ال OSPF له مميزات وخصائص.

    لحل هذه المشكلة تقوم بعمل Redistribution على الراوتر ، يعني نقول لل RIP : يا RIP سنقوم بضخ الشبكات التالية في جدول البيانات الخاص بك، ولكن إنتبه يا RIP هذه الرواترات هي من نوع آخر وهو OSPF ولكن لا تقلق يا RIP سأساعدك على فهم هذه البيانات.

    وبالمقابل نقول لل OSPF : يا OSPF سنقوم بضخ شبكات معينة في قاعدة البيانات الخاصة بك، ولكن يا OSPF إنتبه، فهذه الشبكات هي من بروتوكول آخر هو RIP ، ولكن لا تقلق يا OSPF فسنقوم بمساعدتك على فهم هذه ال Routes .

    هذه هي عملة ال Redistribution بإختصار.

    مانفعله هو الذهاب لكل Routing Protocol و ضخ راوترات من Routing Protocol أخر، ولكن لكي نسهل العملية على ال Protocol المراد ضخ البروتوكولات فيه لابد من تغيير خصائص البروتوكول الداخل إليه، ماذا أعني بالخصائص؟؟؟

    الخصائص مثل OSPF لا يفهم ال Metric المستعمل في ال RIP وهو طبعاً ال HUB Count ، وال RIP لا يفهم ال Metric المستعمل في ال OSPF وهو ال Cost ، بمعنى آخر لكل راوتنج بروتوكول مميزات خاصة به لا يفهمها الراوتنج البروتوكول الآخر، من يضع هذه الخصائص هو أنت طبعاً، وبدون هذه الخصائص لن يستطيع أي Routing Protocol أن يترجم أو يفهم ال Routing Protocol الآخر حتى لو كانا معاً يعملان في نفس الرواتر!!!

    عملية ال Redistribution هي العملية التي تسهل عملية الفهم هذه، طبعاً في هذه العملية سنقوم بإخبار كل راوتنج بروتوكول أننا سنضخ بداخله راوتنج بروتوكول أخر مختلف عنه تماماً في الخصائص والمميزات.

    لمن لم يفهم كلمة ضخ فهي تعني Inject أو حقن بالعامية :D

    هذه هي عملية ال Redistribution بكل إختصار.

    تطبيقها سهل جداً وسأعود له لاحقاً بعون الله تعالى.
    CCIE Voice # 26926
    CCIE R&S # loading
    اللهم لك الحمد والشكر حتى ترضى ... ولك الحمد والشكر إن رضيت

  12. #12
    عضو الصورة الرمزية ethical
    تاريخ التسجيل
    Dec 2004
    المشاركات
    332
    معدل تقييم المستوى
    0

    رد: distribute-list,redistribute rip,redistribute ospf

    شكرا يا اخوان علي هذا الموضوع ...

    صاحب الموضوع جزاك الله خير ..

    لومارك ..الله يسهل عليك ان شاء الله ..

    بس هذا الموضوع .. لسي سي ان بي ... ولا شوا اصلا !!!

    لاني خلصت سي سي ان اية ... وما صادفني او اني سهيت عنة !!... ارجو الرد

    وشكرا

  13. #13
    عضو
    تاريخ التسجيل
    Dec 2006
    المشاركات
    171
    معدل تقييم المستوى
    0

    رد: distribute-list,redistribute rip,redistribute ospf

    جزاك أخى الحبيب و معلمى كل خير و منتظر منك المزيد من الشرح فى هذا الموضوع

  14. #14
    عضو
    تاريخ التسجيل
    Feb 2008
    المشاركات
    116
    معدل تقييم المستوى
    0

    رد: distribute-list,redistribute rip,redistribute ospf

    yes this topic in ccna sybex veision 6 routing redestribution

  15. #15
    عضو
    تاريخ التسجيل
    Dec 2006
    المشاركات
    171
    معدل تقييم المستوى
    0

    رد: distribute-list,redistribute rip,redistribute ospf



    اتمنى المزيد أخى

صفحة 1 من 2 1 2 الأخيرةالأخيرة

المواضيع المتشابهه

  1. فيديو خطوات إقامة العلاقااات فى OSPF process / OSPF
    بواسطة noube في المنتدى الأرشيف
    مشاركات: 0
    آخر مشاركة: 27-03-2012, 15:15
  2. ما الفرق بين الامر sh ip access-list و الامر sh access list
    بواسطة Dr Virus.exe في المنتدى الأرشيف
    مشاركات: 2
    آخر مشاركة: 05-07-2011, 21:23
  3. Prefix List Vs Distribute list Vs Offse list Vs Route Map Vs Access List
    بواسطة Brigadier في المنتدى الأرشيف
    مشاركات: 8
    آخر مشاركة: 17-02-2011, 03:50
  4. redistribute static من خلال osp ???افيدوني
    بواسطة omar882 في المنتدى الأرشيف
    مشاركات: 0
    آخر مشاركة: 19-01-2011, 11:56
  5. سؤال في redistribute
    بواسطة يوسف44 في المنتدى الأرشيف
    مشاركات: 2
    آخر مشاركة: 27-06-2010, 15:58

الكلمات الدلالية لهذا الموضوع

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •