النتائج 1 إلى 11 من 11

الموضوع: مشكلة عويصة تطاردني منذ يومين لم أجد الحل مساعدة حول Wan Virtual cloud with Dynamips

  1. #1
    عضو الصورة الرمزية karlot_96
    تاريخ التسجيل
    Dec 2006
    المشاركات
    167
    معدل تقييم المستوى
    0


    السلام عليكم
    بعد البحث في الأنترنيت وجدت في Blindhog.net طريقة كيفية عمل Wan or Internet Virtual Cloud with Dynamips

    بعد أن أعددت صورة الاب الذي أنا بصدد أن أقوم ب إعداده



    صورة الاب http://img514.imageshack.us/img514/3301/problemqg5.jpg



    و بعدها جاءت مرحلة إعداد dot net file of Dynamips

    رابط ملف أعدادات الديناميبس
    http://www.4shared.com/file/54863792...ified=d651b386

    حتى الأن كله تمام

    شغلت الراوترين Router 1 and Router 2



    configuration of Router 1

    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$Ihvg$JsptnFkGzSf30z07qhRp71
    !
    no aaa new-model
    !
    resource policy
    !
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0/0
    ip address 192.168.200.254 255.255.255.0
    full-duplex
    !
    interface Ethernet0/1
    no ip address
    shutdown
    half-duplex
    !
    interface Ethernet0/2
    no ip address
    shutdown
    half-duplex
    !
    interface Ethernet0/3
    no ip address
    shutdown
    half-duplex
    !
    interface Serial1/0
    ip address 192.168.100.1 255.255.255.252
    serial restart-delay 0
    clock rate 2016000
    no dce-terminal-timing-enable
    !
    interface Serial1/1
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    interface Serial1/2
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    interface Serial1/3
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    ip http server
    no ip http secure-server
    !
    ip route 0.0.0.0 0.0.0.0 192.168.100.2
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec s show ip int brief
    !
    !
    line con 0
    exec-timeout 0 0
    password ccna
    logging synchronous
    login
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    password ccna
    logging synchronous
    login
    line vty 5 871
    exec-timeout 0 0
    password ccna
    logging synchronous
    login
    !
    !
    end


    then the configuration of Router 2


    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R2
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$Ihvg$JsptnFkGzSf30z07qhRp71
    !
    no aaa new-model
    !
    resource policy
    !
    memory-size iomem 5
    !
    !
    ip cef
    ip name-server 4.2.2.2
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0/0
    ip address 192.168.1.250 255.255.255.0
    ip virtual-reassembly
    full-duplex
    !
    interface Ethernet0/1
    no ip address
    shutdown
    half-duplex
    !
    interface Ethernet0/2
    no ip address
    shutdown
    half-duplex
    !
    interface Ethernet0/3
    no ip address
    shutdown
    half-duplex
    !
    interface Serial1/0
    ip address 192.168.100.2 255.255.255.252
    ip virtual-reassembly
    serial restart-delay 0
    clock rate 2016000
    no dce-terminal-timing-enable
    !
    interface Serial1/1
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    interface Serial1/2
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    interface Serial1/3
    no ip address
    shutdown
    serial restart-delay 0
    no dce-terminal-timing-enable
    !
    ip http server
    no ip http secure-server
    !
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    ip route 192.168.200.0 255.255.255.0 192.168.100.1
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    alias exec s show ip int brief
    !
    line con 0
    exec-timeout 0 0
    password ccna
    logging synchronous
    login
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    password ccna
    logging synchronous
    login
    line vty 5 871
    exec-timeout 0 0
    password ccna
    logging synchronous
    login
    !
    !
    end


    و بعد ذلك

    قمت بأضافة static Route in DSL ZTE Modem to reach the both of 192.168.200.0 and 192.168.100.0 addresses for i can ping the modem from the router 1 and the loopback 1 interface

    الصورة التالية توضح ذلك



    و هذه صورة ل Static Routing table for DSL modem



    و لكي أوضح لكم الصورة بالنسبة للراوتيج في الراوتران

    ها هي sh ip route output of R1 and R2



    R1#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is 192.168.100.2 to network 0.0.0.0

    C 192.168.200.0/24 is directly connected, Ethernet0/0
    192.168.100.0/30 is subnetted, 1 subnets
    C 192.168.100.0 is directly connected, Serial1/0
    S* 0.0.0.0/0 [1/0] via 192.168.100.2

    ---------------------------------------------------------------------------------------

    R2#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is 192.168.1.1 to network 0.0.0.0

    S 192.168.200.0/24 [1/0] via 192.168.100.1
    C 192.168.1.0/24 is directly connected, Ethernet0/0
    192.168.100.0/30 is subnetted, 1 subnets
    C 192.168.100.0 is directly connected, Serial1/0
    S* 0.0.0.0/0 [1/0] via 192.168.1.1




    بعد الذي عملت في configuration أستطيع

    i can From loopback 1 ping Router 1 , router 2 and DSL modem
    i can from Router 1 ping loopback 1 , Router 2 and DSL modem
    i can from Router 2 ping loopback 1 , Router 1 and DSL modem

    نأتي الأن الى المشكل العويص

    بعد الذي أنا قمت بأعداده

    Router 2 هو الذي بأستطاعته أن يتصل بالأنترنيت فقط
    و كل من PC from loopback interface and the Router 1 have not access to the Internet

    Whyyyyyy ???? i dont know

    ملاحظة ... قمت بتفعيل NAT في DSL Modem و هذا ما يبرر أن Router 2 الذي يحتوي على Private IP بأستطاعته الأتصال بالأنترنيت.(when i remove NAT from DSL Router 2 also hasn't access to internet )

    سوف أظيف بعض المعلومات ربما تساعدكم ر تحليل المشكل و هي Traceroute of Router 1 Router 2 and PC
    هنا نلاحظ ان المشكل يكمن في DSL modem with ip address 192.168.1.1

    Traceroute 4.2.2.2 of Router 2 who has access to internet
    لاحظ الصورة



    traceroute 4.2.2.2 from Router 1
    لاحظ الصورة



    Tracert 4.2.2.2 from the PC
    لاحظ الصورة




    و الله أنى محتار أين هو الخطا و الله اعلم

    أرجو من الأخوة أن يعطونا حل للمشكلة و جزاكم الله خيرا

    انا هنا لأفادتكم ببعض النقاط الغامضة في الاب
    أتمنى اني وفقت في ألحاق المشكلة
    شكرا و السلام عليكم

  2. #2
    عضو الصورة الرمزية karlot_96
    تاريخ التسجيل
    Dec 2006
    المشاركات
    167
    معدل تقييم المستوى
    0

    رد: مشكلة عويصة تطاردني منذ يومين لم أجد الحل مساعدة حول Wan Virtual cloud with Dyna

    please i friend i want the Help please help me for this problem
    CCNA (640-802) in Progress


    We Make The ImpOssble PoSsiBle ..Inshallah..

  3. #3
    عضو
    تاريخ التسجيل
    Apr 2006
    المشاركات
    590
    الدولة: Egypt
    معدل تقييم المستوى
    12

    رد: مشكلة عويصة تطاردني منذ يومين لم أجد الحل مساعدة حول Wan Virtual cloud with Dyna

    ممكن توضح سؤالك أكثر ؟

  4. #4
    عضو الصورة الرمزية karlot_96
    تاريخ التسجيل
    Dec 2006
    المشاركات
    167
    معدل تقييم المستوى
    0

    رد: مشكلة عويصة تطاردني منذ يومين لم أجد الحل مساعدة حول Wan Virtual cloud with Dyna

    يا أخي
    أنا أريد أن الكومبتوتر يعمل أتصال للأنتيرنيت عن طريق loopback و ليس مباشرة بالفيزيكال أنترفيس ... و منه ال Packets تقوم بالمرور من لووباك الى الراوتر 1 ثم عبر السيريال لينك ثم الراوتر 2 ثم تقوم بالخروج من الفيزيكال انترفيس الى DSL modem و الى الأنتيرنت ...
    لقد قمت بالذي ذكرته في الأعلى في اللاب و كل configuration عملتها كويس و الدليل على ذلك ping يعمل بكفاءة جيدة على كل الأجهزة يعني
    من الكومبيوتر أستطيع أن أصل راوتر 1 راوتر 2 و كذلك DSL modem
    من راوتر 1 أستطيع أن أصل ب البينج ل PC راوتر 2 و DSL modem
    من راوتر 2 أستطبع أن أصل راوتر 1 PC and DSL modem
    و من هنا كل شىء جيد..
    و عندما أريد أن أتصل بالأنتيرنيت من الكومبيوتر لا أستطيع ...... و كذلك لا أستطيع أن أتصل بالأنتيرنيت من راوتر 1
    و لاكن أستطيع أن أتصل بالأنتيرنيت من راوتر 2 فقط و الذي هو Directly connected to DSL modem
    المشكل أن لا أستطيع الولوج في الأنتيرنيت من الكوبيوتر عبر loopback interface

    مع العلم ان ظبطت الراوتيج في Router 1 , router 2 and DSL modem بشكل جيد و الدليل على ذلك Ping يعمل بشكل جيد ..

    لقد فعلت كذلك NAT in DSL modem و هو شغال على ما أظن لأن الراوتر 2 الذي يحتوي على Private Ip address يدخل الأنتيرنيت جيدا يعني النات يقوم بعمله

    و الله لم أجد الحل لهذا ....

    لقد قمت ب Traceroute في الراوتر 2 (الوحيد الذي يدخل الأنتيرنيت ) و كانت تصل ل أي بي 4.2.2.2 كما هو موضح في الصورة بشكل جيد

    لقد قمت ب Traceroute في PC to Reach IP 4.2.2.2 و لاكن كان الباكيت يخرج من loopback ثم يذهب ل الراوتر 1 يعني next hop و من ثم عبر serial link between routers ثم يصل الباكيت ل الراوتر 2 و بعد ذلك يصل الى DSL modem و بعدها لايوجد trace للراوت (كما توضحه الصورة ل التراس راوت لل PC ) ( أضن أن Routing على مستوى الأجهزة مطبق بشكل صحيح و هذا ما ترك الباكيت تمر حسب ما أريد أنا يعني جهاز كمبيوتر ----- راوتر 1 ------ راوتر 2 ------ موديم و السؤال لماذا لا يكمل المسار و يكون الأنتيرنيت في جهاز الكومبيوتر و هذا هو سؤالي أين هو الخطأ أو اين هو الحل للمشكلة أو لماذا الباكيت تصل ل DSL modem لا تكمل مسيرها .. علما أن في الراوتر 2 عندما عملت التراس راوت كان جيد حتى الديستانايشن
    أين الخطا ...
    ملاحظة نفس السيناريو عندمات عملت Traceroute في راوتر 1 فأن الباكيت تمشي جيدا نحو راوتر 2 ثم الى DSL modem ثم يصبح الباكيت لا تمكن أن يحول النتيرنيت ... (الصورة التراس راوت ل راوتر 1 توضح ذلك )

    أرجو من الأخوة أن يحللوا معي المشكل من فضلكم
    و أنا هنا لمزيد من التوضيع

    و الله هذا اللاب أصبح لي challange for me و ان شاء الله أتمكن من حله

    شكرا جزيلا و السلام عليكم
    CCNA (640-802) in Progress


    We Make The ImpOssble PoSsiBle ..Inshallah..

  5. #5
    عضو برونزي الصورة الرمزية one-zero
    تاريخ التسجيل
    Jul 2007
    المشاركات
    8,296
    معدل تقييم المستوى
    59

    رد: مشكلة عويصة تطاردني منذ يومين لم أجد الحل مساعدة حول Wan Virtual cloud with Dyna

    حاول تخلي ال default route على الانترقيس المقابل للرواتر كــــ next hop
    و لي سؤال علما اني لم اقراء التهئية بالاعلى هل قمت بتهيئة pppoe على الراوتر المتصل بال dsl modem
    [CENTER][SIZE=4]{[COLOR=red]وَإِذْ يَمْكُرُ بِكَ الَّذِينَ كَفَرُوا لِيُثْبِتُوكَ أَوْ يَقْتُلُوكَ أَوْ يُخْرِجُوكَ وَيَمْكُرُونَ وَيَمْكُرُ اللَّهُ وَاللَّهُ خَيْرُ الْمَاكِرِينَ[/COLOR]}[/SIZE][SIZE=4]…[/SIZE][SIZE=6][SIZE=4](الأنفال:30)
    [URL="http://www.facebook.com/pages/yasserauda/215036411882800"]للتواصل معي عبر الفيس بوك اضغط هنا
    [/URL][URL="http://www.youtube.com/watch?v=37LoZWjv1HE&feature=player_profilepage"][/URL][URL="http://www.facebook.com/pages/yasserauda/215036411882800"] صفحتي الخاصه على الفيس بوك
    [/URL][URL="http://www.facebook.com/pages/Mentored-Learning-New-Horizons-Dubai/234720379925819"]صفحة التعليم الارشادي على الفيس بوك
    [/URL][URL="http://www.youtube.com/user/yasserramzyauda"]قناتي على اليوتيوب
    [/URL][/SIZE][/SIZE][SIZE=3][URL="http://yasserauda.blogspot.com/"]مدونتي الخاصه[/URL][/SIZE][/CENTER]

  6. #6
    عضو الصورة الرمزية karlot_96
    تاريخ التسجيل
    Dec 2006
    المشاركات
    167
    معدل تقييم المستوى
    0

    رد: مشكلة عويصة تطاردني منذ يومين لم أجد الحل مساعدة حول Wan Virtual cloud with Dyna

    يا أخي وبو شكرا جزيلا على الرد

    بالطبع عملت PPPOE على الموديم و هو شغال بكفائة بما أن الراوتر 2 يتصل بالأنتيرنيت ..

    و بخصوص ال default route على أي جهاز أقوم بتطبيقها

    شكرا يا أخي أتمنى الرد و المناقشة
    CCNA (640-802) in Progress


    We Make The ImpOssble PoSsiBle ..Inshallah..

  7. #7
    عضو الصورة الرمزية karlot_96
    تاريخ التسجيل
    Dec 2006
    المشاركات
    167
    معدل تقييم المستوى
    0

    رد: مشكلة عويصة تطاردني منذ يومين لم أجد الحل مساعدة حول Wan Virtual cloud with Dyna

    ألووو أين المساعدة
    CCNA (640-802) in Progress


    We Make The ImpOssble PoSsiBle ..Inshallah..

  8. #8
    عضو الصورة الرمزية karlot_96
    تاريخ التسجيل
    Dec 2006
    المشاركات
    167
    معدل تقييم المستوى
    0

    رد: مشكلة عويصة تطاردني منذ يومين لم أجد الحل مساعدة حول Wan Virtual cloud with Dyna

    أين أنتم يا أحبة

    أين أنتم يا أخوة لومارك محمد سمير وبو قاهري ساعدوني يا أحبة أني لا أنام الليل من أجل هذا اللاب
    شكرا مسبقا
    CCNA (640-802) in Progress


    We Make The ImpOssble PoSsiBle ..Inshallah..

  9. #9
    عضو
    تاريخ التسجيل
    Apr 2006
    المشاركات
    590
    الدولة: Egypt
    معدل تقييم المستوى
    12

    رد: مشكلة عويصة تطاردني منذ يومين لم أجد الحل مساعدة حول Wan Virtual cloud with Dyna

    على ما أظن أن المشكلة تتعلق بسبب عدم ربط ADSL Modem حقيقة مع الرواتر وبالتالي لا يستطيع الراوترات الأخرى أن تصل إليه

  10. #10
    عضو الصورة الرمزية karlot_96
    تاريخ التسجيل
    Dec 2006
    المشاركات
    167
    معدل تقييم المستوى
    0

    رد: مشكلة عويصة تطاردني منذ يومين لم أجد الحل مساعدة حول Wan Virtual cloud with Dyna

    شكرا يا أخي MaaM
    من فضلك حاول أنت أن تعمل اللاب و قل لي كيف صار معك
    شكرا مسبقا
    CCNA (640-802) in Progress


    We Make The ImpOssble PoSsiBle ..Inshallah..

  11. #11
    عضو
    تاريخ التسجيل
    Apr 2006
    المشاركات
    590
    الدولة: Egypt
    معدل تقييم المستوى
    12

    رد: مشكلة عويصة تطاردني منذ يومين لم أجد الحل مساعدة حول Wan Virtual cloud with Dyna



    علمته منذ أن عرضت الطبولوجي في المشاركة الأولى وحدث معي مثل ما حدث معك
    وما ذكرته لك هو السبب الرئيسي في ظني حالياً

المواضيع المتشابهه

  1. مشكله في ربط dynamips ب virtual m/c
    بواسطة diligent1 في المنتدى الأرشيف
    مشاركات: 4
    آخر مشاركة: 23-07-2010, 13:39
  2. نقل دومين من ماينه real إلى virtual
    بواسطة mfarouk7900 في المنتدى منتدى الشهادات العام
    مشاركات: 2
    آخر مشاركة: 22-05-2010, 11:12
  3. مشكلة عويصة ارجو منكم الحل
    بواسطة fantomswar في المنتدى السوفتوير العام
    مشاركات: 2
    آخر مشاركة: 15-10-2009, 23:16
  4. مشاركات: 8
    آخر مشاركة: 17-10-2005, 07:53
  5. مشاركات: 3
    آخر مشاركة: 08-12-2003, 01:24

الكلمات الدلالية لهذا الموضوع

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •