صفحة 1 من 2 1 2 الأخيرةالأخيرة
النتائج 1 إلى 15 من 29

الموضوع: درس فى الحماية (security (CCNA

  1. #1
    عضو
    تاريخ التسجيل
    Apr 2008
    المشاركات
    124
    معدل تقييم المستوى
    0

    درس فى الحماية (security (CCNA



    السلام عليكم ورحمة الله وبركاته
    كيف الحال ان شاء الله تكونوا بخير ان شاء الله هنتكلم عن الحماية و كل شئ يتعلق بيها فى نطاق ال ccna وبره ال ccna بس بشوية صغيرة

    1-console connections
    2-vty connections
    3- user name + password
    4-http server
    5-pap & chap authentication


    اولا ال console port يجب وضع كلمة سر على console port لكى لا يستخدم اى فرد ال console cable ويدخل على الروتر ويغير الكنفوجريشن فى الروتر

    Router#conf t
    Router(config)#line console 0
    Router(config-line)#password cisco
    Router(config-line)#login

    وبكده نكون حطينا اول بسورد على الروتر وكلمة login مهمة جدا من غيرها الامر ميشتغلش

    2- الvty وهيه اختصار لكلمة Virtual TeletYpe interface وده لو عشان عاوز تتصل على الروتر على برنامج الtelnet وحسب كل روتر ممكن يفتح كام session يعنى لو الروتر عندك بيفتح 15 session
    يبقى ممكن تخلى 15 فرد يعملوا telnet على الروتر فى وقت واحد طيب لو انتا مش عاوز تفتح غير 1 session او اى عدد انتا عوزه حسب طلبك نفذ الامر وطبعا ال vty بتسهل علينا الاتصال بالروتر من اى مكان فى الشبكة الداخلية او حتى عن طريق الانترنت

    Router#conf t
    ؟ Router(config)#line vty
    <0-15> First Line number
    Router(config)#line vty 0 2
    Router(config-line)#password cisco
    Router(config-line)#login

    3- user name + password
    اكيد اى فرد ممكن يدخل على الروتر ويغير فى الكونفجريشن لزم يكون ليه اسم مستخدم وكلمة سر سيسكوا عملة حاجة حلوه اوى وهيه مستوى دخول لكل مستخدم زى مثلا فى الويندوز عندنا ال user - power user - administrator سيسكوا عملة جده برده بس بقى عملتها ازاى عندنا حاجة اسمها مستويات من المستوى 0 الى حد المستوى 15 طبعا الى ياخد مستوى 15 ده هوه المدير وكل ما قل المستوى قلة صلاحيات المستخدم


    ؟ Router(config)#username melshare privilege
    <0-15> User privilege level
    Router(config)#username melshare privilege 15 password cisco
    يــــــــــــــــــــــتــــــــــــــــــبع

  2. #2
    عضو
    تاريخ التسجيل
    Apr 2008
    المشاركات
    124
    معدل تقييم المستوى
    0

    رد: درس فى الحماية (security (CCNA

    4-http server
    ده لو انتا حبيت تدخل على الكونفجريشن بتاعة الروتر بتاعتك بس من على الويب
    وتغير فيها
    Router#conf t
    Router(config)#ip http server
    Router(config)#ip http authentication local

    كده نكون عملنا السيرفر وقلنا للروتر لما تحب تتئكد من اسم المستخدم و كلمة السر اكد عليهم من خلال البيانات الموجودة فى الروتر
    يعنى لزم يكون فيه اسم مستخدم وكلمة سر فى الروتر

  3. #3
    عضو برونزي الصورة الرمزية one-zero
    تاريخ التسجيل
    Jul 2007
    المشاركات
    8,296
    معدل تقييم المستوى
    59

    رد: درس فى الحماية (security (CCNA

    معلومات رائعة وعلشان نكملها صح لدارسي ال ccna

    هناك كلمة سر اساسية من اجل الانتقال من user mode الي prividge mode يمكن عملها و هي :
    Router(config)#enable password
    وستخزن كلمة السر هنا غير مشفرة في ملف ال start
    اما لتخزينها مشفرة نستخدم بدل الامر السابق الامر التالي:
    Router(config)#enable secret
    وسيشفر البيانات او بمعنى اخر سيتم عمل هاش لها hash من نوع MD5

    اخيرا كلمات السر السابقة الخاصة بالكونسول و التلنت والتي قام بها الاخ m el shere يمكن تشفيرها بالامر
    Router(config)#service password-encryption

    والتي تستخدم طريقة تشفير ضعيفة نسمبها Vengere يمكن فكها و كسرها ببرنامج getpass من شركة boson
    [CENTER][SIZE=4]{[COLOR=red]وَإِذْ يَمْكُرُ بِكَ الَّذِينَ كَفَرُوا لِيُثْبِتُوكَ أَوْ يَقْتُلُوكَ أَوْ يُخْرِجُوكَ وَيَمْكُرُونَ وَيَمْكُرُ اللَّهُ وَاللَّهُ خَيْرُ الْمَاكِرِينَ[/COLOR]}[/SIZE][SIZE=4]…[/SIZE][SIZE=6][SIZE=4](الأنفال:30)
    [URL="http://www.facebook.com/pages/yasserauda/215036411882800"]للتواصل معي عبر الفيس بوك اضغط هنا
    [/URL][URL="http://www.youtube.com/watch?v=37LoZWjv1HE&feature=player_profilepage"][/URL][URL="http://www.facebook.com/pages/yasserauda/215036411882800"] صفحتي الخاصه على الفيس بوك
    [/URL][URL="http://www.facebook.com/pages/Mentored-Learning-New-Horizons-Dubai/234720379925819"]صفحة التعليم الارشادي على الفيس بوك
    [/URL][URL="http://www.youtube.com/user/yasserramzyauda"]قناتي على اليوتيوب
    [/URL][/SIZE][/SIZE][SIZE=3][URL="http://yasserauda.blogspot.com/"]مدونتي الخاصه[/URL][/SIZE][/CENTER]

  4. #4
    عضوية جديدة
    تاريخ التسجيل
    Jul 2008
    المشاركات
    34
    الدولة: Egypt
    معدل تقييم المستوى
    0

    رد: درس فى الحماية (security (CCNA

    ألف شكر على الشرج الجميل
    ربنا يقدرك وتكمل.
    ياريت لو تعرف مكان شرح لل WAN
    أو تشرحه أكون شاكر جدا

  5. #5
    عضو برونزي الصورة الرمزية Nightspy
    تاريخ التسجيل
    May 2007
    المشاركات
    1,573
    معدل تقييم المستوى
    12

    رد: درس فى الحماية (security (CCNA

    معلومات رائعة وعلشان نكملها صح لدارسي ال ccna

    هناك كلمة سر اساسية من اجل الانتقال من user mode الي prividge mode يمكن عملها و هي :
    Router(config)#enable password
    وستخزن كلمة السر هنا غير مشفرة في ملف ال start
    اما لتخزينها مشفرة نستخدم بدل الامر السابق الامر التالي:
    Router(config)#enable secret
    وسيشفر البيانات او بمعنى اخر سيتم عمل هاش لها hash من نوع MD5

    اخيرا كلمات السر السابقة الخاصة بالكونسول و التلنت والتي قام بها الاخ m el shere يمكن تشفيرها بالامر
    Router(config)#service password-encryption

    والتي تستخدم طريقة تشفير ضعيفة نسمبها Vengere يمكن فكها و كسرها ببرنامج getpass من شركة boson


    وتكمله لتكملة الاخ العزيز ياسر رمزى

    من الممكن بدل الدخول للكونسول باستخدام الباسورد فقط يمكنك استخدام اسم مستخدم وكلمة مرور

    اليك الاتى

    Router(config)#username ahmed password ccna
    Router(config)#line console 0
    Router(config-line)#login local

    وكل عام وانتم بخير
    [SIZE=1][B][B]..||..[/B][/B][/SIZE][SIZE=1][B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=125858"]حمل جميع محاضرات احمد نبيل R&S من رفعى[/URL]..||..[/B][/B][B][B][COLOR=Red][URL="http://www.arabhardware.net/forum/showthread.php?t=119516"]شرح IS-IS[/URL][/COLOR]..||..[/B][/B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=108310"][B]شرح IPv6,OSPFv3 [/B][/URL][B]..||..[URL="http://www.arabhardware.net/forum/showthread.php?t=108310"].[/URL][/B][/B][URL="http://www.arabhardware.net/forum/showthread.php?t=100662"][B]شرح كامل للOSPF[/B][/URL][B][B]..||..[/B][/B][URL="http://www.arabhardware.net/forum/showthread.php?t=91625"][B]حصريا شرح الEigrp[/B][/URL][B][B]..||..[/B][/B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=93682"]كن خبير لتحليل ترافيك شبكتك مع شرحWireShark[/URL][/B][B][B]..||..[/B][/B][URL="http://www.arabhardware.net/forum/showthread.php?t=94484&highlight=iptv"][B]مقال عن تقنية الIPTV[/B][B][B]..||..[/B][/B][/URL][B][URL="http://www.arabhardware.net/forum/showthread.php?t=93854"]جميع اوامر الروتنجIOS[/URL][/B][B][B]..||..[/B][/B][B][URL="http://www.arabhardware.net/forum/showthread.php?t=94813"]أفضل برنامج لرسم وتخطيط الشبكات وبدون تنصيب[/URL][/B][B][B]..||..

    [/B][/B] [URL="http://badr-call-manager.blogspot.com/"][IMG]http://muslimtech.files.wordpress.com/2010/06/blog-badr-banner.jpg[/IMG][/URL]
    [URL="http://mohammad.islamway.com/"][B]سيرة أشرف من مس هذا الكوكب بقدمه وبجميع اللغات[/B][/URL]

    [/SIZE]

  6. #6
    عضو الصورة الرمزية binhadi-1
    تاريخ التسجيل
    May 2008
    المشاركات
    263
    معدل تقييم المستوى
    0

    رد: درس فى الحماية (security (CCNA

    شكرا يجماعه علي اشرح الجميل
    hadi

  7. #7
    عضو فضي الصورة الرمزية محمد مندور
    تاريخ التسجيل
    Feb 2008
    المشاركات
    527
    الدولة: Egypt
    معدل تقييم المستوى
    10

    رد: درس فى الحماية (security (CCNA

    ماشاء الله تضافر جهود الإخوة........بارك الله فيكم
    إذا غـامَــرْتَ فِي شَـرَفٍ مَـرُومِ *** فَـــلا تَقنَــعْ بِـمَـا دونَ النّـجـــومِ

    فطَـعْـمُ المَـوْتِ فِي أمْـرٍ حَقِيـرٍ *** كطَعْـمِ المَـوْتِ فِي أمْـرٍ عَظيـمِ


    FB: https://www.facebook.com/Firststep2020
    [SIGPIC][/SIGPIC]

  8. #8
    عضو
    تاريخ التسجيل
    Apr 2008
    المشاركات
    124
    معدل تقييم المستوى
    0

    رد: درس فى الحماية (security (CCNA

    الحمد لله الذى قدرنا على ان نكمل بعضنا البعض وان شاء الله ده يفضل موجود على طول
    طيب بعد ما عملنا كل الخطوات الى فاتت ممكن نتفرج على الكونفجريشن بتاعة الروتر شكلها ازاى
    بس هنتفرج عليها مرتين مره قبل الامر enable secret و الامر service password-encryption
    ومره بعد مانشغلهم

    قــــــــــــــــــــــــــــــــــــبل
    enable password cisco
    !
    username arab password 0 cisco
    !
    !
    ip classless
    !
    line con 0
    password cisco
    login
    line vty 0 4
    password cisco
    login
    line vty 5
    password cisco
    login
    بـــــــــــــــــــــــــــــــــــــــعد

    service password-encryption
    !
    enable secret 5 $1$mERr$qxlNnEU53UUzjboDLhs1s0
    enable password 7 0822455D0A16
    !
    username arab password 7 0871141C5B4D5042365B2D557C
    !
    line con 0
    password 7 0822455D0A16
    login
    line vty 0 4
    password 7 0822455D0A16
    login
    line vty 5
    password 7 0822455D0A16
    login

    طبعا فرق جامد جدا لما تكون كل حاجة متشفرة على فكرة كل الى حصل ان شغلنا الامر ده service password-encryption وعملنا بسورد كمان الى هيه enable secret عشان الدخول على الرورتر كده تمام اوى اعتقد ان كده امان للروتر بعد كل التشفير ده

    يـــــــــــــــــــــــــــــــــــــــــــــــــ ـــتبع

  9. #9
    عضو
    تاريخ التسجيل
    Apr 2008
    المشاركات
    124
    معدل تقييم المستوى
    0

    رد: درس فى الحماية (security (CCNA

    اخيار نتكلم عن نظام الحماية عندما نربط روترين ببعض اذاى نخلى الروترات تتئكد ان المعلومات
    هتوصل متشفرة وان الروتر الى بنرسل اليه ونستقبل منه هوه الروتر الصحيح
    اولا نتكلم عن البرتوكول (PAP)
    او اختصار الى Password Authentication Protocol


    لو انتا عندك عدد 2 روتر فى كل فرع روتر بتعت وتستقبل منه الداتا بتعتك اكيد لزم تحاول تأمن البيانات باى شكل عشان تتئكد ان محدش يقدر يوصلها وهيه مشيه فى الطريق طيب البرتوكول
    PAP هيعمل حماية للداتا بس بطريقة سهلة شوية عندما ترسل الداتا الى الروتر الاخر هيسئله
    يقله ميين الى باعة الداتا الروتر التانى هيقله انا فلان الفلانى و البسورد بتاعتى اهيه ويقوم
    الروتر الى بيرسل يبعت اسم المستخدم وكلمة السر للروتر الى طلبهم بس المشكلة انه بيعتهم
    بطريقة مفيهاش اى نوع من انواع التشفير وبيكونا وضحين اما البرتوكول الثانى chap بيعمل
    عكس كده خالص بيبعتله الاول كلمة السر متشفره + مفتاح فك الشفرة لو الروتر التانى وصله مفتاح فك تشفير و كلمة السر يقوم عامل ايه مدخل فتاح فك الشفرة ده فى معادلة المعادلة ديه مكونه من 5 معادلات اذا قدر يحلها يقوم واخد الحل وفاكك بيه الشفرة بتاعة كلمة السر مهيه كلمة السر اساسا هيه كمان مبعوته متشفرة بس تخيل بقى انه بيعمل كده 5 مرات يعندى بيبعت 5 مفاتيح فك شفرة عشان يتئكد ان الروتر التانى هو المطلوب .


    طيب نيجى بقى ونقول تانى ان ال PAP و ال chap والى هيه اختصار لكلمة
    Challenge-Handshake Authentication Protocol
    يعنى التحدى و المصافحة اسم جامد برده الاثتنين دول معمولين عشان يأمنوا ان الاطراف الى بتكلم مع بعضها هيه الاطراف الصحيحة والمطلوب الارسال و الاستقبال منها

    ندخل بقى على الكونفجريشن
    يتــــــــــــــــــــــــــــــــــــــــــــــــ ــــــــــبع

  10. #10
    عضو
    تاريخ التسجيل
    Apr 2008
    المشاركات
    124
    معدل تقييم المستوى
    0

    رد: درس فى الحماية (security (CCNA

    الاول انا هعمل الكونفجريشن على 2 روتر عشان الى عاوز يجرب وهستخدم برنامج Packet Tracer 5.0
    طيب تمام اوى بس فيه حاجة نقولها كمان ان الاتنين دول PAP & chap لزم يشتغلوا ما نظام
    ربط يعنى ايه ربط يعنى زى بروتكول PPP
    Point-to-Point Protocol
    PPP لما تكون رابط بين روترين عن طريق السريل هنا نشغل ال PPP
    طيب الكونفجريشن هيكون عامل ازاى اولا لزم نتئكد ان الكونفجريشن ده هيكون على الاثنين روتر ويكون على الانترفيس السريل تمام طيب لو مكنش الاثنين روتر الكونفجريشن الخاصة بى ال pap او ال chap زى بعض ايه الى هيحصل الى هيحصل ان الورترات مش هتقدر تكلم بعض
    و لا حتى هيقدروا يعملوا بينج على بعض

    Router(config)#int s1/0
    Router(config-if)#encapsulation ppp
    Router(config-if)#ppp pap sent-username cisco password cisco

    Router(config-if)#ppp authentication pap
    فاضل بقى ان نضيف اسم مستخدم وبسورد لكل روتر عند الروتر التانى زى اماره او علامة
    Router(config)#username cisco password cisco
    دخلنا الاول على الانترفيس السريل وادنلها ip address وبعدين عملنا الخطوات بتعاتنا على الروتر الاول وده شكل ال show run for serial 1/0
    interface Serial1/0
    ip address 192.168.1.1 255.255.255.0
    encapsulation ppp
    serial restart-delay 0
    ppp authentication pap
    ppp pap sent-username cisco password 0 cisco
    طيب الروتر النحية التنيه هكون الكونفجريشن عامل ازى

    interface Serial1/0
    ip address 192.168.1.2 255.255.255.0
    encapsulation ppp
    serial restart-delay 0
    ppp authentication pap
    ppp pap sent-username cisco password 0 cisco

    لزم نتئكد ان الكونفجريشن الخاصة بى الpap موجودة فى الطرفين

    ولزم يكون فيه اسم مستخدم وبسورد زى بعض فى النحتين

  11. #11
    عضو فضي الصورة الرمزية hisham_munshar
    تاريخ التسجيل
    Nov 2006
    المشاركات
    2,595
    الدولة: Palestinian Territory
    معدل تقييم المستوى
    14

    رد: درس فى الحماية (security (CCNA

    مشكور و بالتوفيق

  12. #12
    عضو الصورة الرمزية hamidh
    تاريخ التسجيل
    Jul 2007
    المشاركات
    320
    معدل تقييم المستوى
    0

    رد: درس فى الحماية (security (CCNA

    الله يعطيكم العافية جميعا

    قمه في الروعة .. بالتوفيق لي ولكم

  13. #13

  14. #14
    عضو الصورة الرمزية المستعصم بالله
    تاريخ التسجيل
    Dec 2007
    المشاركات
    421
    معدل تقييم المستوى
    11

    رد: درس فى الحماية (security (CCNA

    شرح ممتاز بارك الله فيك وفى انتظار مشاركات الجميلة دايما
    ( اللهم انفعنا بما علمتنا وعلمنا ما ينفعنا )

    ( اللهم صلى وسلم على سيدنا محمد وعلى أله وصحبه أجمعين )

    previously Mr Mac

  15. #15
    عضو برونزي
    تاريخ التسجيل
    Apr 2008
    المشاركات
    1,430
    معدل تقييم المستوى
    11

    رد: درس فى الحماية (security (CCNA



    جزاك الله خيرا اخى الكريم

صفحة 1 من 2 1 2 الأخيرةالأخيرة

المواضيع المتشابهه

  1. CCNA , CCNA Voice , CCNA security , CCDA , CCNP, System engineer بفضل الله
    بواسطة Mohammed Kasim في المنتدى الأرشيف
    مشاركات: 0
    آخر مشاركة: 13-05-2012, 12:03
  2. الحماية من الفيروسات فيس بوك و تويترTitanium Maximum Security 2012
    بواسطة mattosh في المنتدى السوفتوير العام
    مشاركات: 0
    آخر مشاركة: 18-12-2011, 03:09
  3. مشكلة فى برنامج الحماية Microsoft Security Essential
    بواسطة miro the king في المنتدى مشاكل الحاسب وحلولها
    مشاركات: 4
    آخر مشاركة: 25-08-2010, 05:21
  4. انفراد جديد مع صاروخ الحماية Kaspersky Internet Security
    بواسطة oneduff في المنتدى السوفتوير العام
    مشاركات: 4
    آخر مشاركة: 03-04-2007, 03:22

الكلمات الدلالية لهذا الموضوع

المفضلات

ضوابط المشاركة

  • لا تستطيع إضافة مواضيع جديدة
  • لا تستطيع الرد على المواضيع
  • لا تستطيع إرفاق ملفات
  • لا تستطيع تعديل مشاركاتك
  •